This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Macman

Membres
  • Compteur de contenus

    13
  • Inscription

  • Dernière visite

À propos de Macman

  • Rang
    Initié

Visiteurs récents du profil

667 visualisations du profil
  1. Je n'ai pas réussi à m'en sortir, j'ai donc tout remis à zéro, et là cela fonctionne de nouveau. Le sujet peut être fermé, merci de m'avoir lu !
  2. Bonjour à tous, Depuis le dernier redémarrage de mon Nas (DS413, en DSM 6 dernière version) ce weekend suite à une coupure de courant (arrêté proprement grâce à mon onduleur) , tous mes domaines sont redirigés systématiquement vers mon dsm. Ex : http://www.monsite.fr, ou http://www.monsite.fr/mail sont redirigés vers http://www.monsite.fr:5000. Seuls mes domaines qui pointent vers sickbeard, sabnzbd ou mes autres sites utilisant des ports différents du 80/443 fonctionnent correctement. En essayant http://www.monsite.fr:80 je suis redirigé vers http://www.monsite.fr:5000. Bien évidemment je n'ai rien touché au niveau de Webstation et j'ai bien toutes mes redirections vers les bons répertoires (ex : web/WordPress avec 80/443). J'ai mis à jour mon Nas avec la dernière version, j'ai arrêté/mis à jour/redémarré WebStation et rien ne semble avoir changé. Est-ce que cela vous est déjà arrivé ? Auriez-vous des pistes ? Merci à vous !
  3. Macman

    Utiliser Pypdf Sur Synology

    Merci Diaoul !
  4. Macman

    Utiliser Pypdf Sur Synology

    Bonsoir à tous, Je cherche à faire fonctionner un script qui utilise pypdf sur mon DS413 (DSM 5, paquet python 2.7.8-11 par synocommunity) A noter que mon script fonctionne très bien sur windows (python 2.7, PIL 1.1.7 et pypdf 1.7). Je vous avoue que c'est la première fois que j'ajoute un package python supplémentaire sur mon syno. J'ai récupéré le package ici : https://code.google.com/p/pyfpdf/ J'aurais aimé déposer le package dans /usr/local/python/lib/python2.7/sites-packages (pour faire comme je fais d'habitude sur windows) mais je n'ai pas trouvé comment faire. Du coup je l'ai déposé dans le dossier /volume1/web/python/ et j'ai lancé l'install avec la commande suivante : /usr/local/python/bin/python setup.py install A priori ça s'est bien passé, je me surprends agréablement à retrouver les fichiers dans "/usr/local/python/lib/python2.7/sites-packages". Arrive alors le premier test, génération d'un fichier pdf basique, cela fonctionne et j'ai un joli fichier PDF. Deuxième test, ajout d'une image au format "jpg", et là ça coince : /usr/local/python/bin/python /volume1/web/python/ndfpdf/test.py Traceback (most recent call last): File "/volume1/web/python/ndfpdf/test.py", line 33, in <module> pdf.add_page() File "/usr/local/python/lib/python2.7/site-packages/fpdf/fpdf.py", line 284, in add_page self.header() File "/volume1/web/python/ndfpdf/test.py", line 11, in header this.image('logo_small.jpg',10,8,33) File "/usr/local/python/lib/python2.7/site-packages/fpdf/fpdf.py", line 894, in image info=self._parsejpg(name) File "/usr/local/python/lib/python2.7/site-packages/fpdf/fpdf.py", line 1589, in _parsejpg self.error('PIL not installed') File "/usr/local/python/lib/python2.7/site-packages/fpdf/fpdf.py", line 221, in error raise RuntimeError('FPDF error: '+msg) RuntimeError: FPDF error: PIL not installed PIL not installed, dammit, pourtant j'ai bien PIL, je l'utilise dans d'autres scripts. Après un coup d'oeil avec vi dans le fichier fpdf.py : from datetime import datetime import math import errno import os, sys, zlib, struct, re, tempfile, struct try: import cPickle as pickle except ImportError: import pickle try: # Check if PIL is available, necessary for JPEG support. import Image except ImportError: Image = None Si vous avez une piste, cela m'arrangerait bien De façon plus générale, connaissez vous une méthode plus propre pour installer un package ? Merci à vous
  5. Macman

    Probl

    J'ai effectué un reset et le problème est résolu.
  6. Macman

    Probl

    Bonjour, Depuis que j'ai mis à jour le paquet phpmyadmin, je n'arrive plus à accéder à l'interface DSM de mon nas via le port . Pour accéder à mon nas de l'extérieur j'utilise des sous domaines avec utilisation du fichier vhost: /usr/syno/etc/httpd-vhost.conf-user. /usr/syno/etc/httpd-vhost.conf-user : Include /usr/syno/etc/httpd-proxy-vhost.conf-user avec /usr/syno/etc/httpd-proxy-vhost.conf-user : LoadModule proxy_module modules/mod_proxy.so LoadModule proxy_connect_module modules/mod_proxy_connect.so LoadModule proxy_http_module modules/mod_proxy_http.so NameVirtualHost *: <VirtualHost *:> ServerName * DocumentRoot /var/services/web </VirtualHost> <VirtualHost *:> ServerName dsm.XXXXXXX.fr ProxyRequests Off ProxyVia Off <Proxy *> Order deny,allow Allow from all </Proxy> ProxyPass / http://localhost:5000/ ProxyPassReverse / http://localhost:5000/ <Location /> Order allow,deny Allow from all </Location> </VirtualHost> J'ai tenté un restore de mes paramètres, ce qui n'a rien donné (le restore a effacé le contenu de mon fichier vhost, auquel j'ai ajouté la ligne d'include du fichier httpd-proxy-vhost.conf-user). Avez vous rencontré le même problème ? Je pense effectuer un reset, comme indiqué dans ce post en espérant que cela fonctionne mais j'aurais préféré trouver une solution moins radicale. Merci à vous !
  7. Macman

    Dlna Ne Fonctionne Plus

    Tu peux aussi vérifier au niveau de ton parefeu si les ports idoïnes sont bien ouverts.
  8. Macman

    Syno 213 Comme 1Ere Exp

    Pas de soucis pour les films HD via le CPL, sous réserve que ton réseau électrique soit pas trop mal foutu. J'ai eu des soucis avec des prises CPL 500, mon réseau éléctrique était trop vieux, je n'ai plus de soucis depuis que j'ai des 200.
  9. Macman

    Syno 213 Comme 1Ere Exp

    Hello, J'avais à peu près le même besoin que toi et après mûre réflexion j'ai fini par : - brancher mon NAS (212J) directement sur ma box (sfr) avec un câble droit - relier la box avec ma TV Samsung via prise CPL J'ai un ordinateur relié en RJ45 avec la box, d'autres connectés en wifi. Tous ont accès au NAS sans problème. Le backup de mes disques s'effectue très simplement, il y a divers packages pour cela ou la commande "rsync". Je te rassure, tu n'as pas besoin de beaucoup de connaissances pour arriver au bout
  10. Macman

    Choix Entre Nas Ds212J, Ds212, Ds212+ Et Ds213

    Hello, Pour ma part je possède un DS212J (il y a maintenant 1 an et demi). Je m'en sers pour stocker des films (afin de les lire à partir de ma TV), rsync, python et d'autres applications légères. J'ai installé le DSM 4.2 sans problème. Deux problèmes mineurs que je n'aurais pas eu si j'avais acheté un DS213 : - port usb3 absent pour les x12 (ce qui ne me gênait pas avant que l'on m'offre un DD externe 1To USB3) - certains formats video non lisibles sur macbook pro à partir du DS212j Remarque : Si mon DS212J venait à planter, j'achèterais probablement un DS213+ (mais c'est un autre budget j'en conviens).
  11. Macman

    Ds212J : Raid 1 Et Backup

    Merci pour ton retour Lurik, c'est bien ce que je pensais. Je vais opter pour la solution du DD2 en USB Il ne me reste plus qu'à enlever le raid 1 sur mes deux disques, je vais me ballader sur le forum y'aura sûrement un tuto ! Merci !
  12. Bonjour à tous, Je possède un ds212j, dans lequel j'ai installé 2 disques durs identiques (WD Caviar green 1To, DD1 et DD2), montés en raid 1. Je ne possède pas d'onduleur et d'après ce que j'ai pu comprendre, si j'ai un problème, il y a de fortes chances pour que mes deux disques durs fassent la tronche en même temps (dates d'achat des deux DD espacées de 6 mois volontairement). Je cherche à faire en sorte qu'un seul des deux disques ne soit utilisé (essentiellement pour le serveur multimédia), et que l'autre ne soit allumé qu'une fois par mois pour effectuer un backup. J'avais pensé (dans mes rêves les plus fous) qu'il serait probablement possible d'utiliser un crontab pour éteindre mon DD2, le rallumer à une date précise, effectuer le backup (en le laissant faire grâce au raid 1, comme par "magie", ou un rsync tout autant magique) puis l'éteindre ? Je vous soumets plusieurs questions : 1) Le raid 1, que j'avais choisi au début pour faire du simili-backup (j'insiste sur le "simili" car j'avais bien conscience qu'il ne s'agit pas de backup, j'avais envie d'essayer), est il adapté pour ma situation ? 2) Ne ferais je pas mieux d'oublier le raid 1, brancher l'un de mes deux disques en USB (avec un adaptateur sata-usb) et de faire ainsi un backup à la fréquence souhaitée avec l'un des paquet proposé par syno ? Ce serait quand même dommage de ne pas utiliser les deux slots offerts par le ds212j et de passer par USB. Merci d'avance pour vos retours !
  13. Macman

    Subliminal

    Hello ! J'ai le même problème qu'alantya, ma TV ne lit les sous titres que si le renommage est exact. My 50 cents : cd nomdulecteur/nomdudossier FOR /f "tokens=*" %d in ('dir "*.fr.srt" /a-d/b/s ') DO REN "%d" *. FOR /f "tokens=*" %d in ('dir "*.fr" /a-d/b/s ') DO REN "%d" *.srt C'est clairement pas optimisé mais ça renomme les fr.srt en .srt dans tous les dossiers et sous dossiers, si ça peut aider quelqu'un. (Si vous préférez un faire un .bat, n'oubliez pas de remplacer %d par %%d). Au passage merci à toi Diaoul, ton travail déchire.