This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

amemo06

Membres
  • Compteur de contenus

    22
  • Inscription

  • Dernière visite

À propos de amemo06

  • Rang
    Initié
  • Date de naissance 11/09/1969

Profile Information

  • Gender
    Male
  1. Salut, je viens de passer une petite après-midi sur ce sujet qui me casse les pieds depuis fort longtemps mais qui vient de trouver une solution. Je m’apprêtais à ouvrir un post dédié à la visibilité d'un NAS sur un réseau local. @loicb Malheureusement, ce qui suit peux ne pas être une réponse qui s'applique à ton cas. Mais pour moi, ça a été la solution... Dans mon cas, le Synology fait entre autre office de DNS, serveur DHCP, partage de fichiers Windows, NFS. Pas d'Apple Sur le réseau, il y a un routeur multi Wan et quelques switch, 1 point d'accès wifi et un répéteur wifi (quelque saleté celui-là). Depuis fort longtemps, certaines machines historiques ne voient pas le NAS alors que les nouvelles le voit ! Le point commun de la plupart des machines nouvelles, principalement des laptops, c'est qu'elles se connectent en Wifi et par conséquent (bien que pas obligatoire) ont une adresse attribué par le NAS en DHCP. Toutes les machines historiques, elles, ont une adresse IP fixe. Toutes les machines sont sur le même groupe de travail. Pour les machines historique en IP fixe, j'ai tout essayé sans succès ou presque. A savoir, que si je passe ces vieilles machines en DHCP, là, surprise, le NAS apparaît immédiatement. Ce qui m’amène à 'ma' solution. Il m'a suffit redéfinir la machine en 'Réseau domestique' A savoir sur Windows 7 d'aller dans Panneau de configuration, Réseau et internet, et forcer le changement de réseau domestique/privé/public. J'aimerai fournir un 'pas à pas'. Mais je n'y arrive plus. Peut être dans un prochain post. Ce qui est sur dans mes étapes. * Casser la connecxion. Passer en DHCP ou autre. -->Si passage en DHCP, le NAS est de retour * Recréer la connexion en IP fixe. -->Le NAS n'est plus visible dans le voisinage réseau mais accessible sans problème //NAS... * Passer en réseau domestique. -->Retour du NAS Bon courage
  2. Recherche BT renvoie 'Echec de l'opération'

    Bon, sans explication ça s'est mis à fonctionner ! Pas de mise à jour, pas de reboot. Juste ça fonctionne aujourd'hui tout comme sur l'ancien NAS qui lui fonctionnait déjà.
  3. Sur mon beau synology ton neuf et fraichement installé, Quelque soit la recherche, j'obtiens uniquement 'Echec de l'opération'. Et avec l'application DSDownload, j'obtiens parfois des résultats. A noter que sur mon vieux Synology, la recherche fonctionne parfaitement. Et les 2 Synology sont à jour et au même niveau de version. Une idée?? Questions subsidiaires: * Ou sont les log? Vu que le Syno me dis qu'il y a un échec, je suppose que quelque chose est loggé ! * Ainsi que dans le cas ou elles seraient vide, comment active-t-on les log?? Petit update de dernière minute trouvée par hasard : une différence entre les 2 syno. Le vieux n'a pas apparmor, le nouveau oui. Mais stopper apparmor avec ' /usr/syno/etc.defaults/rc.sysv/apparmor.sh stop ' ne change rien
  4. Migration DS413J -> DS2415+

    La 'migration' avance bien. Le DS2415+ c'est vraiment un autre monde. Pour l'instant ça va a peut près bien. Partie 1: c'est pour l'histoire. Pas vraiment utile à lire. Du moins, pas de vrai questions Les vieux stockage PC RAID 5 avec disques de 3To sont enfin sortis et installé dans le DS. Opération longue surtout en considérant que j'ai quand même fait une sauvegarde temporaire sur le nouveau NAS. Je l'avais mis temporairement en JBOD sinon j'avais pas assez de disques. Puis changer disque par disque 3T->4T, attendre la reconstruction et recommencer.... Ca c'est fait Installation du nouveau NAS avec les 3To et quelques 4To en SHR2, 1 groupe de disques et 2 volumes. Configuration en cours, Vérification de parité en cours. Pétard c'est vraiment long. 1 seul groupe de disque vu que j'ai sinon pas assez de disques pour faire 2 groupes distincts en SHR2. Enfin c'est pas vraiment correct. C'est juste que j'aurais pas assez de stockage pour mettre toutes les données. De toute manière, je vais de toute façon me trouver court en emplacements. Mais je pense qu'un seul groupe de disque n'était pas le mieux. La vérification de la parité est vraiment longue. Ca fait un peu peur pour la prochaine reconstruction après crash disque. Le nouveau NAS étant configuré presque à l'identique de l'ancien. Configuration manuelle. C'est long aussi. Création des utilisateurs, Certificat, VPN, DNS, différents paquets (Audio, Vidéo, Surveillance...) Partie 2: il y a des interrogations Ce qui m'amène aux soucis (ou les interrogations) du jour. Il me reste à transférer les données de l'ancien NAS vers le nouveau. Et c'est les données 'critiques'. Surtout le dossier homes. J'utilise pour la première fois rsync. Donc j'ai pas de recul. J'ai fait un premier transfert d'un dossier de 800Go. Le taux de transfert est de 7-8Mo/s !! ?? Très très lent. Je n'ai pas demandé d'encryption. Je suis en local. Je me demande si c'est normal et s'il y aurait une autre manière de faire plus rapide. Le DS413J est certe lent. Mais quand même. Pour une copie de fichier vers un PC il est quand même plus rapide. En moyenne, au moins >20Mo/s. La je suis entre 2 et 3 fois plus lent. Ca m'inquiète pour le transfert du dossier homes. C'était la première question. La deuxième concerne le résultat de rsync sur le nouveau NAS. J'avais créé le même dossier partagé que je souhaitais synchronisé. Visiblement inutile car rsync l'a renommé en 'document_1'. 'document_1' est donc vide avec les droits utilisateurs que j'ai mis à la main. 'document' lui se transfère (24h !!) et aucun droits de positionnés. Donc j'en conclus qu'une fois terminé et après avoir basculé le nouveau NAS en NAS principal (changement d'adresse) et changé l'adresse de l'ancien, je vais devoir reconfigurer les droits et aussi supprimer le dossier 'document_1'. Pour le dossier homes, est-ce que j'ai des choses particulières à considérer pour remettre les droits des usagers? Vu que les usagers ont été créés à la main. Donc les noms d'utilisateurs sont identiques sur les 2 NAS. Mais peut être unix, entre 2 systèmes les différencies par un GUID ou autre chose. Donc beaucoup de texte pour juste 2 petites questions. Au fait, et le bruit dans tout ça. Donc mon DS413J faisant environ 22db. Maintenant avec le DS2415+ en mode calme, les 2 font 45db. Sonomètre posé à quelques centimètres des 2 NAS. Bientôt j'aurais un retour avec seul le DS2415.
  5. Migration DS413J -> DS2415+

    J'espère pas. Mais je parlais du vieux NAS qui ne recevra que les backups. Genre 1 activité tout les jours/bi-hebdomadaire/semaine ! Ca me fait bizarre de le laisser tourner sans veille ! Tu crois vraiment que c'est un soucis pour les disques dans ce cas?
  6. Migration DS413J -> DS2415+

    Bah, il faut ce qu'il faut . Moins de consommation électrique.2 vieux PC éteints et le vieux NAS en veille la plupart du temps. Stockage plus rationnel. Plus d'espace. Si tout va bien, même sans passer le NAS en LACP, meilleures performances moyennes. Les vieux RAID plafonnaient à 40MB en écriture et à peine mieux en lecture sur de gros fichiers. Le DS413J j'en parle même pas. Enfin des vrai backups (simples !?) du volume principal Et peut être même une amélioration inespérée pour les backups. Vue que, discrètement, il devrait rester 1 ou 2 disques inutilisés du simple fait de l'économie de disques de parité (2PC Raid 5)+ les nouveaux disques pour monter le nouveau NAS ! Je devrai pouvoir sauver une partie des données des vieux PC Raid. Sans compter le SHR-2. Bref montée en gamme violente et que des plus. Mis à part la dépense. Et aussi des arguments nouveaux pour: soit changer le vieux NAS pour un plus gros et résoudre complètement le problème des backups, soit monter un deuxième en miroir. A suivre...
  7. Migration DS413J -> DS2415+

    Merci beaucoup. J'ai maintenant les éléments qui me manquaient pour avancer. Ca va être clairement différent de mon idée initiale. Et Mic13710 et Fenrir, je vous suis très reconnaissant de vos conseils. D'autant que j'avais aussi zappé quelques détails. Conversion SHR vers SHR-2 impossible. Et même en SHR pas d'ajout de disque de taille inférieure au plus petit en usage ! Bref il est pas prêt d'être en place le nouveau NAS. D'abord installer les nouveaux disques de 4T dans les 2 vieux stockages PC RAID-5 qui ont des 3To et 1 4To chacun. Serrer méchamment les fesses le temps que les RAID se reconstruisent 3 fois. Et oui, 2 RAID-5 avec chacun 3 DD 3To + 1 4To . Monter le nas avec les 3T récupéré. Transférer tous les stockages RAID-5 des 2 vielles machines vers le NAS. Pour finalement récupérer les disques quasi neuf pour les installer sur le NAS. Et finalement agrandir le stockage. La seule partie zen sera au final ce qui me semblait le plus galère. A savoir la configuration du nouveau NAS sur l'exemple de l'ancien, transfert de ses données et convertir le vieux en machine de backups. Oups et avant ça tester les nouveaux disques ! 15H de test par disque de 4To ! Bref c'est parti pour au moins 2 semaines en serrant les fesses une bonne partie du temps. En corrigeant les fautes de saisies, je vois que l'ordre est pas terrible. Donc 2ème tentative: test des nouveau disques configurer le nouveau NAS, transférer l'ancien Basculer les NAS Réinitialiser l'ancien Backup du nouveau charger à mort le nouveau nas et l'ancien avec le plus de données des 2 PC RAID. Comme ça s'il y a un soucis dans les étapes suivantes, il restera quelque chose Idéalement j'aurais pu utiliser les nouveaux 4To pour sauvegarder les 2 RAID-5. Installer les vieux disques dans le NAS et charger le NAS. Mais l’interruption serait trop longue. Donc upgrader les vieux raid 5 en 4T 3x Monter les vieux 3T sur le nouveau NAS Transférer les PC Raid vers le NAS Eteindre les PC Raid Récuperer les disques Etendre le stockage du NAS + installer enfin les spares Anecdotiquement, continuer de chercher le budget pour une solution de backup complête. Ras le bol de serrer les fesses en attendant la catastrophe. Toute une épopée. C'est pas mon boulot.
  8. Migration DS413J -> DS2415+

    Oui j'entendais remplacer le DS2415 par le vieux DS413J temporairement. Dans ce cas, seul le volume1 serait synchronisé. Le reste du stockage (et la plus grosse partie) peut patienter. En lisant la doc SHA, je comprends que ce n'est pas possible. Par contre avoir 2 NAS avec une configuration identique, un volume principal quasi identique et une réplication du volume principal semble envisageable. Le plus simple et probablement le plus raisonnable serait de n'utiliser le vieux DS que pour des Backup. Onduleur->fait line interactive, clim envisagée. Par contre je ne suis pas sur de comprendre ton exemple. Le volume SHR-2 ok c'est clair. Par contre l'autre volume ?! Le Raid 1, c'est le système ou pour des tests comme tu l'écris? Si c'est le système, je suppose que ça sépare les backups et c'est plus simple à restaurer. Si c'est pour des tests, quels genre de tests et expérimentations fais-tu ou imagines-tu? Et encore merci pour vos clarifications, grâce à elles j'espère faire de moins mauvais choix.
  9. Migration DS413J -> DS2415+

    Hum, c'est bien la réponse que je craignais. Je vais donc passer par une installation complète :-) Dans un sens, ça devrait bien se passer vu que j'ai du me refaire une configuration complète il y a quelques mois suite à une étrange perte du système. Merci pour vos réponses éclairées et super rapides. Pour les 2 questions subsidiaires, auriez vous une opinion? A savoir, comment faire en sorte que le DS413J soit configuré comme solution de repli en cas de crash/panne du DS2415+ ? Est-ce possible? Si oui, je pense définir 2 volumes dans le DS2415+. Prenant malheureusement le risque de ne pas avoir de backup sur le deuxième volume. Si ce n'est pas possible, du coup c'est différent, le DS413J devient une unité de sauvegarde uniquement. Et ça génère la 2ème question qui reste valide même si la 1ère est positive. Vaut-il mieux avoir 2 volumes avec des disques physiquement distincts ou 1 seul volume avec tous les disques. D'une manière plus claire, Dans l'optique d'un crash et reconstruction, qu'est-ce qui génère le moins d'effort sur les disques 'survivants' ? Une grosse masse de disques ou une plus petite? Sachant que, dans tous les cas, seul 1 volume et en l’occurrence le plus petit et le plus critique sera sauvegardé correctement.
  10. Ma question du jour concerne le projet de rationaliser les différents stockages qui sont en place tout en profitant de bien meilleures performances avec le nouveau NAS.. Est-ce possible ainsi qu'une bonne idée de migrer un DS413J vers un DS2415+ ? Pas très motivé pour tout ré-installer complètement ! Le NAS historique gère les comptes utilisateurs ainsi que leurs dossiers utilisateurs, le site interne, mails, video surveillance, VPN, les sauvegardes critiques et anecdotiquement photos et musiques... Il est donc 'assez' bien utilisé et pas mal de configurations sont en place (vu mon niveau technique bien sur). A noter que depuis l'introduction du reverse proxy dans DSM, il n'y a plus de paquet tiers installé. Une fois migré, il recevra et centralisera les différents stockages raid 5 qui sont aujourd'hui en usage sur différents PC. Mais ça c'est une autre étape qui probablement fera l'objet d'un deuxième volume qui contiendrait l'ensemble des différents stockage. Et dans une dernière étape, voir s'il est possible d'utiliser le vieux NAS comme NAS de secours ou repli en cas de panne totale. Bien sur, ça ne concernerait que le volume 1. Le/les autres volumes ne pouvant pas être disponible pour des raisons évidentes de manque d'espace ! 4 disques contre 12 dans un premier temps ! J'espère avoir été clair. D'avance merci
  11. @CoolRaoul: merci encore. Des que j'ai un peu de temps (insomnie !?) J'étudie ngingx et ton exemple. Ça semble être exactement ce que je recherche. @Georges: intéressant et merci pour ton exemple. Là, moi aussi, j'aimerai bien comprendre ou est la subtilité. Un petit point que j'ai oublié de mentionner. Domoticz tourne sur un raspberry dédié. Il n'est pas installé sur le NAS. Même commentaire que dessus. Dès qu'un peu de temps je regarde les log de connections de domoticz
  12. Merci pour ta suggestion. C'est comme ça que j'ai limité la casse. Pour info, le serveur domotique c'est Domoticz. Avec Domoticz, tu peux spécifier soit la liste des machines autorisées sans authentification, soit un range de machines autorisées avec *. Style 192.168.0.* Mais ça m'oblige à entrer la liste exhaustive des machines susceptible de s'y connecter. Alors qu'en fait, il n'y en a qu'une (le nas), que je souhaite restreindre. Du coup, je me demandais s'il était possible de configurer le reverse proxy avec une authentification. Depuis l'interface, il n'y a rien de ce genre de visible. Mais peut etre dans un fichier de configuration. Ou une autre solution.
  13. Suite à la perte intempestive du système d'exploitation de mon nas, j'ai du tout reconfigurer. Du coup j'ai utilisé la nouvelle fonctionnalité de DSM, à savoir le proxy inversé natif. Il est ultra simple comparé à mon ancienne configuration ou j'utilisais haProxy. La question: j'ai besoin de l'utiliser pour accéder à mon serveur domotique. Y aurait-il une configuration cachée pour mettre en place une authentification? En gros, j'aimerai devoir m'authentifier lorsque je viens de l'extérieur de mon réseau. Sinon c'est un peu trop open bar ! J'ai bien une authentification obligatoire lorsque je viens de l'extérieur mais en passant au travers du reverse proxy mon serveur domotique me voie comme une connection locale. Si j'ouvre un port dédié sur le routeur, je n'ai plus de soucis, mais je ne peux plus me connecter depuis le bureau. D’où l'utilisation du proxy inversé.
  14. DSJ413J status orange clignotant

    Bon, la réinstallation s'est bien passée. Il me reste plus qu'a tout reconfigurer. Entre autres, DNS, Surveillance Station ... qui ne sont pas sauvegardé dans le fichier de configuration ni récupéré après ré-installation des package. Mail server reste un mystère
  15. Bonjour, gros soucis du jour. Après coupure électrique, malgré l'onduleur, le NAS de démarre plus. Je suppose qu'il ne s'est pas arrêté à temps et le système est corrompue. Au démarrage, les 4 disques sont allumés en vert constant. La LED LAN clignote. La LED status est en orange clignotant et un BIP. Le NAS n'est plus visible sur le réseau à son adresse. Synology Assistant le retrouve avec une adresse inattendue 169.254.48.252 au lieu de 192.168.0.x. et m'indique configuration perdue. Version affichée 6.0-7321. En changeant l'adresse de mon PC, je peux faire un ping du DSM. Si je me connecte dans ce cas sur le DSM, je tombe sur un assistant de réinstallation. A votre avis, Est-ce que je doit faire la re-installation? Je ne l'ai jamais fait et comme je n'ai qu'un volume, je crains la perte de donnée via reformatage. Pour l'instant, rien ne me permet de déterminer si un des 4 disques à un soucis. J'ai aussi une sauvegarde de la config du NAS directement accessible. Mais janvier 2015 ! Depuis il y en a eu des mises à jours ! Peut être une sauvegarde plus récente mais soit sur le NAS lui même (débile) soit sur le PC mediacenter. Mais il est aussi planté pour une autre raison. D'autant plus critique que c'est aussi le NAS qui contient mes sauvegardes des autres machines et que le PC principal (mediacenter) à aussi un problème système qui s'est déclaré lors du problème électrique. Lui aussi avait un onduleur. Le problème du PC n'a rien à voir et est identifié mais j'ai besoin de la sauvegarde du NAS. Pas de bol. 2 pbs en même temps. Bref pour résumer, 1 question pour l'instant Est-ce que je doit ré-installer? Y a t-il un risque de formatage direct (sans mon consentement !)? A l'aide ! Et merci d'avance