This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

Tonton Glenn

Wake On Lan

563 messages dans ce sujet

Le 15/01/2017 à 17:01, Christ88 a dit :

Bonjour Michel,

Je ne puis t'Expliquer...

J'ai essayé ave un autre ordi, et le WOL fonctionne ! Bizarre...

Mais chose certaine, le ping ne fonctionne pas. Dans tous les cas il me répond que l'ordi est hors ligne.

Christian

Attention pa fois il faut aussi l'activer dans Windows, sur ma nouvelle machine avec une carte réseau Intel cela ne marcher pas alors que j'avais le dernier driver du site gigabytes, mais en faite j'ai mis le driver officiel de Intel et là j'ai pu l'activer dans le gestionnaire de périf. Car lors de l'arrêt de windows c'est lui qui doit laisser la carte en veille si pas actif il la coupe totalement. Sur certain PC l'activation simple du bios suffit.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Est-il possible de demander au synology d'activer une machine grâce à ton Wake on Lan automatiquement, avec une tache et un script?

Merci de ta réponse 

Patrick

Modifié par Lucien77
Citation inutile

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Oui avec DSM 6 il est possible de programmer un script via le planificateur de tache du DSM

Donc nouvelle tache puis script défini par l'utilisateur ensuite renseigner les horaires si nécessaire

ou mettre le script au démarrage du NAS

Dans l'onglet paramètre de tache saisir

synonet --wake XX:XX:XX:XX:XX:XX eth0

remplacer les XX par l'adresse Mac de la machine à réveiller

Plutôt simple

Je me sert de ceci pour réveiller un serveur en même temps que mon NAS  qui lui utilise différents horaires

http://bootstick.ch/?p=5

Modifié par Lucien77
Citation inutile

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 20 heures, jmrodger a dit :

synonet --wake XX:XX:XX:XX:XX:XX eth0

remplacer les XX par l'adresse Mac de la machine à réveiller

Pour une raison qui m'échappe, "synonet --wake" a cessé de fonctionner chez moi et d'autres. Solution: réutiliser ce vieux script Perl qui fait l'affaire comme j'en ai parlé ici:

https://forum.synology.com/enu/viewtopic.php?f=90&t=116493&p=475318#p474953

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Youhou ! Ce script pourrait bien me sauver la vie, merci pour tout ça !

Hélas, j'ai le syndrome page blanche, malgré la désactivation des options de sécurité. J'arrive sur une page me déclarant : "désolé, la page que vous recherchez est introuvable".

Si quelqu'un passe par ici avec de l'info, ça m'intéresse !

Edit : Oups, je viens de voir la solution de catimini, qui règle mon problème. Merci !

Synology DiskStation - WakeonLan error.jpg

Modifié par JohnMcChavs

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 12/03/2017 à 11:41, CoolRaoul a dit :

Pour une raison qui m'échappe, "synonet --wake" a cessé de fonctionner chez moi et d'autres.

Je viens de tester et effectivement cette commande n'envoie que des paquets WoL mal-formés. En tout cas tcpdump ne reconnaît même pas le protocole de transport (udp) :

16:59:12.104120 08:42:ff:ff:ff:ff > ff:ff:ff:ff:ff:ff, Unknown Ethertype (0xffff), length 110:
..2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ....2 ..

On voit bien l'adresse MAC répétée 16 fois, mais l'en-tête du paquet est erronée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Il y a 1 heure, PiwiLAbruti a dit :

Je viens de tester et effectivement cette commande n'envoie que des paquets WoL mal-formés

Normalement faudrait ouvrir un ticket de support chez Syno. Mais mes deux dernières expériences m'ont franchement découragé. Je laisse ça aux plus patients que moi :neutral: (d'autant plus que, la commande n'étant pas documenté et donc pas officiellement supportée, ça leur serait encore plus facile de botter en touche)

Modifié par CoolRaoul

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Le 14/01/2017 à 18:57, Christ88 a dit :

Bonjour,

J'ai suivi les étapes, mais j'obtiens un erreur lors du démarrage de ton application sur le NAS.

Voir les captures.

Merci

1.PNG

2.PNG

1) Pour ceux qui cherche la version modifiée, direction ci-dessous. Gros merci à Catimimi pour son super taf !

2) Piqûre de rappel pour ceux qui ne s'en sortent pas avec le Wol ou Wowan : A) Activer l'option dans le bios B) Installer les pilotes OFFICIEL  de la carte (pilote Intel pour carte Intel, etc), et pas les drivers par défaut de Windows. C'est parfois capital (souvent avec les cartes Intel, par exemple). C) Si besoin de faire du WoWan, commencer par du Wol  D) Si toujours problème, utiliser le vérificateur de réception de magic paquet qu'on trouve sur le site de Depicus (a exécuter sur la machine qu'on veut WoL lorsqu'elle est allumée). Voilou !

 

Modifié par Supermatos.com

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 19 heures, Supermatos.com a dit :

1) Pour ceux qui cherche la version modifiée, direction ci-dessous. Gros merci à Catimimi pour son super taf !

 

 

Bonjour,

Merci, les sources sont à disposition pour ceux qui veulent cross-compiler pour d'autres architectures.

Je les ai fournies à Tonton Glenn qui devait les mettre sur Github, mais je n'ai plus aucune nouvelle de sa part.

De même mes sources pour owncloud 9 sur DSM6 sont disponibles.

Cordialement.

Michel.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

Bonjour,

j'ai installé le paquet "Wake On LAN" de Tonton Glenn, qui fonctionnait parfaitement sur un ancien Syno en DSM 5 mais je n'arrive pas à le faire fonctionner sur le DSM 6 fraichement installé et sur lequel je suis encore novice.

Les symptômes : Comme Christ88 plus haut, une belle page Synology qui dit "Désolé, la page que vous recherchez est introuvable."

Hormis l'installation de Web Station (sans paramétrage spécifique) et de Perl,  y aurait-il d'autres choses à faire pour ce paquet "Wake On LAN" ?

Ma config : DS 716+II avec DSM 6.1.1-15101 Update 3

Merci d'avance pour vos réponses,

Bien cordialement, Stéphane

Modifié par Steph78630

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

IL faut lire les autres posts de ce fil avant de se plaindre.

Le paquet de Tonton Glenn ne fonctionne plus sous DSM6.

j'ai posté dans la zone de téléchargements un paquet qui fonctionne pour les architectures intel donc pour le DS716+II.

Cordialement.

Michel.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, catimimi a dit :

Bonjour,

IL faut lire les autres posts de ce fil avant de se plaindre.

Le paquet de Tonton Glenn ne fonctionne plus sous DSM6.

j'ai posté dans la zone de téléchargements un paquet qui fonctionne pour les architectures intel donc pour le DS716+II.

Cordialement.

Michel.

Bonjour Michel,

rassurez-vous je ne me plaignais pas, je demandais juste un peu d'aide pour l'installation de ce paquet, et je vous remercie de votre réponse.

Je pense avoir lu tous les commentaires précédents de ce post, mais pour une raison que j'ignore le lien de téléchargement dans le post du 8 janvier m'envoyait vers un seul fichier et en y retournant désormais j'accède bien à 4 fichiers, dont le "wakeonlan-x86_64-20170108.spk".

Je confirme que cette nouvelle version de paquet est fonctionnelle sur ma config (DS716+II), merci et félicitations Michel !

Cordialement, Stéphane

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant