This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

cedgw

https et ds video

12 messages dans ce sujet

Bonjour

Tout marche bien sauf que depuis que je passe en https (j'ai lu que indispensable pour sécuriser les connexions) je ne peux plus lire les videos sur ds video, que ce soit sur ipad ou sur tele via apple tv

Malgré mes recherches je ne trouve pas, quelqu'un pourrait-il m'aiguiller svp?

Merci beaucoup !!

Partager ce message


Lien à poster
Partager sur d’autres sites

Video Station ne fonctionne pas (ou très mal) en HTTPS.

Si c'est pour un usage local (chez toi), pas besoin d'https, si c'est pour un accès distant, le VPN est une bonne (si ce n'est meilleurs) alternative.

Partager ce message


Lien à poster
Partager sur d’autres sites

Vidéo station fonctionne parfaitement en https. Il faut simplement avoir un certificat reconnu (pas d'auto signé)

Un certificat let's encrypt par exemple, permet d'utiliser et lire les vidéos en https. 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Vinky : ça a changé alors, je n'ai pas testé depuis un moment (la dernière fois c'était en DSM 5.2), mais j'avais pas mal de soucis alors que mon certificat était correct. Nb, on parle de DSVideo en https uniquement (http bloqué) ici, c'est aussi ton cas ? Si oui, c'est une bonne nouvelle.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjours,

   En Http : aucun probleme de lecture des video

   En Https : ( Pour lecture exterieur, avec un dyndns... ) , ports ouverts (5001 ), redirection: Box OK,  il arrive a lance DSvideo, mais impossible de regarde un Films... ( il commence, puis s'arrete )

  Un solution ? ,

ps: J'utilise certicat : Lets Encrypt : Pour info

   Cordialement ..

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Si tu utilise un lecteur vidéo comme VLC, il faut également accepté le certificat sur l'application pour lire la vidéo.

Autre point, dans le pare-feu syno, il y a des ports spécifique pour Vidéo Station peut voir de ce côté la.

 

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Re Bonjour,

       Ok, je vais aller . je vais voir le certificat de VLC ; Pour les ports j'ai juste ouvert 5001 et 5000 . je vais jete un coup d'oeil /)

   Merci a  Vous

   Cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de tester, ça fonctionne effectivement en full HTTPS si le certificat est reconnu coté client (j'utilise mon propre certificat d'autorité)

À toutes fins utiles, sur iOS il y a une option coté client à désactiver :

  • Lire des vidéos sur HTTP

Sinon il essaye de lire la vidéos sur un autre port (le TCP 5000 par défaut).

Je n'ai pas vu cette option sur Android, ça peut expliquer les résultats différents chez les uns et les autres (pour moi ça ne marchait pas car je testais avec un iPad).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je relance le sujet car je bataille depuis un bon moment avec ça... Effectivement, je souhaite rester en HTTPS quoi qu'il en soit et le visionnage de vidéos à distance me donne du fil à retordre. Je n'en suis qu'à essayer de le faire fonctionner en local pour m'affranchir, dans un premier temps, de la box.

J'ai un certificat Let's Encrypt (par défaut):

58d04a30b29ba_Sanstitre.png.a56f0ccd32e4af95421193ad3b115c7f.png

Certificat importé et vérifié dans iOS.

Comme Fuzel, j'ai accès à la liste et les jaquettes mais pas moyen de lire une vidéo sur la version iOS de DS Video ("La lecture vidéo a échoué suite à des problèmes de certificats. Accédez à la FAQ..."). La lecture via la page web fonctionne.

Un petit coup de pouce serait le bienvenu!

Partager ce message


Lien à poster
Partager sur d’autres sites

Le certificat que tu utilises doit correspondre au nom que tu renseignes dans dsvideo ET être nativement reconnu par ton "player" (iOS dans le cas présent).

Comme tu as un certificat letsencrypt, il est probablement valable pour un nom de domaine uniquement accessible depuis Internet (sauf loopback)

Si tu n'as pas mis en place un DNS interne, le nom que tu utilises est probablement différent de celui déclaré dans le certificat

=>il est probable que tu ne sois pas dans les bonnes conditions pour que ça fonctionne (il faut oublier quickconnect, en local c'est incompatible avec ... presque tout)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant