This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

Thesalan

Pages PHP non exécutés?

3 messages dans ce sujet

Bonjour,

Depuis la dernière mise à jour, mes scripts PHP ne sont plus exécuté. Si j'essai par exemple de me rendre sur la page de TTRss, ca m'affiche directement le contenu du fichier PHP.

Lorsque je regarde la configuration de WebStation, tout me semble correct (PHP5.7 bien démarré, Apache également...)

Que s'est-il passé, et comment y remédier?

Merci d'avance!

Modifié par Thesalan

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir, je viens d'avoir le problème en voulant activer hsts via php (header), j'avais mal set le header, si le code php est afficher c'est que apache a rencontré une erreur, essayer d'allez voir dans les log du syno dans /var/log

au passage faites un vide du cache de votre navigateur

FAUX!!!

c'est plutôt mes changements de Vhost + cache navigateur qui a causé mon problème, forcement durant un cours laps de temps (quand on supprime un vhost) php n'est pas activé.

bref pour ton problème, plusieurs piste :

  1. si tu utilise des vhosts pour tes sites, vérifie que dans leurs configurations, php 5.6 est bien sélectionné (pas a  non configuré) 
  2. sinon au niveau paramètres généraux même chose php5.6 de sélectionné
  3. sinon au niveau des paramettre php, paramettre avancés, coeur, verifié que engine = 1
  4. apache, avez vous changé de version ? avez vous des htaccess ?
Modifié par devildant

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé j'étais parti en vacances, et je ne pensais plus à ce message.

Finalement tout est rentré dans l'ordre lors d'un second reboot du NAS. Mais je n'ai pas compris ce qui s'était passé...

  1. Pas de vhosts, utilisation standard
  2. Oui c'était bien le cas
  3. Ca je n'avais pas regardé
  4. Non, rien de manuel en tout cas, j'avais juste installé la dernière petite update de DiskStation

Bref, c'est revenu dans l'ordre, mais je n'aime pas trop ca, que les choses bugs et se réparent toutes seules... 

En tout cas, merci pour ta réponse!

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant