This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

firlin

[TUTO] Préparation des disques avec Badblocks

Messages recommandés

Heu oui firlin

La tache a du se relancer car il y avait la croix cochée ...

DONC, SI TEST BADBLOCKS LANCE PAR TACHES, DECOCHER LA CROIX DES TACHES SINON REDEMARRAGE DU TEST.

Bob, maj du nas, redémarrage du test, tu es une trufe ...

Merci firlin

 

Bob

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

J’ai réussi à lancer le test avec un vieux DD de 250go où j’ai installé DSM (sur mon DS218+). J’ai commencé sur mon premier DD WD Red 6To. Le fichier log s’est bien créé ! :mrgreen: 

Par contre, impossible d’avoir accès avec WinSCP (dans mon cas, Cyberduck sous Mac). 

Mais je sais télécharger le fichier log et le lire pour voir l’avancement... (voir photo). 

C'est suffisant ? 

Par ailleurs, j’ai l’impression que ça va vite pour ma part : 5% environ 30min... :eek: (soit 10h pour réaliser la tâche selon mes calculs...)

Bien à vous, 

Walred

B96C7478-5AAA-498D-9486-922A267D0AA3.jpeg

Partager ce message


Lien à poster
Partager sur d’autres sites

@Walred cela me parait bon.

Petite question tu l'as lancé comment ? et quelle ligne de commande ?
c'est pour comparait par rapport à un autre DS218+ et un disque de 4To Seagate

 

Modifié par firlin

Partager ce message


Lien à poster
Partager sur d’autres sites

Nickel ! :biggrin:

Je l’ai lancé via DSM, avec une tâche. (Comme la première solution mentionnée dans ton tuto). 

===>  badblocks -nvs /dev/sdX > /volume1/toto/sdX.log 2>&1 & (ou est remplacé par b puisque deuxième disque).

Je te tiens au jus du log final pour comparer ! :razz:

Les disques (deux WD red 6To) sont arrivés hier, livrés par Amazon dans un package qui laisse clairement à désirer par contre... Enfin, j’espère pas de casse. :evil:

E2F9E70C-64AE-44AB-A921-22E9D0548367.jpeg

2D4883AB-6F73-44CB-8106-FD7FE8DD3ECF.jpeg

Modifié par Walred

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

Pour info:

Red 8To sur un 1817+, test badblocks en mode script, testé en +-27h.

 

Walred, j'ai laissé tomber Amazon pour les disques durs justement à cause de l'emballage. Trop de "déchets" ( retours).

Je passe par RdC, emballage bien fait et TRES bonne politique de retour au cas où. Ou alors si je récupère des bon de réduc, par WD directement et là, l'emballage top.

 

Bob

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pose la question car j'ai un amis qui a lancer un badblock sur un disque de 4To de chez Seagate avec un DS218+ et c'est pas le même temps que vous.

Il lui faut 7 jours, avec les 2 méthodes taches et ligne de commande.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 19 minutes, perduici a dit :

Bonjour

Pour info:

Red 8To sur un 1817+, test badblocks en mode script, testé en +-27h.

 

Walred, j'ai laissé tomber Amazon pour les disques durs justement à cause de l'emballage. Trop de "déchets" ( retours).

Je passe par RdC, emballage bien fait et TRES bonne politique de retour au cas où. Ou alors si je récupère des bon de réduc, par WD directement et là, l'emballage top.

 

Bob

Je le saurai pour la prochaine fois ! Merci pour l’info. En effet, 27h pour 8To, c’est casiment le triple de temps pour 1,5 x de données par rapport à mon cas... Étrange :confused:

il y a 15 minutes, firlin a dit :

Je pose la question car j'ai un amis qui a lancer un badblock sur un disque de 4To de chez Seagate avec un DS218+ et c'est pas le même temps que vous.

Il lui faut 7 jours, avec les 2 méthodes taches et ligne de commande.

Là par contre, je suis complètement hors norme... :neutral:

ça me parait bizarre cette histoire ! 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir, 

Bon, le test est terminé ! :biggrin:

Durée totale : 11:36:01 !  (Avec un WD Red 6To sur DS218+ et un vieux DD 250go où est installé DSM).

J’ai pris une photo du script lancé en tâche sur DSM et une photo du log.

Pass complete, 0 bad blocks found. (0/0/0 errors) :mrgreen:

Je lance le test sur le deuxième DD et vous tiens au courant demain ! :razz: 

Bonne soirée,

Walred

A9A4809B-253C-41A3-873F-EB1F6BA8D7EB.jpeg

F79E8716-C576-410D-9C7E-3D22C9FEFDC3.jpeg

Ps : en faisant un rapide ratio, je serai exactement à 11h36 pour le second test si tout se passe comme prévu ! :razz:

Modifié par Walred

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 17 heures, firlin a dit :

Je pose la question car j'ai un amis qui a lancer un badblock sur un disque de 4To de chez Seagate avec un DS218+ et c'est pas le même temps que vous.

Il lui faut 7 jours, avec les 2 méthodes taches et ligne de commande.

Il n’a pas d’indexation ou autre derrière en tache de fond ? Des machines virtuelles ou j’en passe ? J’ai remarqué que l’exploiration trop forte du nas pouvait ralentir le processus

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Einsteinium a dit :

Il n’a pas d’indexation ou autre derrière en tache de fond ? Des machines virtuelles ou j’en passe ? J’ai remarqué que l’exploiration trop forte du nas pouvait ralentir le processus

Bonjour,

En effet, je ne vois que ça ! Je n’ai pour ma part aucune autre tâche en fond... 

Sinon, deuxième test terminé ! Pour un total de 11:28:37. Soit un peu moins que le précédent disque dur. :question:

Par contre, toujours aucun badblock trouvé ! :mrgreen:

Je vais donc pouvoir me lancer dans la configuration définitive du NAS.

Merci encore pour les conseils et ce super tuto ! 

Peace,

Walred :biggrin: 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

D'abord merci à toi firlin pour le tuto, ca ma bien servi!

Ensuite je vous fais part de mes résultats sur la vitesse:
Je viens de checker deux disques neufs WD blue WD40EZRZ de 4 To dans mon DS213. Je les ai checkés l'un à la suite de l'autre avec la méthode n°1 (c'est à dire avec une tâche dans DSM).
1er disque en utilisant la ligne de commande fournie par firlin:

badblocks -nvs /dev/sdb > /volume1/toto/sdb.log 2>&1 &

Voici le résultat:

Checking for bad blocks in non-destructive read-write mode
From block 0 to 3907018583
Checking for bad blocks (non-destructive read-write test)
Testing with random pattern:
0.00% done, 0:00 elapsed. (0/0/0 errors)
[...]
100.00% done, 60:23:39 elapsed. (0/0/0 errors)
done
Pass completed, 0 bad blocks found. (0/0/0 errors)

Ca a prit 60 heures!!!

Du coup, en attendant que ça finisse, je me suis intéressé à la fonction et à ses options.
Et en lisant la page wiki de la fonction, je me suis dit que autant l'option "-wsv" prendrait encore plus de temps, autant celle avec un pattern random "-wsv -t random" devrait aller plus vite. En effet, le classique "-wsv" écrit bien 4 fois sur chaque bloc et lit de la même façon 4 fois, mais l'option "-wsv -t random" n'écrit qu'une fois sur chaque bloc (tout le temps le même pattern) et une fois tous les blocs écrits, fait une passe de lecture.
Or l'option "-nsv" fait bien plus que çà. Elle vient d'abord lire le bloc, copie les données quelque part (où?), écrit un pattern, lit le bloc pour vérifier que le pattern correspond bien, va rechercher la donnée d'origine puis la reécrit à sa place. Ça fait donc 6 opérations au lieu de 2 seulement!!!
Du coup, je ne suis pas d'accord avec certains qui disaient que l'option "-nsv" ne "stresse pas trop" le disque. Elle fait quand même 2 écritures par bloc sur toute la surface du disque là où l'option "-wsv" en fait 4 et l'option "-wsv -t random" 1 seule.
Je pense qu'il faudrait donc conseiller cette dernière pour vérifier des disques durs "neufs" avant de les monter dans un Syno non? Qu'en pensez-vous?

Du coup j'ai quand même testé le deuxième disque avec cette ligne de commande:

badblocks -wsv -t random /dev/sdb > /volume1/toto/sdb.log 2>&1 &

Voici le résultat:

Checking for bad blocks in read-write mode
From block 0 to 3907018583
Testing with random pattern:
0.00% done, 0:00 elapsed. (0/0/0 errors)
[...]
100.00% done, 7:56:53 elapsed. (0/0/0 errors)
done
Reading and comparing:
0.00% done, 7:56:54 elapsed. (0/0/0 errors)
[...]
100.00% done, 18:02:06 elapsed. (0/0/0 errors)
done
Pass completed, 0 bad blocks found. (0/0/0 errors)

Plus de 3x moins de temps... Ca me semble cohérent avec l'analyse de la fonction.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le but est de testé réellement le disque... avec cette méthode rapide... autant passé l’utilitaire du constructeur, voir ne rien faire...

Un block n’est pas forcément déclaré HS à la première passe, c’est d’ailleurs très rare..

Partager ce message


Lien à poster
Partager sur d’autres sites

@Einsteinium Qu'est ce qui te fait dire qu'une passe d'écriture c'est moins bien que  les utilitaires des constructeurs?

Sachant que tu disais au début que :

Citation

Les logiciels constructeurs ont une tolérance très laxiste... la ou badblock ne fera pas de pitier... pour faire simple.

Et qu'à propos du test "full" à 4 passes:

Citation

Le test non destructif est plus que suffisant et bien meilleur que tous les test constructeurs... là tu fatigues juste tes disques pour rien... et tu leurs crament 4 cycles d’écritures pour rien...

J'ai du mal à saisir que 1 passe ça soit "naze", 4 beaucoup trop et 2 le chiffre parfait? C'est un peu extrême comme position non?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello les gars !

Petite question, ce soir mon NAS m'as affiché ce message :
scrubbing.PNG.b575e584761e261454e5c3bf89ced6e6.PNG

Que dois-je faire ? Est-ce vraiment utile ? Ca ne vas pas raccourcir la durée de vie des HDD d'activer cette option ?
Merci pour votre aide ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant