This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

spohyak

Link aggregation sans incidence

Messages recommandés

Bonjour à tous,

Cela fait plusieurs jours que j'écume les sites et les forums mais je ne trouve pas de solution.

J'ai un syno ds1511+ relié par deux cables réseau sur un switch cisco sg500x compatible LACP.

Tout est configuré ok sur le switch, sur le nas aussi, j'ai bien 2000mbps qui apparaissent.

Mon PC est branché via sfp+ au swtich, 10 gbps.

Sauf que la vitesse est strictement la même que lorsque j'étais relié du nas au switch en 1gbps et du switch au pc en 1gbps c'est à dire 113 Mo/s

J'ai fait les tests suivants :

- changer les cables : idem

- transfert samba : idem

- 2 transferts samba : idem

-1 transfert samba + 1 transfert ftp : idem

-1 transfert samba sur pc1 + 1 transfert samba sur pc2 (autre nom de login) : idem

 

Du coup je me demande s'il n'y a pas un soucis :)

Si jamais quelqu'un a une idée ... je prends

 

MErci !

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est que vous n'avez pas encore compris comment fonctionne l'agrégation de lien.

Vous auriez beau mettre 10 liens que ça ne changerait strictement rien tout simplement parce que lorsque vous vous connectez au nas, le switch vous basculera automatiquement sur le lien disponible et la connexion ne se fera QUE sur ce lien. L'indication 2Gb signifie seulement que vous avez 2 liens de 1Gb opérationnels et que le NAS peut donc traiter les flux provenant de deux connexions distinctes.

Et votre 1511 n'étant que Gb, vous pouvez y mettre du 10Gb sur le réseau que ça ne le ferait pas aller plus vite.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, spohyak a dit :

Sauf que la vitesse est strictement la même que lorsque j'étais relié du nas au switch en 1gbps et du switch au pc en 1gbps c'est à dire 113 Mo/s

La vitesse du lien ne dépassera jamais le Gb. On aura beau multiplier le nombre de transferts du PC vers le NAS que ça ne changera rien à l'affaire.

Si on arrive à avoir 2 PC utilisant chacun un lien, chaque PC sera toujours en Gb, et c'est seulement la connexion totale sur le 1511 qui sera de 2Gb (soit la somme des deux liens), ce qui correspond à l'agrégation.

Partager ce message


Lien à poster
Partager sur d’autres sites

Il me semble que c'est bien ce que j'ai fait non ? 2 PC différents qui accèdent chacun au NAS, évidemment via le même switch mais bon ... j'ai faux ? Je ne m'attendais pas à avoir 10 gbps avec 2 liens 1 gbits hein ;) mais au moins 2x1gbps via 2 PC.

S'il faut que chaque prise lan du NAS soit sur un réseau local différent pour pouvoir en profiter je ne comprends pas l'option d'agrégation de liens effectivement :)

 

Edit : nouveau test en choisissant l'option 'Adaptive Load Balancing' du DSM Syno (et donc en désactivant l'agrégation de lien sur le switch).

Résultats : j'ai 95-100 Mo sur chaque transfert simultané sur les 2 PC

En revanche sur le même PC, si je fais un thread samba + un thread ftp, mes 113Mo/s se divisent en deux ... Enfin plus exactement samba prend le pas sur le transfert ftp avec 110 Mo/s vs 3Mo/s

Je comprends encore moins l'agrégation de liens alors :)

Modifié par Mic13710
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Lorsque vous écrivez

Il y a 2 heures, spohyak a dit :

Sauf que la vitesse est strictement la même que lorsque j'étais relié du nas au switch en 1gbps et du switch au pc en 1gbps c'est à dire 113 Mo/s

il n'y a rien de surprenant à cela.

Après, il se peut que vos réglages au niveau du switch et du nas ne soient pas les bons.

Pour le switch, je ne sais pas.

Pour l'agrégation au niveau du NAS, il y a cet article de la base de connaissance pour vous aider.

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je connais cette page qui n'aide pas vraiment au final.

Bon ce n'est pas gagné l'histoire ... vivement que je change de nas :) quelqu'un a une date pour les séries rsxxx18 ?

 

Modifié par Mic13710
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant