This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

daffy

Suite MAJ WebStation 2.1.3-0139

Messages recommandés

Bonjour à tous,

 

juste pour info, la MAJ de version du package WebServer est censée apporter :

  1. ajouter une fonction pour configurer le niveau TLS dans les hôtes virtuels.
  2. apporter le support de plusieurs profils PHP.
  3. corriger des anomalies de configuration.

Perso, j'héberge un petit site wordpress mais par mauvaise habitude... (prise parce qu'à un moment cela ne fonctionnait pas bien en interface IHM du package  avec le couple PHP7 et le serveur NGINX) je paramètre mes fichiers de conf pour nginx manuellement.

Le dossier etc/nginx/sites-enabled permet justement cette possibilité sans que cela ne soit remis en cause avec les différentes mise à jour (enfin jusqu'à présent).

Le point 2 de cette release est la cause de  l'anomalie me concernant : plus d'accès au site, erreur php diverses.

Il y' a bien un changement, dans le sens ou le .sock PHP n'est plus celui qui était appelé jusqu’à présent (je ne sais pourquoi) et son appel est largement différent là aussi... (surement lié  au fameux point 2 de cette release -- plusieurs profils PHP) Je m'en suis rendu compte en jouant avec le paquet et de constater les différences.

Ainsi chez moi j'avais :

Avant


 

location ~* \.php$ {
        fastcgi_pass unix:/run/php-fpm/php70-fpm.sock;
        fastcgi_param HOST "[NOMDUSITE].com";
        include fastcgi.conf;
    }

Désormais


 

location ~* \.(php[345]?|phtml)$ {
        fastcgi_pass unix:/run/php-fpm/php-15dd2a73-758c-41c1-87d8-69a67c1cf766.sock;
        fastcgi_param HOST "[NOMDUSITE].com";
        include fastcgi.conf;
    }

 

A savoir : le long php-.....69a67c1cf766.sock ne fut créé qu’après utilisation de Webstation en créant un virtualhost supplémentaire (que j'ai supprimé ensuite).

Citation

Voilà si cela peut aider certains et/ou d'autres à apporter du détail sur le sujet.
En tout cas j'ai retrouvé le bon fonctionnement de mon site.

Bon mais je risque d'être bien seul, car il semblerait que la fonctionnalité WebStation fonctionne parfaitement avec NGINX, PHP7 et WORDPRESS... :confused:

Heu chez moi non mais en manuel si.:geek:

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Perso, j'ai un soucis avec mon site. J'ai tout simplement une page blanche :(

J’héberge un vieux script php avec bdd pour gérer mes favoris et il ne fonctionne plus. Je ne vois pas trop ce que je peux faire car j'ai qu'une page blanche sans erreur particulière.

Partager ce message


Lien à poster
Partager sur d’autres sites

Quand je teste sur autre chose que FF, j'ai pas une page blanche mais ça :

 

Citation

Cette page ne fonctionne pas

Impossible de traiter cette demande via xxx.ndd.fr à l'heure actuelle.

HTTP ERROR 500

J'ai bien activé ce que tu m'as dit mais ça me donne quoi exactement et surtout ou ? Merci à toi

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne m'y connais pas assez en script php... Mon but était surtout d'héberger mon propre serveur de favoris qui tournait depuis des années sur un free.fr

Il fonctionnait bien jusqu'à la dernière maj de web station...

 

Pour htaccess, je l'ai viré mais toujours pareil.

Pour les permissions, elles sont en lecture sur le dossier du script donc normalement ok.

Reste effectivement peut-être l'erreur dans le script mais là, je ne sais pas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le htaccess en faite, le seul que j'ai est à la racine de web et il me permet d'avoir automatiquement une connexion https sur mon site. Donc si je tape http://xxx.ndd.fr, ça me renvoi automatiquement sur https://xxx.ndd.fr

Partager ce message


Lien à poster
Partager sur d’autres sites

Je m’incruste... J'imagine que ce serait l'explication pour laquelle mes scripts ne fonctionnent plus du tout, ce serait à cause de cette mise à jour du WebStation :'( (j'ai la page blanche, page error 505, je ne vais pas m'en sortir :'( )

Partager ce message


Lien à poster
Partager sur d’autres sites

Non pas vraiment, les scripts fonctionnent toujours si je tente d'héberger sur un service d'hébergement en ligne (tels que OVH, etc...) mais plus sur nas.

J'imagine qu'il doit y avoir des trucs comme structure / appellations qui a changé avec la nouvelle mise à jour de WebStation non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'imagine qu'il doit y avoir des trucs comme structure / appellations qui a changé avec la nouvelle mise à jour de WebStation non ?

Absolument.

Lors de l'utilisation de webstation cela génère un fichier du genre "webstation.host.conf" dans lequel on constate les lignes d'appel notamment pour PHP.

 

C'est ce dont je me suis inspiré pour produire mon propre fichier de conf que j'ajoute dans le dossier sites-enabled.

 

Bon mais je précise, que je n'utilise pas de serveur Apache mais nginx

Partager ce message


Lien à poster
Partager sur d’autres sites

N'étant pas un expert dans la manière, je pense que je vais devoir donc appeler Synology pour un support (même si au fond de moi, j'aurais aimé m'en passer de devoir les appeler)

Mais avant cela j'essaie tout de même à trouver des anciens version WebStations, si t'en as sous les coudes n'hésites pas à m'en partager :)

Partager ce message


Lien à poster
Partager sur d’autres sites

@InfoYANN @Sadi @

Avez-vous créer un profil dans les paramêtres PHP et activer PHP Xdebug. Dernièrement suite à la MàJ de Web Station certains avaient des erreurs et souvent résolu à cause de la connexion à la DB et particulièrement MariaDB10.

Voir ma réponse

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Non je n'ai pas fait ça mais en même temps, mon script tournait déjà sous PHP 5 et sous MariaDB 10. C'est pas une mise à jour de MariaDB qui l'a planté mais WebStation.

J'ai pas encore eu le temps de le tester en local pour voir.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Merci @Novioritum, je viens à l'instant de tester la solution proposé, il y a un petit peu du nouveau je crois :)

Alors à présent, ça m'affiche quelque chose plutôt que la page blanche.

Voici ce qu'il affiche :

Fatal error: Uncaught PDOException: could not find driver in /volume1/web/xxxxxxxx/include/data.php on line 7 PDOException: could not find driver in /volume1/web/xxxxxxxx/include/data.php on line 7 Call Stack: 0.0000 360272 1. {main}() /volume1/web/xxxxxxxx/index.php:0 0.0001 360632 2. require('/volume1/web/xxxxxxxx/include/data.php') /volume1/web/xxxxxxxx/index.php:2 0.0001 362032 3. PDO->__construct() /volume1/web/xxxxxxxx/include/data.php:7 

Voici la ligne concerné :

$bdd = new PDO('mysql:host=localhost;dbname=mes_scripts', 'xxx_UTILISATEUR_xxx', 'xxx_MDP_xxx');

Je pense que ça rapproche, quelqu'un comprend quelques choses ? :)

Modifié par Sadi

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

c'est que j'ai pu constaté (bien qu'en étant avec NGINX) le stack d'appel du PHP est différent AVANT versus APRÈS mise à jour Webstation.
Du coup j'ai réutilisé cette ligne dans mon scrip manuel et les choses se sont résolues.

Pour mémoire : lorsque je paramètre Webstation "tout comme il faut" il me génère un fichier contenant les informaitons pour le serveur nginx, (nottament l'appel PHP qui fonctionne alors) mais cela ne suffit pas pour que cela fonctionne à 100%, donc je m'en inspire et je fais les choses manuellement avec un script déposé dans le dossier sites-enabled.

Citation

A voir si cela peut être fait pour un serveur apache (j'iamgine que oui... ou en jouant sur les fichier htt.access)

 

AVANT :

 fastcgi_pass unix:/run/php-fpm/php70-fpm.sock;

 

APRÈS

fastcgi_pass unix:/run/php-fpm/php-15dd2a73-758c-41c1-87d8-69a67c1cf766.sock;

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant