This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Jeff777

Nas connecté à la box ou directement au PC??

Messages recommandés

Bonjour,

Je ne sais pas trop où poser ma question. Je tente ici et merci de me dire s'il y a un meilleur endroit.

Je vous expose le problème (qui n'en est peut-être pas vraiment un) ,

Dans les journaux récents j'ai la notification suivante :

User (admin) logged in from [192.168.0.254) via [DSM] 

254 c'est ma box free.

Mais parfois 254 est remplacé par 2  qui est l'adresse IP de mon PC, celui sur lequel je lis ces notifications.

Je ne remarque pas vraiment de différence en fonctionnement mais il me semble que lorsque j'ai la notification avec la box j'obtiens 19/20 au test http://ipv6-test.com/  alors que, assez souvent mais sans que ce soit systématique, je n'obtiens que 4/20  pour une notification avec mon PC.

C'est à dire que je n'aurais pas de connectivité IPV6 dans ce cas.

En général lorsque je démarre le PC je commence avec la notification PC puis  la BOX. Mais ce n'est pas non plus systématique.

Quelle différence entre les deux modes de fonctionnement et y a t'il un paramétrage à faire pour rester avec la box ?

 

Modifié par Jeff777

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Aucun avis sur la question ?

Je ne dois pourtant pas être le seul dans ce cas.

De mon côté rien de nouveau si ce n'est que le manque de connectivité IPV6 ne semble pas être liée  à la différence de logging.

Partager ce message


Lien à poster
Partager sur d’autres sites

Personnellement je ne comprends rien à ce que tu cherche à faire.

Si on s’en tient au titre, un NAS doit être connecté au réseau, peu importe que ce soit à la box ou à un switch. Connecter un NAS directement à un PC a peu de sens.

Partager ce message


Lien à poster
Partager sur d’autres sites

 

Il y a 4 heures, PiwiLAbruti a dit :

Personnellement je ne comprends rien à ce que tu cherche à faire.

Je cherche juste à comprendre (satisfaction purement intellectuelle de savoir) pourquoi dans les journaux récents le message suivant :

"user (admin) from 192.168.0.254 logged successfully via (DSM)"

alterne avec le même message mais avec l'adresse 192.168.0.2.

En d'autres termes que signifient l'un et l'autre des messages.

Mais ça n'a rien de fondamental car je n'observe aucune différence de fonctionnement (Je croyais qu'il y avait une relation avec les pertes d'IPV6 mais non ce n'est pas lié)

Partager ce message


Lien à poster
Partager sur d’autres sites

192.168.0.254 c'est quand tu passes par le loopback de ta (free?)box.

Donc par le ddsn, to ip wan ou ton ndd.

Le 192.168.0.2 c'est quand tu utilises ton réseau local.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pluton212+ pour l'explication.

Mais qu'est ce qui fait que je passe soit par le loopback soit par le réseau local. Je vais faire quelques tests pour essayer de comprendre.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 09/06/2018 à 15:30, Jeff777 a dit :

Mais qu'est ce qui fait que je passe soit par le loopback soit par le réseau local. Je vais faire quelques tests pour essayer de comprendre.

Eh bien, c'est ce que te dit Pluton212, si tu n'accèdes pas directement au nas avec son adresse privée et que tu passes d'abord par ton adresse wan ou un ndd, tu fais du loopback.

Georges.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je ne dois pas m'exprimer clairement.

J'ai bien compris ce que me dit Pluton 212+ mais ce n'est plus l'objet de ma question. Je vois bien la différence des deux modes de fonctionnement mais ce que ne comprends pas c'est pourquoi je suis parfois dans un mode parfois dans un autre; autrement dit  qu'est-ce qui provoque ce changement?

Je m'explique

Je précise que j'utilise DNS serveur en local et en public avec un DNS secondaire (Hurricane Electric). J'ai suivi les Tutos de Fenrir et tout marche à merveille en https.

Si j'ouvre mon navigateur (Chrome) j'ai plusieurs pages de démarrage qui sont :

1/ https://syno.mondomaine.fr     mon NAS où je vois les notifications (décrites qq lignes plus loin) dans les journaux récents. (à noter qu'avec cette adresse, je peux accèder au NAS soit directement soit en loopback puisque j'ai le même enregistrement CNAME dans la zone privée et dans  la zone publique.

2/ https://test-ipv6.com/     pour voir si j'ai la connectivité IPV6

3/ d'autre pages internet http://www.nas-forum.com   par exemple

et bien parfois je suis en loopback parfois en direct sur le NAS  si j'en crois les journaux récents qui affichent  :

      "user (admin) from 192.168.0.254 logged successfully via (DSM)" ou parfois 192.168.0.2.

Autre curiosité, parfois je perds la connectivité IPV6.

Je voudrais comprendre ce qui provoque ces changements. Y a t-il une cause qui induit le mode de fonctionnement ou est-ce purement aléatoire ?? Peut-on forcer un mode plutôt qu'un autre et y a t-il un intérêt?

ça, fait beaucoup de questions mais si je vous soûle laissez tomber!  🤣

Partager ce message


Lien à poster
Partager sur d’autres sites

soit 192.168.0.10 si c'est à partir du LAN soit mon adresse publique si ça vient de l'extérieur.

 

Dans la zone privée j'ai les enregistrements:

syno.mondomaine.fr   CNAME  ns.mondomaine.fr

ns.mondomaines .fr  A 192.168.0.10

et la même chose en remplaçant l'IP locale par mon adresse publique dans la zone publique.

il y a 43 minutes, PiwiLAbruti a dit :

En quelle adresse IP se résout syno.mondomaine.fr dans chacun des deux cas ?

Suite à ta question j'ai changé le premier DNS de mon DHCP de l'adresse publique de mon syno en son adresse privée pour voir.

Pour le moment pas de changement je suis toujours en mode connecté au NAS en direct et j'attends pour voir si ça change.

Modifié par Jeff777

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me suis donc lancé dans plusieurs tests. A chaque changement j'ai fait par précaution un "ipconfig /flushdns" et un rafraîchissement des pages web.

 

1ère série/Avec l'adresse privée de mon NAS en tête de DHCP (et les DNS FDN en 2 et 3ème position) :

J'ai pour l'instant toujours eu   "user (admin) from 192.168.0.2 logged successfully via (DSM)"  dans les journaux récents

Que je fasse un nslookup syno.mondomaine.fr 192.168.0.10   ou bien avec mon adresse publique,  j'ai toujours 192.168.0.10 en résolution sauf avec un dns de FDN ou j'obtiens l'adresse publique.

J'ai même essayé de me connecter via un proxy : pas de changement. Sauf bien sûr dans les journaux récents où l'adresse du proxy remplace mon adresse privée.

 

2/ Avec l'adresse publique de mon NAS en tête de DHCP mêmes résultats sauf que de temps en temps (connecté sans proxy) dans les journaux récents l'adresse publique remplace l'adresse privée et cela je n'arrive pas à savoir pourquoi.

Concernant les pages internet elles s'affichent toutes. Par contre en passant par le proxy je perd la connectivité IPV6 sur https://test-ipv6.com/

 

Maintenant d'après toi tout ceci est-il logique et est-il préférable de mettre l'adresse privée ou publique dans DHCP ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tes équipements réseau utilisent plusieurs serveurs DNS (peu importe qu’ils soient distribués par DHCP ou non), il est important que les serveurs DNS soient cohérents entre eux. C’est-à-dire qu’ils retournent les mêmes résultats de résolution, ce qui n’est pas le cas avec ta configuration actuelle.

Il se peut aussi qu’en fonction des applicatifs utilisés les résolutions utilisent tous les serveurs DNS de manière cyclique, ce qui expliquerait ton problème.

Essaye en ne distribuant que l’adresse privée de ton NAS comme serveur DNS.

Partager ce message


Lien à poster
Partager sur d’autres sites

Si je mets un seul DNS dans mon DHCP mon adresse privée ou d'ailleurs l'adresse publique j'obtiens toujours comme résolution 192.168.0.10 avec nslookup syno.mondomaine.fr

Ce qui est normale puisque je suis sur mon LAN donc mon DNS va utiliser la vue locale et donc la zone locale. Là ou syno.jeff-dom.fr est enregistré en 192.168.0.10.

Par contre si je mets un DNS quelconque (par exemple google 8.8.8.8 après nslookup syno.mondomaine.fr ) celui-ci n'a que la zone publique qui est effectivement propagée partout et donc il va résoudre l'adresse syno.jeff-dom.fr avec l'adresse publique. C'est ce que je viens de faire et cela marche bien comme cela.

Tous les DNS externes sont à mon avis cohérents pour la zone publique. La zone privée ne figure que pour le DNS du NAS. J'ai même essayé de mettre la box en DNS et bien elle aussi répond avec l' adresse publique.
Capture.JPG.74f6d8a6c33c096bc6ae169fcad16ff7.JPG

Il y a 7 heures, PiwiLAbruti a dit :

Il se peut aussi qu’en fonction des applicatifs utilisés les résolutions utilisent tous les serveurs DNS de manière cyclique, ce qui expliquerait ton problème

Oui ceci est à explorer ou bien le type de connexion qui serait fonction des applicatifs (PC NAS en directe ou PC BOX NAS) ce qui expliquerait les changements sur les journaux récents.
Merci pour tes conseils. Je vais regarder ceci de plus près.

Partager ce message


Lien à poster
Partager sur d’autres sites

En poussant le raisonnement un peu plus loin:

Si je désactive la zone locale sur DNS Serveur je me connecte toujours avec l'adresse de la box en loopback (l'adresse de l'appli est résolue en adresse publique par la zone publique)

Si je désactive la zone publique je me connecte toujours via l'adresse de mon PC (l'adresse de l'appli est résolue en adresse privée par la zone privée donc le PC se connecte directement en local)

Si j'ai les deux zones actives normalement la priorité est donnée à la zone privée mais parfois c'est la zone publique qui résout l'adresse. Reste à savoir pourquoi.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, PiwiLAbruti a dit :

Quels sont les adresses de serveurs DNS configurées sur ton PC ?

Tu veux dire dans le DHCP de la box ?   Là j'ai gardé 192.168.0.10 et 192.168.0.254 (le syno et la box)

il y a 4 minutes, PiwiLAbruti a dit :

Comment sont configurées les vues ? (ordre, zone sélectionnée, liste d'IP source)

J'ai suivi le tuto de Fenrir.

Vues.thumb.JPG.348418d0072407b093105348025299da.JPG

Pour les zones ordre identique (privée puis publique). La vue LAN pointe sur la zone privée, la vue WAN sur la zone publique.

Y a t'il un moyen d'interdire l'accès à la vue WAN aux IP de la liste du LAN ci-dessus pour être exactement complémentaire de la vue LAN?

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Jeff777 a dit :

Si j'ai les deux zones actives normalement la priorité est donnée à la zone privée mais parfois c'est la zone publique qui résout l'adresse. Reste à savoir pourquo

Je crois savoir pourquoi ! Si je mets mon PC en veille pendant quelques minutes et que je rallume le PC sans faire de flushdns la connexion à syno.mondomaine.fr  va se faire via la box et je vais avoir la notification dans le journal. 

Donc problème (qui n'en était pas vraiment un) résolu ! En fait tout viendrait du cache dns.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, Jeff777 a dit :

Tu veux dire dans le DHCP de la box ?   Là j'ai gardé 192.168.0.10 et 192.168.0.254 (le syno et la box)

Ne mets que l'adresse du NAS car le DNS de la box n'est pas capable de résoudre la zone locale, ce qui engendre des incohérences de résolution en local (probablement à l'origine du problème).

Il y a 4 heures, Jeff777 a dit :

Y a t'il un moyen d'interdire l'accès à la vue WAN aux IP de la liste du LAN ci-dessus pour être exactement complémentaire de la vue LAN?

C'est inutile. Tel que tu as définis les vues, les clients locaux ne peuvent pas utiliser la zone WAN (les règles sont traitées dans l'ordre).

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, PiwiLAbruti a dit :

Ne mets que l'adresse du NAS car le DNS de la box n'est pas capable de résoudre la zone locale, ce qui engendre des incohérences de résolution en local (probablement à l'origine du problème).

J'ai essayé. Effectivement cela semble résoudre le problème, je suis connecté directement au NAS après réveille du PC. Du moins sur les deux essais que j'ai réalisés.

Par contre lorsque j'arrête le NAS je perds la résolution des adresses web car je n'ai plus de DNS  et si je mets un autre DNS il ne sera pas non plus capable de résoudre la zone locale n'est-ce pas!

 

Il y a 1 heure, PiwiLAbruti a dit :

C'est inutile. Tel que tu as définis les vues, les clients locaux ne peuvent pas utiliser la zone WAN (les règles sont traitées dans l'ordre).

Oui c'est bien ce que je pensais. 

En tout cas, je te remercie pour le temps passé sur mon petit problème ! 😊

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as choisi d’utiliser ton NAS comme serveur DNS, tout ton réseau en est dépendant donc il faut qu’il soit allumé en permanence.

Sinon il ne devrait pas faire office de serveur DNS.

Modifié par PiwiLAbruti

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je comprends, mais je trouve un peu bête de laisser le NAS allumé la nuit, il est donc éteint de 0h à 7h;. Mais j'ai chez moi des enfants adultes qui ne s'en servent pas et qui continuent à surfer pendant ce créneau.

Pour bien faire il me faudrait un script qui déclenche le deuxième DNS seulement dans ce créneau.

Modifié par Jeff777

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui c'est plus simple.

Mais finalement je vais plutôt ne garder que le NAS en DNS c'est effectivement plus stable, je n'ai plus de changement sur le journal de connexion ni de perte de connectivité IPV6

et je vais réduire la fenêtre d'arrêt du NAS ou bien la supprimer.

Merci pour cet échange très instructif.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant