This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

fildar42

[Résolu]SSH avec un deuxième compte admin puis passage en root

Messages recommandés

Bonjour à tous,

Je rencontre un problème depuis quelques jours et ne je comprends pas le comportement de mon NAS. Pourriez vous m'aider?

J'ai créé un second compte d'administration, comme recommandé dans le tutoriel "Sécuriser son NAS" qui est très bien fait.

J'ai activé le SSH et je peux me connecter avec tous les comptes d'admin.

Si je me connecte en SSH avec admin@nas avec le mot de passe du compte admin OK

ensuite, je fais admin@nas# sudo su -     et j’entre le mot de passe du compte admin OK

root@nas#

-> je suis bien connecté en root.

 

par contre, si je me connecte avec le second compte d'adm que j'ai créé, je peux me connecter en Admin2@nas avec le mot de passe du compte Admin2  OK

si je veux passer au compte root, je fait    Admin2@nas# sudo su -

j’entre le mot de passe du compte admin   ->   KO, ce ne fonctionne pas, le mot de passe d'admin n'est pas reconnu.

 

comment passer de Admin2 à root avec une élévation de droit?

 

Merci d'avance pour votre aide.

 

Fildar

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour Admin2, soit le mot de passe entré lors du "sudo su -" n'est pas celui d'Admin2, soit Admin2 n'est pas dans le groupe d'utilisateurs qui a le droit de faire "sudo su -".

En tant qu''admin' et 'Admin2' lancez la commande : groups et comparez.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Merci pour votre réponse. Je n'avais pas compris que je devais entrer le mot de passe de Admin2, j'essayais d'entrer celui d'admin.

Cela fonctionne parfaitement maintenant.

Merci pour votre aide

PS: le commande groups n'existe pas dans le shell synology

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.