This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

ckl6767

Partage d'un Répertoire avec un utilisateur "Non inscrit" sur mon NAS, sous Drive

Messages recommandés

Bonjour,

J'ouvre ce sujet, car je n'arrive pas à partager un dossier avec une personne extérieure (cad qui n'a pas de compte sur mon NAS)

Exemple: Je souhaite partager le Dossier "Clauss" avec un personne extérieure 

J'utilise la configuration suivante : "Lien de protection pavancée"

 

 

 

 

Quand je me connecte sur : .../d/s/436033636687422546/tKuXM5igwFZrk_nQilnfnwFKrDLwtWQg-UyQgRGAaDQY_

J'obtiens comme réponse:

 

Pouvez-vous me dire ce qui cloche ??

Merci d'avance

Christian

 

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, bien entendu 😉

Est-ce que cela veut dire que mon configuration, est bonne, et que le problème viendrait d'ailleurs ?

Déjà pour me rassurer par rapport à l'approche...

Je tiens à préciser que le partage avec des personnes qui ont un compte sur mon NAS fonctionne. 
mais dans ce cas, j'utilise la configuration suivante:

 

 

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai fait exactement la même manipulation que tu décris et ça fonctionne avec demande du mot de passe pour 

accéder au dossier.

Ta configuration est elle opérationnelle:

tu utilises le port 5000, est il ouvert dans ton routeur et redirigé vers le nas ?

Vu que tu utilises cette configuration, j'ai envie de te diriger vers le tuto de @Fenrir:

sécuriser-les-accès-à-son-nas

Je pense que tu vas comprendre ce qui peut coincer après lecture.

ps: Christian est sur le réseau local ou bien est un utilisateur distant ?

Modifié par pluton212+

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réactivité.

Je suis actuellement à distant, j'arrive à accéder au NAS, et les ports 5000, 5001 et 6690 sont ouverts.

L'accès fonctionne soit en quickconnect ou en direct sur mon routeur qui redirige les 5000/5001/6690 sur mon NAS

(Donc pour la dernière question, Christian est un utilisateur distant)

De ce coté pas de soucis.

J'avais fait un essai rapide en utilisant https, mais même problème.

Je vais lire l'article de Fenrir, et revenir si je trouve le PB. sinon je reviens aussi 😉

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réactivité.

Je suis actuellement à distant, j'arrive à accéder au NAS, et les ports 5000, 5001 et 6690 sont ouverts.

L'accès fonctionne soit en quickconnect ou en direct sur mon routeur qui redirige les 5000/5001/6690 sur mon NAS

(Pour la dernière question, Christian est un utilisateur distant)

De ce coté pas de soucis.

Après lecture de l'article de Fenrir (très complet) outre des aspects de sécurités je ne vois pas ce qui pourrait expliquer mon problème..

Pour ma part, j'ai toujours le message "Element Invalide" au niveau de mon navigateur,

 

 

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as essayé avec un navigateur alternatif (tu utilises lequel ?)

 

je viens de cliquer sur ton lien et il me met:

'Élément invalide"

"cet élément n'existe pas"

Si je fais "connecter" j'ai la page de login du dsm.

C'est peut-être au niveau des droits...

 

Capture du 2018-08-03 16-59-48.png

Capture du 2018-08-03 17-01-51.png

Modifié par pluton212+

Partager ce message


Lien à poster
Partager sur d’autres sites

Essai  fait sur Chrome et Firefox.

Ce qui est étonnant est que quelque soit le navigateur, je n'ai déjà pas le même résultat que toi.

En ce qui me concerne, je ne vois pas de connect

image.png.9bf995d05311cd6764ab3d905805bc66.png

Concernant ta remarque sur les droits

Que veux tu dire ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pourquoi créer plusieurs topics avec la même demande ?! 🙄

Tu pouvais continuer sur l'autre topic...

 

Citation

(Donc pour la dernière question, Christian est un utilisateur distant)

Tu veux dire que c'est un utilisateur inscrit en tant qu'utilisateur sur ton DSM ou non parce que le partage n'est pas le même en fonction de la réponse !

Partager ce message


Lien à poster
Partager sur d’autres sites

La réponse est simple.

Le premier topic abordait le sujet de savoir comment partager des images (Moments)  entres plusieurs utilisateurs (inscrits et non inscrits sur mon NAS)

Ce topic a trouvé un certain nombre de réponses.

Pour ne pas polluer le premier topic, je préférais me concentrer sur le problème de partager un répertoire avec une personne non inscrite sur mon NAS.

D'où ce nouveau topic

Je mettrai bien entendu le premier topic à jour une fois le/les problèmes résolus.

Je trouvais cela plus logique de partir sur: 1 problème  = 1 topic 

A vous de me  dire

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

Peux-tu répondre à ma question sur "Christian" afin que l'on avance aussi stp.

Je réitère :

Citation

(Donc pour la dernière question, Christian est un utilisateur distant)

Tu veux dire que c'est un utilisateur inscrit en tant qu'utilisateur sur ton DSM ou non parce que le partage n'est pas le même en fonction de la réponse !

Partager ce message


Lien à poster
Partager sur d’autres sites

Voici la procédure pour partager sous Drive un fichier/dossier avec un utilisateur qui existe dans DSM :

  1. Clic droit sur le dossier/fichier puis "Partager".
  2. Selectionner "Privé - Seuls les invités bénéficient d'un accès".
  3. Dans "Liste des invités", tapez "Christian" ce qui devrait proposer l'utilisateur si il existe.
  4. Sélectionner l'utilisateur puis choisir à droite le choix de partage que tu veux.
  5. Cliquer sur + afin de finaliser l'opération de partage.

 

Cette personne verra le partage  dans son Drive dans un dossier nommé "Partagé avec moi" et toi tu le verras dans un dossier nommé "Partagé avec d'autres".

Tu peux aussi copier/coller le lien qui est dans cette fenêtre pour lui envoyer directement ce qui reviendra de toute façon au même que si il allait lui même dans son Drive.

 

 

8RXXK0q.png

Modifié par InfoYANN

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce topic ne concerne pas l'accès d'un répertoire à une personne qui est inscrite sur mon DSM.

En reprenant le topic depuis le début, tu vois que cela fonctionne (en suivant la procédure que tu as indiqué)

Mais comme dit le titre: ici le problème est

Partage d'un Répertoire avec un utilisateur "Non inscrit" sur mon NAS, sous Drive

C'est là ou cela coince, et c'est bien pour cette raison que j'ai créé ce topic spécifique

 

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

En effet, j'ai mal lu. Pour la procédure que tu souhaites, je ne vais pas pouvoir t'aider plus car là, ça coince pour moi aussi.

Le partage public ne fonctionne pas et je me demande si ça ne serait pas un bug côté logiciel.

Surtout que mon partage fonctionne si je le fais depuis File Station.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je cherche de mon côté mais pour le moment, je ne trouve pas la solution et je suis à peu près sûr que ça vienne de chez eux.

  1. Je passe tout par le reverse proxy. Pas de raison que ça fonctionne sous File Station et non Drive
  2. J'ai vérifié en tant qu'admin les paramètres de la console Drive et j'ai bien l'option cochée pour autoriser tous les utilisateurs à partager des fichiers en public. Je l'ai même décochée et recocher mais ça ne change rien.

Bref, je cherche encore au cas ou le soucis viendrait de moi...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon et bien j'ai finalement trouvé la solution en visitant le forum officiel.

https://forum.synology.com/enu/viewtopic.php?f=291&t=143876

 

Ce qu'il faut retenir :

  1. Synology sont au courant car le soucis a déjà été remonté
  2. Il y a une solution provisoire pour que ça fonctionne.
  3. Tout le monde ne rencontre pas ce problème...

La procédure :

Dans DSM en tant qu'administrateur : Panneau de configuration > Privilèges > double cliquer sur Drive > cliquer sur l'onglet "Privilèges par défaut" > Cocher la case et cliquer sur OK.

Normalement, le partage public fonctionne dans Drive !

Modifié par InfoYANN

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, InfoYANN a dit :

Bon et bien j'ai finalement trouvé la solution en visitant le forum officiel.

https://forum.synology.com/enu/viewtopic.php?f=291&t=143876

 

Ce qu'il faut retenir :

  1. Synology sont au courant car le soucis a déjà été remonté
  2. Il y a une solution provisoire pour que ça fonctionne.
  3. Tout le monde ne rencontre pas ce problème...

La procédure :

Dans DSM en tant qu'administrateur : Panneau de configuration > Privilèges > double cliquer sur Drive > cliquer sur l'onglet "Privilèges par défaut" > Cocher la case et cliquer sur OK.

Normalement, le partage public fonctionne dans Drive !

C'est donc un problème de droits si ça marche.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci à vous,

image.png.ad3d65a4430831335765b460c0284584.png

j'arrive à y accéder.

Par contre je n'arrive toujours pas à y déposer des fichiers.

L'objectif étant de donner accès à un utilisateur externe au DSM, à un répertoire, afin que celui-ci puisse y déposer des photos.

Est-ce que vous arriver à déposer des fichiers ?

J'ai bien mis:

image.png.4633a7757b3542b980e6dd58d123eaf5.png

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'ai pas vu d'option qui permettre cela par contre donc je dirais que ce n'est pas possible contrairement à File Station.

Autant que tu passes par ce dernier pour créer le lien de partage ou un invité pourra sans soucis déposer ses fichiers.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce qui est déroutant c'est que Synology Drive fait bien une distinction entre:

  • Tout le monde peut afficher
  • Tout le monde peut modifier

Dans le cas, "modifier", on s'attend donc à pouvoir déposer des fichiers. Pour moi c'est un BUG que je vais signaler à Synology.

Dommage qu'il faille passer par File Station, et donner des droits spécifiques en  accès en Ecriture à "Tous" les utilisateurs  sur un répertoire donné

En effet, Je ne vois pas ou donner l'accès en écriture sur le lien à partager.

 

En conclusion: pour "Drive" c'est résolu pour l'accès, mais pas pour la dépose de fichier 😞

En tous les cas merci à vous pour votre aide !

Modifié par ckl6767

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant