This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Dsm 4.1 Et Win7_ Fichiers Non Modifiables


Messages recommandés

Bonjour,

Depuis la mise à jour DSM, j'ai un problème de latence pour modifier le nom d'un fichier ou d'un dossier

Exemple:

je modifie le nom d'un dossier => pas de problème

Je viens de valider ma modification et je m'aperçois d'une faute d'orthographe: je corrige et au moment de valider=>

"Cette action ne peut pas être réalisée car le dossier ou l'un des fichiers est ouvert dans un autre programme.

fermez le dossier ou le fichier, et réessayez"

A condition d'attendre un délai d'environ 30s , l'action peut être validée.

Quelqu'un a-t-il se problème?

Une idée pou le résoudre?

Merci par avance

Sincères salutations

Loïc B

Lien à poster
Partager sur d’autres sites

C'est la faute de windows. Pour stocker les informations sur les fichiers présents dans un dossier, il stocke des infos dans un fichier "Thumbs.db" dans chaque répertoire.

Lorsque tu effectues une modification dans un répertoire, windows met un certain temps pour actualiser le "Thumbs.db".

Tu trouve le même comportement lorsque tu supprimer un répertoire avec des videos => le fichier "Thumbs.db" est ouvert par windows, et tant qu'il l'est, tu ne peux pas supprimer ton répertoire.

Après 30s, l'actualisation du fichier est finie => tu peut renomer / supprimer le répertoire comme tu veux.

C'est le fonctionnement de windows 7 qui est en cause

Lien à poster
Partager sur d’autres sites

OK, mais ce qui est curieux c'est que je n'avais jamais eu ce problème avant...

Et des copier-coller de dossier puis renommage, je le fais pratiquement tous les jours... et ce sans latence avant la mise à jour DSM

Lien à poster
Partager sur d’autres sites

Perso c'est un souci que j'ai depuis x versions de DSM ... sous Windows 7 et probablement d'autres versions (j'ai oublié).

J'avais deviné aussi qu'il s'agit de fichiers temporaires et donc de la façon dont Windows gère les partages réseau. Sauf à interdir à Windows de créer des thumbs.db voir d'autres fichiers temporaires je crois qu'il n'y a rien à faire non ?

Lien à poster
Partager sur d’autres sites

le problème se situe en fait uniquement sur les dossiers et non les fichiers

Pour un répertoire vide que tu supprimes, le problème est identique ?

(je pense à la corbeille réseau et aussi à l'indexation des fichiers)

Lorsque ça arrive, le moniteur de ressources dans l'interface DSM indique une charge supplémentaire ?

Le problème est identique en local et/ou sur des partages d'autres PC ?

Si tu peux tester...

A+

Michel

Lien à poster
Partager sur d’autres sites

le problème se situe en fait uniquement sur les dossiers et non les fichiers

c'est parceque windows ouvre un fichier temporaire que le repertoire le contenant est "bloqué". Xp ne le faisait pas, cela vient de seven (j'ai pas eu de vista sous la main)

Lien à poster
Partager sur d’autres sites

Cher Lurik, je pense que ta réponse est trop restrictive. ça fait plus d'un ans que j'ai seven, et le problème n'est apparu qu'aujourd'hui avec la mise à jour dsm4.1

De plus, en regardant les propriétés du dossier, la case de l'attribut "Lecture seule" est remplit en bleu et la case archive est cochée

A présent, je suis même obligé de modifier ces données avant de poursuivre la modification...

Et windows qui met pratiquement 1 min pour modifier un fichier thumb...en réseau gigabit sur un RS 812... ça me paraît louche...

PROBLÈME RÉSOLU

J'aurai peut-être du vous préciser que l'accès se faisait via un lecteur réseau sur Windows.

J'ai déconnecté ce lecteur, redémarré l'ordi , recréé le lecteur et ...ça marche

Modifié par loicb
Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.