This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

benoit16

Transferts automatiques fichiers dédié vers NAS

Messages recommandés

Bonjour,

Voila, j'ai un serveur debian chez online et je souhaite que les nouveaux fichiers téléchargés soient automatiquement transférés sur mon NAS.

Malgré de longues recherches sur le net, je n'ai trouvé aucun tuto clair sur le sujet.

Pourtant, je pense qu'avec les outils qu'offre dsm 5.2 ça ne doit pas être si compliqué.

J'ai trouvé ça https://www.synology.com/fr-fr/knowledgebase/tutorials/613 

mais je n'ai rien compris au dernier paragraphe.

Si quelqu'un a réalisé cette automatisation et peut expliquer comment il a fait, je lui en serait très reconnaissant.

Modifié par benoit16
orthographe !

Partager ce message


Lien à poster
Partager sur d’autres sites

ben en fait, c'est pas très compliqué :

rsync -av home/ admin@192.168.55.66::NetBackup/backupdata/

c'est la commande à tapé sur ton server online

faut donc les paquet rsync et ssh installé (en théorie, c'est le cas)

home/ : le dossier de ton serveur online que tu désire synchroniser
admin : le nom d'utilisateur de ton nas
192.168.55.66 : l'ip publique ou se trouve ton nas
NetBackup : le dossier partagé
backupdata : un dossier dans le dossier partagé

maintenant, tu peux lancé rsync en mode deamon, pour que ce soit fait en temps reel
http://www.jveweb.net/en/archives/2011/01/running-rsync-as-a-daemon.html (c vieux, mais ca devrait toujours fonctionner ;))

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Sinon il y a aussi lsyncd qui permet de faire du rsync sur ssh pour une synchronisation en temps réel de répertoires.

Mais j'avoue que j'aime bien la solution de Fenir qui ne nécessite à priori aucune installation nul part, et qui permet surtout que ce soit le NAS qui vienne chercher les sauvegarde... par contre, il faut bien faire attention à la sécurisation du fichier XML et des fichiers de sauvegarde !!!!!!

Modifié par loli71

Partager ce message


Lien à poster
Partager sur d’autres sites
Sur 12/12/2015 16:05:20 , gaetan.cambier a déclaré:

ben en fait, c'est pas très compliqué :


rsync -av home/ admin@192.168.55.66::NetBackup/backupdata/

c'est la commande à tapé sur ton server online

faut donc les paquet rsync et ssh installé (en théorie, c'est le cas)

home/ : le dossier de ton serveur online que tu désire synchroniser
admin : le nom d'utilisateur de ton nas
192.168.55.66 : l'ip publique ou se trouve ton nas
NetBackup : le dossier partagé
backupdata : un dossier dans le dossier partagé

maintenant, tu peux lancé rsync en mode deamon, pour que ce soit fait en temps reel
http://www.jveweb.net/en/archives/2011/01/running-rsync-as-a-daemon.html (c vieux, mais ca devrait toujours fonctionner ;))

 

Merci pour ce complément d'information. Mais quid du login du nas ?

Avant d'essayer cela, j'ai voulu commencer par gérer le paramètre automove dans rutorrent. et ça ne marche pas.

J'ai donné /home/pierre/torrents/complete comme chemin vers le répertoire des torrents terminés et copier comme type d'opération.

Les fichiers n'arrivent pas dans /complete, ils restent dans /torrent

Normalement, mes fichiers arrivent dans /torrents

Ce doit être évident, mais je ne vois pas.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 19 minutes, benoit16 a déclaré:

Merci pour ce complément d'information. Mais quid du login du nas ?

Pour utiliser rsync avec ssh, il faut mettre en place l'authentification pas clé pour ssh sur ton serveur online pour le compte qui lancera le rsync vers le compte que tu souhaites utiliser sur le synology.

Partager ce message


Lien à poster
Partager sur d’autres sites
Sur 12/12/2015 16:05:20 , gaetan.cambier a déclaré:

ben en fait, c'est pas très compliqué :


rsync -av home/ admin@192.168.55.66::NetBackup/backupdata/

c'est la commande à tapé sur ton server online

faut donc les paquet rsync et ssh installé (en théorie, c'est le cas)

home/ : le dossier de ton serveur online que tu désire synchroniser
admin : le nom d'utilisateur de ton nas
192.168.55.66 : l'ip publique ou se trouve ton nas
NetBackup : le dossier partagé
backupdata : un dossier dans le dossier partagé

maintenant, tu peux lancé rsync en mode deamon, pour que ce soit fait en temps reel
http://www.jveweb.net/en/archives/2011/01/running-rsync-as-a-daemon.html (c vieux, mais ca devrait toujours fonctionner ;))

 

Je ne comprends pas, l'adresse que tu me donnes en exemple est une adresse locale et, plus loin, tu dis "ip publique où se trouve ton NAS" ?

A mon avis, ce doit être une adresse publique. J'ai néanmoins essayé les 2 !

Dans tous les cas, j'ai l'erreur classique :

error in socket io (code 10) at clientserver.c(122) receiver=3.0.9

Je pense avoir paramétré correctement le NAS et affecté correctement les permissions.

La commande que je passe sur mon serveur debian est :

rsync -av home/xxx/torrents pierre@81.65.xxx.xxx::NetBackup/incoming

pierre a les droits d'accès sur incoming

J'ai essayé avec l'adresse locale du NAS (mais je ne vois pas comment ça pourrait marcher)

rsync -av home/xxx/torrents pierre@192.168.xxx.xxx::NetBackup/incoming

Et ça ne marche pas non plus

Remplacé pierre par admin : pareil

rsync est evidemment installé sur mon serveur.

Je n'y comprends vraiment rien

Une aide serait très appréciée !

Modifié par benoit16
orthographe

Partager ce message


Lien à poster
Partager sur d’autres sites

As tu bien configuré la redirection du port SSH sur ta Box déjà vers ton syno ?

Première chose à faire pour tester que les flux fonctionnent , c'est depuis ton debian :

Citation

ssh pierre@192.168.xxx.xxx

tu dois pouvoir te connecter sans avoir a fournir de mot de passe (utilisation de la clé privée/public entre les deux machine).

Autre conseil, ne pas ouvrir le port 22 sur ta box côté interne, c'est pas le mieux en terme de sécurité, ce qui veut dire qu'il faut aussi que tu ajoutes dans ta commande (pour tester le ssh) soit en utilisant le paramètre "-p <port>".

La solution la plus simple (pour ne pas avoir a retenir ce parametre et pour que le ssh s'en serve quelque soit l'appel, donc aussi au travers du rsync) est de créer un fichier "config" dans le répertoire ".ssh" de l'utilisateur qui doit lancer les commande sur ta debian, ce fichier doit par exemple contenir les infos suivantes :

host MonNas
   Hostname 81.65.xxx.xxx
   Port 622

Dans cet exemple, c'est le port 622 que tu as forwardé sur ta box côté internet vers le port 22 de ton syno.

il te suffit d'utiliser la commande suivante dans tes tests :

ssh pierre@Monnas

et dans ton rsync:

rsync -av home/xxx/torrents pierre@MonNas::NetBackup/incoming 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Non Fenrir, pour le fichier de config, c'est "~/.ssh/config" sur la debian... à ne pas confondre avec le fichier d’autorisation des clés à compléter/créer lui sur le syno (~/.ssh/authorized_keys)

Modifié par loli71

Partager ce message


Lien à poster
Partager sur d’autres sites
rsync -av home/xxx/torrents pierre@<nom_de_mon_NAS>::NetBackup/incoming

euh, ben essaye "ssh pierre@<nom_de_mon_NAS>" étant donné que tu utilises le port 22 sur ta box côté internet (d'après ton fichier nas.config)

Et si tu arrives à te connecter sans problème et sans mot de passe (utilisation des cles), alors essaye la commande rsync

rsync -av home/xxx/torrents pierre@<nom_de_mon_NAS>::NetBackup/incoming
Modifié par loli71

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure , loli71 a déclaré:

Non Fenrir, pour le fichier de config, c'est "~/.ssh/config" sur la debian... à ne pas confondre avec le fichier d’autorisation des clés à compléter/créer lui sur le syno (~/.ssh/authorized_keys)

j'avais lu la question en diagonale ...

Pour tes tests, ajoute l'option --dry-run dans ta commande rsync, ça dit ce que ça va faire mais ça ne fait rien (simulation), ça t'évitera des mauvaises surprises en cas de fausse manip

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement