This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

lemondaft

[Résolu] Nas inaccessible

Messages recommandés

Bonjour à tous,

Je suis à la recherche d'une bonne âme qui pourrait m'aider car j'avoue ne plus rien comprendre à la situation.

Je dispose d'un NAS Synology DS213j avec DSM 6.0 (ou dernière version). Le NAS est relié à ma freebox (Freebox v5) avec une IP fixe

Jusqu'à peu, tout fonctionnait bien, j'accédais au NAS depuis chez moi et depuis l'exterieur via un port que j'avais configuré.

Il y a qques jours début des ennuis : La LED du Disque 2 s'allume par intermittence mais reste verte. Souvent elle est éteinte. Intrigué je lance une analyse SMART du HDD2 mais le disque est indiqué comme indisponible. L'accès à l'interface DSM reste possible à ce moment mais "plante" parfois (impossible d'accéder à l'interface de gestion.

La ou ca se gate, c'est que maintenant l'accès à la DSM est impossible depuis l'exterieur et depuis mon réseau interne. J'ai essayé de taper l'adresse IP du NAS, de raccorder par cable ethernet mon Mac au NAS, d'utiliser l'assistance Synology d'installation...rien y fait... Ah si, une fois tous les 20 rafraichissements : oh bonheur je vois dans l'assistant mon NAS mais dès que j'essaie de connecter... ben non plantage.

De son coté le voyant du HDD2 continue de clignoter vert de temps en temps et rester éteint le reste du temps.

J'ai fait un truc pas très propre : j'ai coupé le courant, ouvert le capot et essayé de revisser le HDD2 histoire de voir si un faux contact était à l'origine... mais non rien...

Bon le problème c'est que je n'arrive même pas à l'interface de gestion donc je ne peux RIEN faire.

J'ai essayé un ping de l'adresse IP... rien est renvoyé...

J'ai peur que ce soit le NAS qui soit tombé et franchement ca fait juste 2 ans que je l'ai donc ca me foutrait pas mal les boules

 

Merci d'avance pour votre aide!!

Partager ce message


Lien à poster
Partager sur d’autres sites

Les deux disques sont montés en raid (le montage raid propose par synology) 

pour le shr et protection de données j'avoue ne pas savoir et comme je n'arrive pas à accéder à dsm je suis un peu bloque...

merci bcp

J'avais fait une sauvegarde via l.utilitaire sync de type Time machine il y a 3 semaines donc pas de pb s'il faut faire des opérations sur les disques

Partager ce message


Lien à poster
Partager sur d’autres sites

Si vous avez fait l'installation standard, vos disques sont en shr avec protection des données (équivalent RAID1)

Faite d'abord un test de la CM en suivant ce tuto Synology. Attention de bien repérer les disques (ne pas les mélanger) et leur emplacement respectif.

Si le test est OK, vous ne remontez que le disque 1 et vous redémarrez le NAS.

Quel modèle de disques ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'ai rien contre les WD. Seulement, il se trouve que les 3To toutes marques confondues ont un taux de panne plus élevé que les autres capacités et que le RED 3To est celui qui détient la triste place de premier, assez loin des autres. C'est assurément le disque le moins fiable du moment.

Ne vous laissez pas berner par les disques soient disant NAS. Malgré les beaux discours des fabricants, ils ne sont ni meilleurs ni pires (sauf le 3To WD) que les autres. Ils tombent tout autant en panne que les autres et ne fonctionnent pas mieux. C'est principalement un gros coup de marketing. Ceci étant, ce n'est que mon avis (et celui de beaucoup d'autres).

Si vous devez changer votre disque, je vous conseille d'abord de prendre une capacité supérieure, un 4To par exemple. Vous ne l'exploiterez que comme un 3To, mais le jour où vous changerez l'autre disque par un 4To, votre SHR occupera alors tout l'espace cad 4To. Prenez de préférence un disque compatible avec votre NAS (voir les compatibilités sur le site Synology). S'il ne l'est pas, vérifiez au moins qu'il n'est pas dans la liste des incompatibles. Choisissez un disque dont les caractéristiques sont assez proches du disque sain. Sauf si ce dernier est en 7200t, prenez un 5400t. Par exemple, les WD green (ancienne dénomination) ou blue de la nouvelle gamme en 5400t sont très bien. Celui que vous trouvez dans ma signature fonctionne très bien aussi. Pour des questions de qualité globalement satisfaisante et de SAV, prenez seulement une des marques reconnues : HSGT, WD, Seagate.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de la réponse

Bon finalement, je n'ai pas eu le temps de tester la carte mère car mon fils de 2 mois ne me laisse pas des masses de répit. J'ai une fois de plus forcé l'arrêt car un appui long sur le bonton on/off mettait le voyant bleu en clignotant mais n'éteignait jms le syno.

J'essaie de m'y remettre ce we et vous tiens au courant!

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon ben j'ai l'impression que c'est la grosse blague tout ça!

J'ai fait le test du Tuto :

- avec le hdd2 (seagate seul) ==> jamais eu de bip et voyant bleu clignotant tout le temps

- avec hdd1 (wd seul) ==> alleluia ça bip mais en fait ça continue à biper car disque défectueux 

disk manager me proposait une réparation de disque. Compte tenu de l'absence du hdd2 je me suis dit qu'il valait mieux dire que ce sera fait au prochain démarrage avec un nouveau disque pour remplacer le seagate.

 

En conclusion, pensez vous que je fais bien en achetant un nouveau hdd (je suis votre conseil) de 4To, l'installant puis redémarrant mon synology?

au redémarrage il y a aura t il des choses particulières à faire? 

 

Merci beaucoup!!!

Partager ce message


Lien à poster
Partager sur d’autres sites

Vous pouvez tenter la réparation de disque dans un  premier temps.

En fait, vous avez probablement une double peine : le hdd1 a sa partition donnée qui est hs et sa partition système OK, le hdd2 a sa partition donnée ok et la partition système hs. Donc, vous ne pouvez pas tourner avec un seul disque. Comme les pannes ne surviennent jamais simultanément, vous aviez probablement un pb depuis un certain temps que vous avez laissé trainer, ce qui vous conduit à la situation présente.

Si la réparation est ok, on pourra envisager la reconstruction avec un disque neuf. Sinon, il va falloir envisager une autre option.

Partager ce message


Lien à poster
Partager sur d’autres sites

Vous me conseillez de redémarrer le synology avec le disque 1 pour voir si la réparation fonctionne c'est ça?

si cela ne fonctionne pas et avant de partir dans de nouvelles acquisitions , quelles sont les autres options que vous évoquez? En gros je me dis que si racheter 1 hdd de 4to avec le risque qu'on ne puisse pas récupérer et que le 3to lache dans qques jours, autant directement partir sur 2*4to tt de suite et éviter achats espaces, réinstal, etc.

 

ce qui est étonnant c'est que le synology n'a jamais clignote en orange sur l'un des disques... Sur l.interface dsm le système et les disques étaient toujours présentes comme sains. Même la semaine dernière, alors que je constatais que la led du hdd2 réagissait bizarrement, un diag des disques le donnait hdd1 sain et hdd2 impossible à accéder mais pas d'alerte...

 

J'en arrive à me demander si le modèle de synology que j'ai (ds213j) est capable de supporter des sollicitations aussi fréquentes (sonos connecte, cloud station, cloud server, synchro gdoc, disk station, etc) 

 

merci de vos retours, j'espere pouvoir régler cette affaire bientôt!

 

merci bcp

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pense effectivement que chacun des disques a un problème. Le 1 est OK au niveau du système et KO au niveau des données, le 2 est KO au niveau du système et OK au niveau des données.

Pour info, les disques comportent chacun 3 partitions : 1 système, 1 swap (propre à linux) et 1 donnée. La partition système fonctionne en RAID1. Si une partition tombe en panne, le système fonctionne toujours sur le ou les disques restants.

Vous pouvez donc tenter 2 choses :

1) lancer la réparation du disque 1 tout seul. Si ça passe, vous pourrez peut-être retrouver tout ou partie de vos données.

2) avec le disque 2 tout seul, tenter un double reset pour réinitialiser le DSM et le réinstaller. Cette manip ne touche pas aux données.

Si aucune des 2 fonctionne, il ne vous reste plus qu'à installer le disque dans un PC ou dans un rack et de faire la récupération des données en suivant ce tuto. Il y a probablement un disque dont la partition de données sera lisible.

Concernant les alerte, si un disque était inaccessible, le NAS a dû vous en informer mais si vos notifications ne sont pas ou mal configurées, vous n'avez pas été alerté. En tout cas, il doit y avoir obligatoirement un enregistrement dans les logs du NAS.

Pas d'inquiétude à avoir au niveau du NAS. Le 213J est tout à fait apte à faire ce que vous lui demandez. S'agissant toutefois d'un modèle de base, il peut avoir quelques ralentissements dans l'exécution de certaines tâches gourmandes en ressources. En aucun cas, il peut être la cause de la défaillance des disques. Comme je l'ai écrit, les 3To sont moins fiables que les autres et vous avez en plus un WD RED. Je ne suis pas vraiment surpris qu'ils puissent tomber en panne. La première panne est sans doute intervenue il y a quelques temps et il aurait fallu en être alerté pour faire le changement de disque.

En tout état de cause, vos 2 disques sont en défaut et il est bien entendu préférable de les changer et l'option 2x4To me semble la mieux appropriée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour toutes ces réponses !

c'est vraiment très sympa de passer du temps à aider les utilisateurs novices que nous sommes.

J'ai redémarre uniquement avec le dd1 et la réparation semble avoir fonctionné. Pour le 2, j'avoue ne pas avoir très envie de remettre la dsm à zéro et sachant que de toute manière je devrai changer les disques à court terme, je le remplace par un 4to.

je changerai le dd1 un tout petit peu plus tard afin d'etre sur de pas trop galèrer sur la récupération des donnees

merci encore bcp bcp! 

Benjamin

Partager ce message


Lien à poster
Partager sur d’autres sites

Allez pour la fin de l'histoire...

J.ai changé le dd2 par un dd de 4to puis redémarre. 

J'ai réussi à réparer le volume à priori entièrement (le dd1 est resté)

J'ai fait un test smart rapide du dd1 et a priori pas de pb. Je suis en cours d'un test étendu.

J'ai quand même regarde les journaux. La première erreur visible sur le disque date du 16 juillet Retry error occurs on the disk [/dev/sdb].

Ca ne fait donc pas très longtemps mais je me dis que quand même il faudrait à l'avenir que je sois plus vigilant sur la santé des disques et remontées d'alertes. 

Comment controlez vous l'etat des disques et paramètres les alertes?

si vous avez un peu de temps pour répondre c'est super sinon, j'ai bien conscience que j'en demande déjà trop! Merci bcp

Partager ce message


Lien à poster
Partager sur d’autres sites

Il faut tout d'abord activer les notifications selon vos besoins : Email, SMS, service push et sélectionner dans l'onglet "Avancé" les alertes que vous souhaitez remonter vers tel ou tel service.

Pour les disques, vous pouvez créer des tâches dans le planificateur de test du menu HDD du gestionnaire de stockage, avec par exemple un test smart rapide une fois par semaine, et un test smart étendu une fois par mois. Et pour être averti du résultat du test étendu, vous validez dans l'onglet Général l'envoi du rapport de santé mensuel par email.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, Mic13710 a dit :

Pas de quoi. Un petit plus n'est pas de refus non plus :biggrin:

 

Le 23 juillet 2016 at 11:39, Mic13710 a dit :

Je pense effectivement que chacun des disques a un problème. Le 1 est OK au niveau du système et KO au niveau des données, le 2 est KO au niveau du système et OK au niveau des données.

Pour info, les disques comportent chacun 3 partitions : 1 système, 1 swap (propre à linux) et 1 donnée. La partition système fonctionne en RAID1. Si une partition tombe en panne, le système fonctionne toujours sur le ou les disques restants.

Vous pouvez donc tenter 2 choses :

1) lancer la réparation du disque 1 tout seul. Si ça passe, vous pourrez peut-être retrouver tout ou partie de vos données.

2) avec le disque 2 tout seul, tenter un double reset pour réinitialiser le DSM et le réinstaller. Cette manip ne touche pas aux données.

Si aucune des 2 fonctionne, il ne vous reste plus qu'à installer le disque dans un PC ou dans un rack et de faire la récupération des données en suivant ce tuto. Il y a probablement un disque dont la partition de données sera lisible.

Concernant les alerte, si un disque était inaccessible, le NAS a dû vous en informer mais si vos notifications ne sont pas ou mal configurées, vous n'avez pas été alerté. En tout cas, il doit y avoir obligatoirement un enregistrement dans les logs du NAS.

Pas d'inquiétude à avoir au niveau du NAS. Le 213J est tout à fait apte à faire ce que vous lui demandez. S'agissant toutefois d'un modèle de base, il peut avoir quelques ralentissements dans l'exécution de certaines tâches gourmandes en ressources. En aucun cas, il peut être la cause de la défaillance des disques. Comme je l'ai écrit, les 3To sont moins fiables que les autres et vous avez en plus un WD RED. Je ne suis pas vraiment surpris qu'ils puissent tomber en panne. La première panne est sans doute intervenue il y a quelques temps et il aurait fallu en être alerté pour faire le changement de disque.

En tout état de cause, vos 2 disques sont en défaut et il est bien entendu préférable de les changer et l'option 2x4To me semble la mieux appropriée.

 

Le 22 juillet 2016 at 23:44, Mic13710 a dit :

Vous pouvez tenter la réparation de disque dans un  premier temps.

En fait, vous avez probablement une double peine : le hdd1 a sa partition donnée qui est hs et sa partition système OK, le hdd2 a sa partition donnée ok et la partition système hs. Donc, vous ne pouvez pas tourner avec un seul disque. Comme les pannes ne surviennent jamais simultanément, vous aviez probablement un pb depuis un certain temps que vous avez laissé trainer, ce qui vous conduit à la situation présente.

Si la réparation est ok, on pourra envisager la reconstruction avec un disque neuf. Sinon, il va falloir envisager une autre option.

 

Il y a 4 heures, Mic13710 a dit :

Il faut tout d'abord activer les notifications selon vos besoins : Email, SMS, service push et sélectionner dans l'onglet "Avancé" les alertes que vous souhaitez remonter vers tel ou tel service.

Pour les disques, vous pouvez créer des tâches dans le planificateur de test du menu HDD du gestionnaire de stockage, avec par exemple un test smart rapide une fois par semaine, et un test smart étendu une fois par mois. Et pour être averti du résultat du test étendu, vous validez dans l'onglet Général l'envoi du rapport de santé mensuel par email.

Merci pour toutes ces reponses

 

benjamin

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 23 heures, Mic13710 a dit :

Pas de quoi. Un petit plus n'est pas de refus non plus :biggrin:

 

il y a une heure, lemondaft a dit :

Merci pour toutes ces reponses

 

benjamin

Quand je parlais d'un petit plus, il s'agissait des flèches en bas à droite :biggrin:

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as utilisé la fonction recherche, c'est tout à ton honneur, mais si tu ne trouve pas ta solution dans ce topic résolu, alors ouvre ton propre topic, celui ci a plus d'un  ;-)

Ps : Dommage que tu ne passes quand coup d'éclair quand tu as un problème...

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.