This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

[TUTO] VPN Server


Messages recommandés

  • Réponses 1,2k
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Préambule Le but de ce tutoriel est de vous aider à mettre en place un réseau privé virtuel (VPN) entre vous et votre NAS depuis Internet. nb : il ne s'agit pas ici de "masquer" votre adress

Je confirme la réponse de @Litsip (surtout l'aspect sécurité illusoire que vendent les fournisseurs de vpn) : exemple : http://www.numerama.com/tech/298268-la-collaboration-decriee-de-purevpn-a

@.Shad. Un énorme merci à toi pour les réglages que tu as effectué sur mon NAS. Tout fonctionne à merveille maintenant !!!! Juste à régler le synology drive comme il faut. Je vais regarder s

Posted Images

il y a une heure, oracle7 a dit :

Un autre point : dans "Panneau de configuration / Accès externe / Avancé" as-tu renseigné ton @IP fixe externe ainsi que les ports 5000 et 5001 ?

Là je ne mettrais rien pour le moment

il y a une heure, .Shad. a dit :

Dans ce cas-là il lui suffit de définir une zone DNS locale avec deux vues, une pour le VPN où il y aura un enregistrement A du NAS vers 10.8.0.1 et une pour le LAN, avec un enregistrement À du NAS 192.168.1.36

Il y a surement moyen de jouer avec les routes statiques mais je ne suis pas persuadé de leur persistance au fil des maj.

Mais la zone locale telle qu'elle est définie ne suffit-elle pas puisque que si il se connecte avec ou sans VPN, xxxx.synology.me doit renvoyer vers 192.168.1.36. Par contre je me demande si son NAS est défini quelque part comme DNS.

Dans réseau général je décocherais "configurer manuellement le serveur DNS" et dans la freebox je mettrais l'IP locale du NAS en serveur DNS avant les deux adresses de FDN

Modifié par Jeff777
Lien à poster
Partager sur d’autres sites

@Jeff777

Je me suis basé sur :

Nulle part dans ce récapitulatif il n'est fait mention d'un serveur DNS sur le NAS.
De plus le serveur DHCP de la Freebox pousse les DNS de la FDN, donc même s'il en a un il ne sert visiblement à rien ici.

Du coup j'ai regardé les pages avant, il y a effectivement une zone xxx.synology.me
Fort bien, mais celle-là ne sert certainement pas à se connecter à son VPN car pour cela quand il est en 4G il passe par les serveurs de Synology. En local, il a défini que ns.xxx.synology.me pointe vers 192.168.1.36

Dans ce cas-là il ne reste plus grand chose à faire pour que son lecteur réseau fonctionne autant en local qu'en VPN.
Il crée une zone identique, sauf que l'IP ne sera plus 192.168.1.36 mais 10.8.0.1

Il crée deux vues différentes, une qui pointe vers la zone "locale" quand l'IP source est 192.168.1.0/255.255.255.0, une qui pointe vers le l'IP VPN quand l'IP source est 10.8.0.0/24

Après cela, il n'y a plus qu'à se connecter à son lecteur réseau en entrant :

\\ns.xxx.synology.me\video

et tout devrait fonctionner.

Je n'ai pas de solution, a priori, pour le fait qu'il ne puisse pas ping l'IP locale du NAS quand il est connecté au VPN.
Il faudrait une prise en main distante pour ça.

Modifié par .Shad.
Lien à poster
Partager sur d’autres sites

@Jeff777Je ne sais pas vraiment si c'est un problème mais il me semble que j'avais vu un truc la dessus dans un post mais je ne sais plus ou, donc dans le doute j'en parle ... on ne sait jamais !

Modifié par Thierry94
Lien à poster
Partager sur d’autres sites

@Thierry94

Bonjour,

J'ai l'IPv6 d'activée chez moi et je n'ai pas relevé de dysfonctionnements liés à cela. Juste le fait que, le client OpenVPN utilise indifféremment IPv4 et IPv6 pour établir la connexion. C'est juste un constat.

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites
il y a 45 minutes, .Shad. a dit :

Nulle part dans ce récapitulatif il n'est fait mention d'un serveur DNS sur le NAS.

Oui mais  @lordatao  a fait une zone locale. Donc autant qu'elle serve et à la fin du tuto de DNS serveur est écrit N'oubliez pas de modifier votre serveur DHCP pour qu'il renseigne vos clients sur l'adresse de votre serveur DNS, ce qui parait logique.

Maintenant je m'y perds un peu. 🤪

il y a 45 minutes, .Shad. a dit :

Il crée deux vues différentes, une qui pointe vers la zone "locale" quand l'IP source est 192.168.1.0/255.255.255.0, une qui pointe vers le l'IP VPN quand l'IP source est 10.8.0.0/24

Je n'ai qu'une seule vue locale de mon côté mais j'intègre tous les sous-réseaux suivants

Capture.JPG

 

Modifié par Jeff777
Lien à poster
Partager sur d’autres sites

@oracle7 @Jeff777 @Thierry94 @.Shad.

Bon, je vois que mon cas fait grand débat 😅🧐 et je m'y perds un peu...

Je dois dire que si la modification du fichier host est suffisante et sécuriser, je ferais bien avec... 

Je vais créer les 2 vues comme le propose @.Shad.

Il y a 1 heure, .Shad. a dit :

Il crée deux vues différentes, une qui pointe vers la zone "locale" quand l'IP source est 192.168.1.0/255.255.255.0, une qui pointe vers le l'IP VPN quand l'IP source est 10.8.0.0/24

Après cela, il n'y a plus qu'à se connecter à son lecteur réseau en entrant :


\\ns.xxx.synology.me\video

J'ai assez pris de votre temps, même si en ce moment, il faut bien dire que l'on en a un peu à tuer 😅

Il y a 5 heures, lordatao a dit :

Je n'ai plus accès en local à nas_yoyo mais à 192.168.1.36 (pas très gênant en soi).

Problème réglé (mon keepass automatique avait modifié le formulaire dans DSM 😤

Lien à poster
Partager sur d’autres sites
il y a une heure, Jeff777 a dit :

Donc autant qu'elle serve

C'est justement ce que je propose. 😉 

il y a une heure, Jeff777 a dit :

Je n'ai qu'une seule vue locale de mon côté mais j'intègre tous les sous-réseaux suivants

Une seule vue c'est très pratique si tu arrives aussi bien à accéder à ton serveur VPN via son IP locale et son IP VPN, ce qui n'est pas son cas. 🙂 

Lien à poster
Partager sur d’autres sites

Il faut retirer le sous réseau 1.0.0.0/8 de la vue LAN

Le sous réseau 10.0.0.0/8 inclue le sous réseau 10.8.0.0/16 donc la système refuse de sélectionner les deux vues dans cet ordre car la vue VPN ne sera jamais utilisée

Modifié par Jeff777
Lien à poster
Partager sur d’autres sites

@Jeff777 @oracle7 @.Shad.

Je viens de retirer le sous réseau comme évoqué

Il y a 1 heure, Jeff777 a dit :

Il faut retirer le sous réseau 1.0.0.0/8 de la vue LAN

Le sous réseau 10.0.0.0/8 inclue le sous réseau 10.8.0.0/16 donc la système refuse de sélectionner les deux vues dans cet ordre car la vue VPN ne sera jamais utilisée

J'ai toujours le message suivant malgré la modification

1874266961_Capturedcran2020-11-07174417_LI.thumb.jpg.e3834319b400fd4146353fa03928d703.jpg

Je viens de me connecter en VPN et là................. Hé bien, non, toujours pas 😂 !!!!!!

Je vais modifier le fichier host, même si ce n'est pas forcement une solution en définitive, je crois que cela m'ira bien comme ça...

Lien à poster
Partager sur d’autres sites

@lordatao

Bonjour,

Tu crèes une seconde zone master à l'image de la première. La seule différence, est que tu utilises l'@IP 10.8.0.1 au lieu de 192.168.1.36.

Ensuite tu fait pointer respectivement les vues LAN et VPN sur la zone master correspondante.

Ahreeee grillé par @.Shad. 🤪

Cordialement

oracle7😉

Modifié par oracle7
Lien à poster
Partager sur d’autres sites

Bonsoir, 

J'ai une question qui tue, je test VPN Server sur mon DS918+
Le problème c'est ça : 
image.png.b650343a2acc5e5062767e78ae0d1a52.png
Comment je dois faire pour qu'une interface réseau s'affiche ? lol

Lien à poster
Partager sur d’autres sites

@GrOoT64

Bonjour,

Pourquoi n'utilises-tu pas le package VPN Plus serveur sur ton RT2600 ? Cela me semble plus simple de gérer cela directement au niveau de la porte d'entée à ton système, non ? En plus tu disposeras de fonctionnalités supplémentaires (SSL VPN par ex).

Cordialement

oracle7😉

Lien à poster
Partager sur d’autres sites

Bonjour @oracle7,

J'aime toucher à tout 😄
ça me permet aussi de pouvoir répondre au gens si besoin !

VPN Server sur mon 418play m'affiche bien une interface réseau, sur le DS120J pas de soucis non plus mais pas sur le 418+. 

Le serveur VPN sur RT2600ac fonctionne à merveille 😉 

Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.