This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Fenrir

[TUTO] DNS Server

Messages recommandés

Bonjour,

J'avais exposé mon problème il y a que temps (pages 12 et 13...) et je ne trouvais pas de solution:

Impossibilité de se connecter à mon Nas depuis un accès internet privé distant, alors qu'en 3/4g j'y arrivais très bien. Après avoir fait et refait la configuration du DNS server et suivi ce tuto et ceux liés, j'ai fini par trouver. En activant l'UPnP (juste pour voir...) j'ai découvert l'existence d'un routeur distant. Après avoir réussi à contacter un technicien réseau de mon FAI, j'ai compris... Je n'ai pas le choix, je suis abonné à un service Naviweb, avec antenne et routeur 4G. Le FAI bloque toutes les entrées sur ce réseau, par son propre routeur, par sécurité sur tout le réseau 4G. Donc à l'intérieur de la 4g ça communique, dès qu'on en sort ça bloque. La seule possibilité est donc d' acheter une IP fixe et de communiquer avec un poste distant avec aussi une IP fixe et de demander d'ouvrir cette communication poste à poste à mon FAI. Vu mes besoins, j'ai lâché l'affaire. Donc voilà c'est pas possible.

Aussi j'ai un routeur 4G Huawei B315, fourni par mon FAI, sur lequel il est impossible de fixer en dur l'adresse IP LAN du NAS (incroyable mais vrai!). Je me suis fait des noeuds au cerveau avant de comprendre. J'ai donc couper le DHCP sur le routeur, configuré manuellement le DHCP du NAS et entré un par un, manuellement les 15 clients de mon réseau local. J'ai pas trouvé mieux. Mais ça fonctionne et c'est stable. L'appli IP scanner m'a bien aidée, ainsi que SynologyAssistant.app pour retrouver mon nas...

Bon du coup, à moins de recevoir une attaque depuis l'intérieur du réseau 4G ( petit réseau exotique...), je suis bien à l'abri derrière ces deux routeurs.

Voilà je voulais partager mes avancées, si cela vous évoque des avis ou des conseils je suis preneur.

A bientôt.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 21/02/2019 à 10:07, Superthx a dit :

Donc est-ce que tout est bon Docteur ?

Non, on peut difficilement faire pire 😂

Tu dois corriger tous les avertissements et toutes les erreurs avant d'aller plus loin ... mais vu les erreurs, même après les avoir corrigés, je te déconseille de suivre la dernière partie du TUTO, tu n'as pas les connaissances nécessaires pour héberger toi même un serveur DNS public de manière fiable et sécurisée (en tout cas pour le moment, mais tu peux apprendre 😉 ).

Partager ce message


Lien à poster
Partager sur d’autres sites
Non, on peut difficilement faire pire
Tu dois corriger tous les avertissements et toutes les erreurs avant d'aller plus loin ... mais vu les erreurs, même après les avoir corrigés, je te déconseille de suivre la dernière partie du TUTO, tu n'as pas les connaissances nécessaires pour héberger toi même un serveur DNS public de manière fiable et sécurisée (en tout cas pour le moment, mais tu peux apprendre ).

Houlaaaaa....
Depuis tout est bleu. Saut pour ip v6 puisque je l’utilise pas.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 20/12/2018 à 08:25, kornfred a dit :

[...]

Il me reste juste une petite étape que j'ai du loupé et ca sera enfin fonctionnelle !!

Sur mon nas en 192.168.1.1 j'ai fais un proxy reverse déjà d' origine:

544369046_OperaInstantan_2018-12-20_082112_192_168.1.1.png.77f9ec95a100670d3604811e4db0bd3a.png

 

Maintenant le soucis .... quand je tape https://jeedom.XXXXXXXXX.fr en local ça ne marche pas mais si je tape http://jeedom.XXXXXXXXX.fr ça marche , une idée?

Bonjour,

Je me permets de citer ce message qui date de quelques pages et qui j'ai l'impression, n'a pas reçu de réponse, étant confronté au problème je rebondis.
J'ai mis en place mon résolveur dns local depuis quelques jours pour bénéficier de la redirection automatique de mon nom de domaine en fonction de l'IP source, tout marche je dois le dire très bien dès que cela concerne le NAS.
En revanche j'utilisais le reverse proxy de mon syno pour me connecter en https sur les applications hébergées sur mon raspberry pi, et depuis la mise en place du dns local, cela ne fonctionne plus.
Je pense voir où se situe le problème, en effet si je rajoute un enregistrement A du type :

pihole.domaine.tld A IP_locale_du_Pi

et que j'ai une entrée dans mon reverse proxy : https://pihole.domaine.tld:443 vers http://IP_locale_du_Pi:port j'ai l'impression que :

- soit il y a une redondance dans la direction
- soit une sorte de conflit

Avant d'utiliser le DNS en local, je gérais tout via mes enregistrements publics chez OVH, j'utilisais les profils d'accès pour limiter l'accès via le net.

Maintenant sur Chrome j'obtiens l'erreur ERR_CONNECTION_REFUSED (le site est introuvable).
Comme kornfred, en http tout fonctionne parfaitement.

Modifié par shadowking

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Je viens de passer une partie de la mâtiner et l'après-midi à tenté de bien comprendre et d'applique le tuto.

Malheureusement je suis (je pense) dans une configuration un peu différente que le tuto, ce qui m'empêche de bien comprendre et faire.

Une personne gentille aurait elle le temps de m'expliquer comment faire ?

 

Actuellement j'ai une freebox delta et un serveur raspberry avec un ndd qui pointe sur le rpi.

Je souhaite intégrer mon syno.

Et donc je dois trouver une solution pour faire cohabiter les deux serveurs sur une même ligne.

J'ai pensé au proxy reverse, mais ca ne fonctionne pas et on m'a redirigé ici.

Je souhaiterais donc utiliser un sndd.ndd.tld vers le rpi et un ndd diffèrent vers le syno.

Croyez-vous que c'est compliqué ? Devrais-je aller jusqu'à faire l'hébergement des dns moi-même ?

 

Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 31 minutes, hercut a dit :

J'ai pensé au proxy reverse, mais ca ne fonctionne pas et on m'a redirigé ici.

Un reverse proxy, c’est pourtant la bonne solution. Si ça ne marche pas c’est que tu dois manquer quelque chose. 

Le principe est le suivant : tes deux noms de domaines doivent pointer sur l’IP de ta box. Sur le routeur tu rediriges le port 443 (si tu veux accéder en https) vers le reverse proxy. Et au niveau du reverse proxy tu rediriges le premier ndd  vers l’IP/port du premier serveur et le deuxième ndd vers l’IP/port du deuxième serveur. 

Rien de bien compliqué...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 16 heures, Kramlech a dit :

Un reverse proxy, c’est pourtant la bonne solution. Si ça ne marche pas c’est que tu dois manquer quelque chose. 

Le principe est le suivant : tes deux noms de domaines doivent pointer sur l’IP de ta box. Sur le routeur tu rediriges le port 443 (si tu veux accéder en https) vers le reverse proxy. Et au niveau du reverse proxy tu rediriges le premier ndd  vers l’IP/port du premier serveur et le deuxième ndd vers l’IP/port du deuxième serveur. 

Rien de bien compliqué...

Ca fonctionne pas mal au final. J'ai réussi bien que une ou deux interrogation se pose encore 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement