This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Fenrir

[TUTO] DNS Server

Messages recommandés

il y a 9 minutes, VaMPyR a dit :

2 noms de domaine différents pour le reverse proxy : 1 pour quand je suis en local et 1 en VPN

Ah oui c'est vrai. Autre idée : jouer sur les zones du DNS Serveur. Une zone pour le LAN et une zone pour le VPN . Sur le LAN tu diriges vers 192.168.x.x et sur le VPN en 10.8.0.1

Modifié par Jeff777

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, Jeff777 a dit :

Ah oui c'est vrai. Autre idée : jouer sur les zones du DNS Serveur. Une zone pour le LAN et une zone pour le VPN . Sur le LAN tu diriges vers 192.168.x.x et sur le VPN en 10.8.0.1

oui merci je pense que c'est plus logique que de créer deux noms de domaine dans le reverse proxy.

donc en effet j'ai créé deux zones master avec le même nom de domaine, une pour le VPN et une pour le LAN.

Connecté en LAN: nslookup nas.mondomaine.xx 192.168.xx.xx

Server: UnKnown
Address: 192.168.xx.xx

Nom: ns.mondomaine.xx
Address: 192.168.xx.xx
Amiases: nas.mondomaine.xx

et si je ping nas.mondomaine.xx j'ai une réponse de 192.168.xx.xx

-------------------------------

Connecté en VPN: nslookup nas.mondomaine.xx 10.8.0.1

Server: UnKnown
Address: 10.8.0.1

Nom: ns.mondomaine.xx
Address: 10.8.0.1
Amiases: nas.mondomaine.xx

Mais là quand je ping nas.mondomaine.xx j'ai : la requête ping n'a pas pu trouver l'hôte nas.mondomaine.xx par contre si je ping 10.8.0.1 j'ai une réponse... Bizarre non sachant que le nslookup me renvoie l'adresse 10.8.0.1 pour nas.mondomaine.xx ???

EDIT c'est bon j'ai trouvé, je me suis dit qu'il ne devait pas utiliser le DNS du synology étant donné qu'il ne trouvait pas l'hote alors que le synology renvoyait la bonne ip pour mon nom de domaine avec le nslookup et j'ai donc forcé OpenVPN à utiliser le DSN du syno 10.8.0.1 avec dhcp-option DNS 10.8.0.1 et ça fonctionne 🙂

Merci Jeff777 ^^ 👍

 

Modifié par VaMPyR

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement