This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

magicoliv

Help : disque RAID en panne et pb données

Messages recommandés

Bonjour à tous,
Je me permets de vous contacter car je rencontre un problème important depuis ce matin. Je possède un syno DS214play avec 2 disques 2Tos en RAID.

Depuis ce matin un des 2 disque semble défectueux CF image ci dessous :

image.png.109caddb0123dddad3ca83ce2430e4e8.png

Les tests SMART effectués sur les 2 disques sont normaux. Il indique cependant 4 secteurs defectueix sur le disque associé au volume 1. Je suis complèement perdu car j'accède à l'ensemble des données mais à la lecture des rapports du Syo le disque fiable n'utilise que 298,6 Mo alors que le disque en panne utilise 1,4 TB alors que j'y accède sans problème.

Pourriez-vous m'aider svp?

Ci-dessous plus de précisions.

 

Merci bcp

 

Olivier

 

image.png.1b25263fc2ded11a8a693abf7140141b.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Vous faites beaucoup de confusions.

Vos deux disques sont en SHR avec protection des données (équivalent RAID1). Ce qui signifie qu'ils sont en miroir.

Sur ces disques vous avez créé 2 volumes qu'on peut assimiler à des partitions dans le monde PC. Il n'y a pas un volume sur chaque disque contrairement à ce que vous le pensez, mais 2 volumes par disque !

Ceci étant dit, votre gestionnaire de stockage indique que votre situation est beaucoup plus critique que vous ne le pensez. En effet, ce n'est pas un mais les deux disques qui sont en panne ! Qui plus est, la liste des disques constituant le SHR est limitée à un seul disque qui est rapporté comme étant en panne.

Le seul conseil que je puisse vous donner c'est de suivre les indications données par le gestionnaire : sauvegardez au plus vite vos données tant qu'il est encore temps avant de ne plus pouvoir y accéder. Sauvegardez aussi la configuration du NAS (c'est dans le menu de mise à jour et restauration).

Si après ça, le NAS fonctionne encore, vous pourrez alors tenter une opération de la dernière chance : éteindre le NAS, retirer le disque 2 qui est manifestement en panne et redémarrer avec seulement le disque 1. Avec un peu de chance, vous pourrez retrouver vos volumes (le NAS va bipper car le groupe est dégradé). Si c'est le cas, il vous suffira de monter un nouveau disque à la place du 2 pour que le SHR se reconstruise). Si vous ne retrouvez pas vos volumes, pas d'autre choix que de repartir sur une installation neuve, avec des disques neufs de préférence.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour et merci pour votre réponse rapide.

J'ai compris votre retour mais malheureusement la situation est un peu différente.

J'ai en effet effectué 3 tests :
 

Test 1 - uniquement disk 1

Résultat :
- Le système apparait comme sain (Toutes les leds du NAS sont au vert)

- 1 seul volume est visible (Volume 2)

- Plus aucune donnée n'est disponible

image.png.95ff7bfe63117bb288adfa2330f0947b.png

image.png.26adc58d7744c999c243fff2767eb712.png

 

Test 2 : Uniquement Disk 2

Résultat :
- Le système apparait comme endommagé(leds disque et statut orange clignotant)

- 1 seul volume est visible (Volume 1)

- Toutes les données sont disponibles

image.png.80c0c149e7f253ff6ac510d41be8d1a8.png

Test 3 : Les 2 disks

Résultat :
- Le système apparait comme endommagé(leds disque et statut orange clignotant / 1 disk vert)

- 2 volumes visibles

- Toutes les données sont disponibles

 

 

image.png.0db0752fa31ac3b41ea48794009dcfc7.png


image.png.4ffc317342115b720d9a5b9f192f38cd.png

image.png.51b8224b4ffce7a304612ebc1ecef8dc.png

image.png.89aa592596bf337b7719ed5a657a68f3.png

image.png.fba873c0f7b93648c8a39779f6cc33f6.png

 

Il semble qu'un disque soit sain sans aucune données ou un problème de partition et l'autre endommagé mais avec les données...

Pourriez-vous m'aider?

 

Merci beaucoup

 

Olivier

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Il y a beaucoup de contradictions dans vos captures d'écran.

Lorsque vos 2 disques sont en place, votre groupe est indiqué comme étant en SHR avec protection des données. C'est équivalent à du RAID1 et donc vos disques sont en miroir, c'est à dire que ce qui est sur le disque 1 se retrouve à l'identique sur le disque 2. Dans cette configuration, vous ne pouvez pas avoir un volume par disque, c'est totalement IMPOSSIBLE.

Ensuite, sur tous les NAS multibaie, la partition système fonctionne en RAID1, cad que tous les disques embarquent le DSM et tous ses paramètres. Tant qu'il reste un disque, le système fonctionne, à condition bien entendu que la partition système ne soit pas en panne. Ce qui est le cas de votre disque 2. Dès lors, comment avez-vous pu démarrer le NAS avec uniquement le disque 2 ?

Ce que je vois dans tout ça c'est que vos 2 disques sont en panne au niveau des partitions système et données.

Le disque 1 a sa partition système intacte mais a perdu le Volume 1

Le disque 2 a sa partition système en panne et a perdu le Volume 2

Ce qui fait que vous fonctionnez sur le système du disque 1, que vous accédez au volume 1 grâce au disque 2 et au volume 2 grâce au disque 1.

Dans votre malheur vous avez une chance innoui de pouvoir encore accéder à vos données. Mais vu l'état général, c'est sans doute pour peu de temps.

Je réitère donc ce que je vous ai dit dans mon premier post : faites une sauvegarde de vos données et de votre configuration avant de tout perdre et repartez sur une installation neuve.

Et à moins que ce soit un besoin impérieux, éviter de créer deux volumes, ça ne sert pas à grand chose. Un seul volume est plus simple a gérer et couvre les besoins dans la majorité des cas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok merci pour cette réponse. J'ai maintenant la partition système du disque 2 réparée mais cela ne résoud pas le problème. Effectivement chaque disque ne semble voir q'un volume différent d'où ma confusion.

Je me lance dans une sauvegarde générale. Une fois la sauvegarde faite, est-il possible par un moyen ou un autre d'essayer de restaurer le volume manquant sur le disque sain?

Cordialement

 

Olivier

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Vu l'état de vos disques, je ne m'aventurerais pas d'essayer une quelconque réparation. A mon avis, vous avez des blocs défectueux sur les deux disques.

Il serait plus sage de commencer par tester chaque disque sur un PC avec le logiciel constructeur (tests approfondis).

Et si seulement si les tests sont bons, vous pouvez à la limite remonter votre NAS avec vos disques.

Une question qui a son importance : est-ce que votre NAS est alimenté avec un onduleur compatible ? Si ce n'est pas le cas et que vous avez subi récemment des perturbations électriques, il se pourrait bien que vos problèmes viennent de là.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Non le NAS n'est pas alimenté avec un onduleur, cela a peut être un lien.

Je vais donc faire un test approfondi comme préconisé. Comment je procède ensuite pour remonter les disques dans le NAS? Il s'agit juste de les réinsérer après vérification ou une autre manipulation?

Partager ce message


Lien à poster
Partager sur d’autres sites

Les tests approfondis font entre autres tests une écriture de zéros sur toute la surface du disque. Ca permet de le vérifier et d'isoler les secteurs défectueux. Suite à ça, il n'y a bien évidemment plus rien sur les disques. Vous faite une installation complète du NAS.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement