This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

lucas3d

Access au client VPN depuis le réseau local du server VPN

Messages recommandés

Bonjour à tous,

Je viens d’ajouter un petit frère (DS218j) à mon DS918+ pour faire des sauvegardes “hors site” via Hyperbackup et OpenVPN.

Pour le moment, le DS218j est sur le réseau local (10.0.1.x) pour les tests, mais il connecté au server VPN du DS918+ via openVPN (10.8.1.6).
Hyperbackup marche comme un charme via l’ip 10.8.1.6, merci Synology.

Voila, en plus de sauvegarde local de Time Machine de mes Mac sur le DS918+, je voudrai faire des sauvegardes “hors site” via Time Machine aussi sur le DS218j.
Le problème est que le DS218j est sur un autre réseau (le VPN), non accessible depuis mon réseau local.

Le DS218j voit très bien mon réseau local en passant par le VPN, ce qui n'aide pas pour ma problématique.

J’ai réalisé un petit graphique pour cela soit plus claire.

Merci d’avance de votre aide.

diagramVPNRemote.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Pour la sauvegarde TM depuis les Mac, il faut que le routeur sache trouver le DS218j

Il faut donc sur le routeur 10.0.0.1, ajouter une règle qui route le sous réseau 10.8.0.x vers la gateway 10.0.1.9

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, StéphanH a dit :

Pour la sauvegarde TM depuis les Mac, il faut que le routeur sache trouver le DS218j
Il faut donc sur le routeur 10.0.0.1, ajouter une règle qui route le sous réseau 10.8.0.x vers la gateway 10.0.1.9

Bonjour Stephan,

Merci beaucoup de ta réponse rapide !!

Je crains malheureusement que mon routeur, un Airport Extreme le dernier modèle, ne supporte pas ce genre de choses:

https://discussions.apple.com/thread/5586692

A moins que je n'ai pas compris ta réponse (ce que je souhaite :-)

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 2018-01-31 à 09:05, StéphanH a dit :

Peut-être y a-t-il un autre moyen : Monter le répertoire TM du DS218j sur le DS918+, et y accéder depuis tes Macs comme un répertoire du LAN.

Merci pour cet autre moyen.

Entre temps, j'ai cassé ma tirelire pour un Ubiquiti Unifi USG (https://www.ubnt.com/unifi-routing/usg).
Il me permettra beaucoup plus de choses que mon "vieux Airport Extreme". Des que je le reçois, je tenterai ta premiere solution.

Plus, je me plonge dans ces passionnantes connaissances réseau, plus je me rend compte que j'ai tout a apprendre :-)
 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 2018-01-29 à 04:38, StéphanH a dit :

Pour la sauvegarde TM depuis les Mac, il faut que le routeur sache trouver le DS218j
Il faut donc sur le routeur 10.0.0.1, ajouter une règle qui route le sous réseau 10.8.0.x vers la gateway 10.0.1.9

Merci @StéphanH de ta suggestions, cela marche parfaitement !!!

PS: Je l'adore ce "petit" Unifi USG !!!

5a7fdaa784dab_Screenshot2018-02-1100_53_02.thumb.jpg.56dd63cf95c7fc0272e08ed7aff62781.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Désolé de déterrer un peu ce topic mais j'ai exactement le même besoin que @lucas3d entre un DS218+ (maison) et un DS118 (maison amis), voici le schéma  (Merci @lucas3d !)

image.png.df91a93485d6a69320d387398007e181.png

J'ai donc défini un route statique sur mon routeur comme suit :

image.png.49f59cee69e0c60c1ab0c3c0ac5664b8.png

 

Mais je n'arrive pas à joindre le DS118 chez mes amis depuis une machine de mon réseau (chez moi). 

Par exemple : alors que j'arrive à bien à joindre 192.168.5.1 depuis la machine 192.168.1.20, voici ce que donne un tracert vers DS118  :

C:\Users\ben>tracert 192.168.5.4

Détermination de l’itinéraire vers BRAVO [192.168.5.4]
avec un maximum de 30 sauts :

  1     *       <1 ms    <1 ms  WRT [192.168.1.1]
  2     1 ms     1 ms     1 ms  ALPHA [192.168.1.10]
  3     *        *        *     Délai d’attente de la demande dépassé.
  4     *        *        *     Délai d’attente de la demande dépassé.
  5     *        *        *     Délai d’attente de la demande dépassé.
  6     *        *        *     Délai d’attente de la demande dépassé.
  7     *        *        *     Délai d’attente de la demande dépassé.
  8     *        *        *     Délai d’attente de la demande dépassé.
  9     *        *        *     Délai d’attente de la demande dépassé.
 10     *        *

Au passage je ne sais pas comment il peut trouver le nom du serveur qu'il affiche correctement (BRAVO).

Je vous remercie beaucoup de vos lumières (les miennes sont grillées depuis longtemps).

 

Modifié par ben9111

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

En mettant le serveur VPN sur le NAS "ami" et ton NAS comme client, cela fonctionnera (avec une règle de routage sur ton ton routeur perso du masque 192.168.x.0/255.255.255.0 vers la gateway 192.168.5.1
(192.168.x.0 est le masque du réseau local "Ami". il faut que x soit différent de 1 et de 5 ...)

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci beaucoup StéphanH pour ta réponse rapide.

En fait j'ai besoin d'avoir le serveur de mon coté car j'ai un autre serveur (domotique) auquel j'ai besoin d'avoir accès de l'extérieur et DSM n'accepte pas d'être configuré en client (dans configuration/réseau) en même temps qu'un VPN soit actif dans le paquet VPN server.

De plus mon routeur n'accepte pas de passerelle autre que sur son réseau 192.168.1.0....

Pourtant ça devrait marcher il me semble avoir bien appliqué ce que tu disais au début

Le 29/01/2018 à 10:38, StéphanH a dit :

Bonjour,

Pour la sauvegarde TM depuis les Mac, il faut que le routeur sache trouver le DS218j

Il faut donc sur le routeur 10.0.0.1, ajouter une règle qui route le sous réseau 10.8.0.x vers la gateway 10.0.1.9

 

Partager ce message


Lien à poster
Partager sur d’autres sites

A ma connaissance, depuis le serveur VPN, on ne peut pas atteindre le LAN d'un serveur Client.

Ne peux tu pas dédier un port particulier à ton serveur Domotique et le Nater dans ton routeur ? La connexion n'est pas sécurisée ?

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est l'inverse que je voudrais faire : atteindre le NAS distant client VPN depuis n'importe quelle machine de mon LAN où est situé le serveur VPN. Je ne cherche pas accéder au LAN de mes amis.

Voila mon raisonnement actuel :

je ne suis pas un spécialiste alors je m'excuse par avance si je te fais saigner les yeux ... mais suis preneur de toute information

j''ai configuré cette route sur mon routeur (🙄) :

image.png.dd4f82cc179c99e0f9381dec77831eff.png

- Un tracert depuis une machine de mon LAN montre que le paquet va bien jusqu'au NAS (serveur VPN) mais qu'il ne sait pas quoi en faire

  C:\Users\ben>tracert 192.168.5.4
Détermination de l’itinéraire vers BRAVO [192.168.5.4]
  1     *       <1 ms    <1 ms  WRT [192.168.1.1]
  2     1 ms     1 ms     1 ms  ALPHA [192.168.1.10]
  3     *        *        *     Délai d’attente de la demande dépassé.

- J'ai donc essayé de configurer une route sur le NAS (panneau de configuration/réseau/route statique) mais DSM ne me permet pas de choisir le VPN comme interface de destination

- En passant en SSH sur le serveur VPN voila ce que j'obtiens :

root@Alpha:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.5.0     192.168.5.2     255.255.255.0   UG    0      0        0 tun0
192.168.5.2     0.0.0.0         255.255.255.255 UH    0      0        0 tun0

Tiens donc : on voit apparaître 192.168.5.2 ! (d'où elle sort cette adresse ?)

- Je cherche donc à changer ça pour 192.168.5.1 (IP VPN du serveur VPN), cette adresse pinge bien depuis les machines de mon LAN avec un coup de bol elle fera bien la passerelle vers mon NAS distant.

 Pour l'instant je google pas mal car il y a cette erreur quand j'essaye de mettre en place la dernière ligne de routage (192.168.5.1     0.0.0.0         255.255.255.255 UH    0      0        0 tun0)

root@Alpha:~# route add -host 192.168.5.1 gw 0.0.0.0 dev tun0
SIOCADDRT: Invalid argument

- J'irai voir aussi du coté des options d'openvpn plus tard

 

Le schéma pour plus de clarté :

image.png.df91a93485d6a69320d387398007e181.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, ben9111 a dit :

Un tracert depuis une machine de mon LAN montre que le paquet va bien jusqu'au NAS (serveur VPN) mais qu'il ne sait pas quoi en faire

C'est bien cela le problème.
Supposons que tu aies plusieurs clients connectés au Serveur VPN, comment le NAS pourrait-il choisir la bonne route ?

Je comprends bien que c'est ce que tu souhaites, mais je doute que cela fonctionne. 

Partager ce message


Lien à poster
Partager sur d’autres sites

heu ... non d'après le titre et le schéma de @lucas3d. J'ai bien la même architecture et le même besoin.

C'est pas grave je vais continuer de chercher. Je te remercie en tout cas pour le temps que tu m'as consacré !

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne peux pas faire le test, n'ayant pas de routeur permettant cela.

mais vu ton précédant tracert, ne devrais tu pas entrer une règle statique dans le 218+ qui envoie 192.168.5.0/255.255.255.0 sur l'IP virtuelle VPN du 218j ?

Modifié par StéphanH

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Ben,

Cela faisait un moment que je n’étais pas passé ici.

Ton problème a été résolu?


heu ... non d'après le titre et le schéma de@lucas3d. J'ai bien la même architecture et le même besoin.
C'est pas grave je vais continuer de chercher. Je te remercie en tout cas pour le temps que tu m'as consacré !
 




Sent from my iPhone using Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant