This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Balooforever

[TUTO] Installer Bitwarden

Messages recommandés

 

il y a 33 minutes, cyborg a dit :

Réinstallation effectuée - Tout est OK 

Bon et bien super !

il y a 17 minutes, Balooforever a dit :

Le tuto n est plus de moi 😄

C'est tout comme 😉

Modifié par Zeus

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour Heimdall, j'ai ma propre page html et javascript qui gère mes raccourcis persos. Je tape un mot et je fais entrer et ça redirige automatiquement sur un site configuré.

Pour les RSS,  j'ai bien un service mais en réalité, il faudrait que je le vire parce que je l'utilise jamais.

Quant à Bitwarden, c'est juste le pied et les 10 euros premium valent vraiment le coup quand je vois le travail du développeur.

Sans compter la fonction via smartphone pour remplir les champs, c'est top 🙂

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Après avoir suivi le tuto (et galérer un peu comme tous le monde...) j'ai enfin une instance de bitwarden fonctionnelle sur mon syno. Par contre je sèche complétement sur la partie envoi de mail. J'ai essayé avec le serveur smtp d'orange (chez qui je suis), avec le serveur smtp d'ovh chez qui est hébergé mon nom de domaine et j'ai un message d'erreur abscon.

2019-01-18 15:25:26.886 +00:00 [Error] Mail send failed.
System.Net.Mail.SmtpException: Syntax error, command unrecognized. The server response was:
   at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
   at System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
   at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)

 

si l'un de vous a trouvé le truc, je suis preneur

 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 21 minutes, zerda a dit :

Hello,

Après avoir suivi le tuto (et galérer un peu comme tous le monde...) j'ai enfin une instance de bitwarden fonctionnelle sur mon syno. Par contre je sèche complétement sur la partie envoi de mail. J'ai essayé avec le serveur smtp d'orange (chez qui je suis), avec le serveur smtp d'ovh chez qui est hébergé mon nom de domaine et j'ai un message d'erreur abscon.

2019-01-18 15:25:26.886 +00:00 [Error] Mail send failed.
System.Net.Mail.SmtpException: Syntax error, command unrecognized. The server response was:
   at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
   at System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
   at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)

 

si l'un de vous a trouvé le truc, je suis preneur

 

bon finalement j'ai trouvé , fallait pas prendre les paramètres préconiser par orange : ssl a false et port 587 au lieu de 465 😉

 

image.png.75f585b7ce1978f598998782fb9473ac.png

Partager ce message


Lien à poster
Partager sur d’autres sites

effectivement mais bon le risque est il important ?

- pour la partie validation du mail utilisateur : je ne pense pas puisqu'il faut entrer son mot de passe mettre par la suite

- pour la partie login du portail admin : peut être. point à creuser effectivement

 

est ce que le serveur ovh permet une authentification avec  ssl à true ?

 

sinon bitwarden est top et fonctionne niquel sur le syno. J'ai ajouté un loopback sur le serveur dns du syno pour mon domaine bitwarden.domaine.com afin qu'il n'y ait pas besoin de jongler entre l'@ du serveur en local ou extérieur !

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 17/10/2018 à 12:20, Zeus a dit :

Bon je reviens après une réinstallation complète afin de comprendre et c'est bon ça fonctionne. Même les notifications par mail 😊

Le soucis chez Bitwarden c'est qu'au niveau ergonomie d'utilisation et fonctionnalités, ils sont au top mais alors question installation, c'est du grand n'importe quoi ! Il faut ajouter des dossiers soit même mais après que le système n'est pas réussi à s'installer en nous disant qu'il manque ceci ou cela dans la fenêtre SSH. Comme si il ne savait pas créer lui même les dossiers manquants. Ensuite, les dossiers changent aussi d'emplacement etc... Bref, du n'importe quoi !

Au niveau notifications, le système va récupérer les informations dans le fichier "global.override.env" et les dupliquer à différents endroits sur les autres containers. Si on a le malheur de lancer Bitwarden dès le départ sans éditer le fichier "global.override.env", c'est mort ! Avant, on pouvait encore changer les choses en éditant un par un les containers qui avait récupérés ces informations mais suite à une des dernière maj, ce n'était plus possible ou en tout cas, je n'y arrivais plus. Bref, voilà les nouvelles étapes pour installer proprement Bitwarden :

@Balooforever, si tu veux éditer ton  tuto, tu peux reprendre toute la partie ci-dessous qui normalement est correcte si j'ai rien oublié. Je vais reprendre pas à pas ma fenêtre ssh.

 

*****************************************************

 

Créer un dossier "bitwarden" dans le dossier "docker" dans FileStation.
Créer un sous domaine pour votre instance bitwarden et faites en sorte que le certificat SSL de Let's Encrypt soit fonctionnel (rien à faire pour les certificats wildcard).
Aller sur le site de Bitwarden afin d'obtenir un ID :
https://bitwarden.com/host
Entrer une adresse mail valide et copier :

ID d'installation : xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Clé d'installation : xxxxxxxxxxxxxxx

Maintenant connecter vous en SSH (voir mon tuto si vous ne savez pas faire).
Rendez-vous ici : cd /volumeX/docker/bitwarden

Nous allons maintenant récupérer le script d'installation et le mettre dans le dossier bitwarden fraichement créé :


curl -s -o bitwarden.sh https://raw.githubusercontent.com/bitwarden/core/master/scripts/bitwarden.sh&& sudo chmod u+x bitwarden.sh

 

Puis on lance l'installation :


./bitwarden.sh install

 

Pendant l'installation, nous allons devoir répondre à quelques questions (moins qu'auparavant) :

*Les lignes en rouge  seront les messages du système au fur et à mesure de l'installation !

(!) Enter the domain name for your Bitwarden instance (ex. bitwarden.company.com): sousdomaine.domaine.tld

(!) Do you want to use Let's Encrypt to generate a free SSL certificate? (y/n): n

(!) Enter your installation id (get at https://bitwarden.com/host): xxxxxxxxxxxxxx

(!) Enter your installation key: xxxxxxxxxxxxx

(!) Do you have a SSL certificate to use? (y/n): y

!!!!!!!!!! NOTE !!!!!!!!!!
Make sure 'certificate.crt' and 'private.key' are provided in the
appropriate directory before running 'start' (see docs for info).

(!) Is this a trusted SSL certificate (requires ca.crt, see docs)? (y/n): y

Installation complete

If you need to make additional configuration changes, you can modify
the settings in `./bwdata/config.yml` and then run:
`./bitwarden.sh rebuild` or `./bitwarden.sh update`

Next steps, run:
`./bitwarden.sh start` and then `./bitwarden.sh updatedb`

 

Rendez-vous dans FileStation mais ne fermez pas votre fenêtre SSH.

Nous allons renommer et copier les fichiers du certificat dans le bon dossier :

privkey.pem vers /volumeX/docker/bitwarden/bwdata/ssl/votredomaine/private.key
cert.pem vers /volumeX/docker/bitwarden/bwdata/ssl/votredomaine/certificate.crt
chain.pem vers /volumeX/docker/bitwarden/bwdata/ssl/votredomaine/ca.crt

 

Nous allons maintenant créer les dossiers qui seront manquants pour la suite de l'installation :

/volumeX/docker/bitwarden/bwdata/logs

/volumeX/docker/bitwarden/bwdata/logs/admin

/volumeX/docker/bitwarden/bwdata/logs/api

/volumeX/docker/bitwarden/bwdata/logs/icons

/volumeX/docker/bitwarden/bwdata/logs/identity

/volumeX/docker/bitwarden/bwdata/logs/mssql

/volumeX/docker/bitwarden/bwdata/logs/nginx

/volumeX/docker/bitwarden/bwdata/logs/notifications

 

/volumeX/docker/bitwarden/bwdata/core

/volumeX/docker/bitwarden/bwdata/core/attachments

 

/volumeX/docker/bitwarden/bwdata/mssql

/volumeX/docker/bitwarden/bwdata/mssql/data

/volumeX/docker/bitwarden/bwdata/mssql/backups

 

Nous allons éditer le fichier "global.override.env" qui se trouve dans "/volumex/docker/bitwarden/bwdata/env" afin de configurer le serveur SMTP pour que Bitwarden puisse envoyer les notifications. On va en profiter pour inscrire notre adresse mail pour la partie admin 😉

Qnwl3Pl.png

 

Il faut maintenant finir de configurer manuellement le fichier "config.yml" qui se trouve dans "/volumex/docker/bitwarden/bwdata" :

Par défaut, les ports sont 80 et 443 mais en général, ils sont déjà utilisés sur DSM alors on va en mettre d'autres. Pour ma part, j'ai choisi le port 81 et 444.

jssCl44.png

 

On retourne dans notre fenêtre SSH et on lance ensuite ces commandes une par une  :


./bitwarden.sh update

./bitwarden.sh updatedb

./bitwarden.sh start

Si ces commandes ne fonctionnent pas, faites d'abord :


./bitwarden.sh rebuild


TUTORIEL FINI 🙂

 

 

 

Un grand (grand) merci pour le tutoriel à jour qui fonctionne parfaitement ! 

Mon seul soucis concerne l'impossibilité de me connecter via l'appli Android qui me donne l'erreur suivante : "There is a problem connecting to the server." , alors que cela fonctionne parfaitement avec iOS ou via n'importe quel navigateur.

Dans les paramètres de l'application j'ai bien renseigné l'url du serveur avec mon nom de domaine + port 444 et  j'utilise un certifical SSL Let's Encrypt.

 

Est-ce que quelqu'un à rencontré le même problème ?

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je suis passé récemment (un moi environ) sur un téléphone sous Android et j'ai quitter le monde téléphone à la pomme et je n'ai rencontré aucun soucis avec l'application Bitwarden sur Android.

Bizarre ton soucis si ton instance Bitwarden est fonctionnelle. Après pour ma part, je fonctionne avec le port 443 via proxy inversé donc je sais pas si ton soucis viendrait de là ou non.

Si tu es seul sur ton instance, retente une installation en supprimant tout au préalable  et en n'oubliant pas de sauvegarder ta bdd depuis un bitwarden fonctionnel (ordinateur par exemple).

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant