This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Stixen92

WebDav et Windows 10: Pas bon...

Messages recommandés

Bonjour,

Cela fait un moment que je cherche comment accéder à mes fichiers sur mon NAS avec WebDav depuis Windows 10.

(Actuellement j'y accède avec Samba)

Je sais qu'on peut le faire avec NetDrive mais celui-ci est payant.

Je tente de mapper un lecteur au serveur WebDav de mon NAS en entrant les paramètres suivants

Lecteur : Z

Dossier: https: 192.168.2.128:5006/Fichiers-Perso/

Windows me demande ensuite de m'authentifier. Chose que je fais. Mais j'obtiens le message d'erreur suivant: "Échec d'ouverture session sur le réseau"

 

Je n'utilise pas de nom de domaine car j'accède à mon NAS depuis l'extérieur en passant uniquement par le VPN intégré.

 

Des solutions/pistes pour que je puisse accéder à mes fichiers sur le serveur WebDav de mon NAS depuis Windows 10?

 

Merci

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Là je ne comprends pas très bien. Pourquoi passer par Webdav à partir d'une adresse privée alors qu'il serait beaucoup plus simple de monter un simple lecteur réseau ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Le SMB passe mal lorsque j'y accède depuis mon VPN. Moins bon débits vidéos que le WebDav.

 

Alors tu sais comment faire pour le WebDav en local sous Windows 10 sans passer par NetDrive?

 

PS: Je ne comprends pas pourquoi les vidéos sur mon NAS rament en lecture lorsque j'y accède avec mon PC depuis l'extérieur (4G) via le VPN du NAS alors qu'avec la même config sur smartphone Android elles sont lues nickel...Où est-ce que ça coince?

Modifié par Stixen92

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'ai jamais fait du Webdav sur un réseau local (..) et je n'utilise plus webdav depuis bien longtemps.

Et si on arrive à faire du Webdav sur un réseau local, si le VPN est lent, je ne pense pas qu'en y ajoutant du Webdav ça va mieux marcher.

Et en passant via les applis Syno (Video Station en l’occurrence) ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @Mic13710

Pareil en passant par VideoStation, toujours des lenteurs...La vidéo rame.  Et en plus,  il refuse de lire certaines de mes vidéos en .mkv (via Firefox et Chrome).

Une solution?

Modifié par Mic13710
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Citation

Une solution?

Oui, arrêter d'utiliser WebDAV sur un réseau local... Faire un simple montage de lecteur réseau et si ça fonctionne pas alors passer par Synology Assistant pour le faire !

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 19 minutes, Zeus a dit :

Bonjour,

Oui, arrêter d'utiliser WebDAV sur un réseau local... Faire un simple montage de lecteur réseau et si ça fonctionne pas alors passer par Synology Assistant pour le faire !

@Zeus

Mais quel est le problème de WebDav en local? Cela marche très bien sur smartphone. Sur PC je n'ai pas réussi à l'installer et c'est pour cela que je demande votre aide... Pour installer WebDav en local sur mon PC.

 

Actuellement j'utilise du SMB3 sur Windows 10. En local ça marche bien, mais si j'utilise le SMB3 sur mon PC avec une connexion 4G+VPN Nas = Lenteurs... Même sur des fichiers 720p.

La même chose en WebDav sur mon smartphone est fluide...

Partager ce message


Lien à poster
Partager sur d’autres sites

A mon avis, c'est plus un problème de qualité de réseau qu'une histoire de VPN. Une fois le tunnel établi, le véritable frein c'est le réseau. S'il est bon, vous devriez pouvoir communiquer sans trop de problème avec votre NAS. Après, tout dépend ce que vous appelez lent. Il est toujours très difficile, voire impossible, de lire des videos de manière fluide avec une connexion adsl.

P.S. : merci de ne pas citer inutilement les messages précédents.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Mic13710

Mon NAS est derrière une connexion Fibre  avec un débit montant de 300 Mégas.

La connexion 4G tourne autour de 45 Mégas.

Si le problème venait de la connexion, j'aurais le même souci sur mon smartphone. Ce qui n'est pas le cas!

Pour résumer:

Lecture d'une vidéo (fichier 1 Go) sur mon NAS (protocole WebDav) depuis mon Galaxy S7 Edge avec connexion 4G + VPN = OK

Lecture d'une vidéo (fichier 1 Go) sur mon NAS (protocole SMB) depuis mon PC Windows 10 avec connexion 4G + VPN = Lenteurs. La vidéo s'arrête toutes les 10 secondes.

 

Donc je pense que le souci vient du protocole SMB trop lent en dehors du local.

Mais hormis NetDrive, comment faire pour avoir une connexion WebDav en local avec Windows 10? Car j'ai eu beau chercher, pas de réponse.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

dans Windows, https= certificat valide (cad non autosigné)

comme tu n'y accèdes que sur le réseau interne ou VPN, essaye en http.

je viens de me connecter depuis le boulot sur mon nas en webdav:

https (certificat letsencrypt)/ reverseproxy vers webdav en interne. focntionne du premier coup

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Brunchto

Comment tu fais exactement? Cela ne marche pas chez moi alors que j'ai un certificat Let's Encrypt sur mon NAS.

J'accède à mon NAS (depuis l'extérieur) via le VPN intégré de DSM.

J'ai essayé ça sous Windows:

https://192.168.XX.XX/Nom_Dossier/

et

http://192.168.XX.XX/Nom_Dossier/

Malheureusement, cela ne fonctionne pas... Pourquoi?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@Brunchto J'ai activé le http pour WebDav, j'ai rajouté le port dans l'adresse mais Windows refuse toujours de le mapper à un lecteur réseau... Pas normal ça...

 

Question HS: Même si le certificat SSL est pour un nom de domaine, il sécurise quand même les données échangées en local entre mon PC et mon NAS (192.168.XX.XXX)?

Modifié par Stixen92

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je voudrais également me passer de netdrive, ou tout autre application payante. Je souhaiterai me connecter à distance à un dossier du nas, et que celui ci s'affiche dans l'explorateur de windows comme un HDD. J'ai créé un nom de domaine, activé le service webdav, configuré le syno comme préconisé sur les différents fils, sécuriser l'accés, dns server, reverse proxy, et tente sans sucés de monter un lecteur réseau.

Est ce que je fais fausse route de vouloir configurer depuis cette option?

k7ti.png

Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Mic13710Un membre de ce même forum m'avait affirmé le contraire... Comme quoi un un certificat SSL même lié à un nom de domaine crypte, malgré l'erreur affichée dans la navigateur, mes échanges entre mon IP privé (NAS/DSM) et mon PC... C'est donc faux?

 

@Hitman_11  Idem, tout essayé et rien ne marche...

 

HELP...

 

Merci aux modos d'avoir récupéré le topic que j'avais supprimé par erreur 😉

Modifié par Stixen92

Partager ce message


Lien à poster
Partager sur d’autres sites

ce n'est pas le pb de crypter ou pas. le fait d'avoir une erreur de validation du certificat est bloquant dans notre cas. il n'y a pas de case à cocher qui dise, "je m'en tamponne si le certificat ne peut être validé"

tout ça parce qu'on a jugé bon, il y a longtemps de lier le cryptage du transfert et l'authentification de la source...

bref… 

dans la zone de texte, tu saisis Cet ça marche pas?

@Hitman_11

soit le domaine toto.fr

webdav.toto.fr pointe vers le nas (IP webdav.toto.fr = IP externe de ton NAS)

un certificat couvre toto.fr et webdav.toto.fr

ta box IP externe https vers IP du nas https

sur le nas

serveur webdav activé, http 5005

reverse proxy sur le nas:

webdav.toto.fr port 443 vers IP_DU_NAS port 5005

vérifier les droits de utilisateurs à utiliser le webdav

fini

 

 

Modifié par Brunchto

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Brunchto a dit :

ce n'est pas le pb de crypter ou pas. le fait d'avoir une erreur de validation du certificat est bloquant dans notre cas. il n'y a pas de case à cocher qui dise, "je m'en tamponne si le certificat ne peut être validé"

tout ça parce qu'on a jugé bon, il y a longtemps de lier le cryptage du transfert et l'authentification de la source...

bref… 

dans la zone de texte, tu saisis "http://IP_DE_MON_NAS:PORT_WEBDAV_HTTP" et ça marche pas?

@Brunchto

Oui, j'ai essayé à plusieurs reprises et cela ne marche pas 😞

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, Stixen92 a dit :

Un membre de ce même forum m'avait affirmé le contraire...

C'est une erreur. Fort heureusement, un certificat n'est pas échangeable, sinon il servirait à quoi ? Il n'est valable que pour le domaine et les autres noms du domaine pour lequel il a été créé. Ainsi, le certificat créé sur le NAS avec un domaine ne fonctionne qu'avec ce domaine (Synology ou autre). Mais vous pouvez parfaitement utiliser le certificat par défaut du NAS (celui qui est inclus dans DSM) pour les connexions qui ne seraient pas couvertes par le certificat du domaine.

Il y a 2 heures, Brunchto a dit :

un certificat couvre toto.fr et webdav.toto.fr

A condition que webdav.toto.fr soit dans le SAN.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Mic13710 Donc si je comprends bien, lorsque je me connecte à mon NAS en WebDav HTTPS (local) depuis mon téléphone avec le certificat SSL (de mon nom de domaine), ma connexion n'est pas chiffrée?

Idem lorsque je me connecte à DSM (HTTPS) en local depuis mon PC avec le certificat SSL (de mon nom de domaine)?

 

Le certificat par défaut du NAS? Il chiffrera la connexion entre mon NAS et mon PC même en local?

Je ne l'ai plus je crois. Je peux le régénérer?

 

Modifié par Mic13710
inutile de répéter le message précédent si ça n'apporte rien de plus à la compréhension

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 15 heures, Brunchto a dit :

ce n'est pas le pb de crypter ou pas. le fait d'avoir une erreur de validation du certificat est bloquant dans notre cas. il n'y a pas de case à cocher qui dise, "je m'en tamponne si le certificat ne peut être validé"

tout ça parce qu'on a jugé bon, il y a longtemps de lier le cryptage du transfert et l'authentification de la source...

bref… 

dans la zone de texte, tu saisis Cet ça marche pas?

@Hitman_11

soit le domaine toto.fr

webdav.toto.fr pointe vers le nas (IP webdav.toto.fr = IP externe de ton NAS)  Peux tu être un peu plus explicite, ou bien me rediriger vers le chapitre d'un tuto que je puisse lire la procédure pas à pas?

un certificat couvre toto.fr et webdav.toto.fr

ta box IP externe https vers IP du nas https. La aussi j'ai besoin d'une explication.

sur le nas

serveur webdav activé, http 5005

reverse proxy sur le nas:

webdav.toto.fr port 443 vers IP_DU_NAS port 5005

vérifier les droits de utilisateurs à utiliser le webdav

fini

 

 

Bonjour,

Merci, Brunchto, mais j'ai oublié de préciser que je n'y connais absolument rien, je suis parvenu au résultat actuel grâce aux divers tutoriels, mais surtout grâce à l'aide précieuse de Zeus qui à pris du temps pour bien me mâcher le travail.

Modifié par Hitman_11

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, Stixen92 a dit :

Donc si je comprends bien, lorsque je me connecte à mon NAS en WebDav HTTPS (local) depuis mon téléphone avec le certificat SSL (de mon nom de domaine), ma connexion n'est pas chiffrée?

Il ne faut pas tout confondre : un certificat n’a jamais rien chiffré. C’est le fait de faire une requête en https qui chiffre la communication. Pas besoin de certificat pour cela. 

Le certificat ne sert qu’a établir une relation de confiance entre les deux personnes qui communiquent ( cela ne sert à rien d’etablir une connexion chiffrée entre toi et ton interlocuteur si au lieu de communiquer avec ta banque tu parles à un obscur hacher russe ...)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant