This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Stixen92

WebDav et Windows 10: Pas bon...

Messages recommandés

Webdav en HTTPS avec windows 7 nécessite que le certificat du NAS soit chargé le le PC mais aussi que le certificat de l'autorité de certification le soit aussi donc il faut charger les deux si c'est un certificat autosigné

Et il faut aussi d'assuré que webdav server et eventuellement le site via reverse proxy utilise le bon certificat

Et dernier détail il faut faire attention au firewall du PC qui peut bloquer le port 5005/6

Modifié par bugs denis

Partager ce message


Lien à poster
Partager sur d’autres sites

@bugs denis

Mon certificat est un certificat Let's Encrypt donc pas autosigné.

Avec une application comme NetDrive (payante), j'arrive à monter sans problème un lecteur WebDav en local, avec ou sans SSL.

Mais avec Windows, impossible...

Mon Firewall est correctement configuré.

Partager ce message


Lien à poster
Partager sur d’autres sites

As tu fait des modification dans la registry comme indiqué ici ? https://confluence.atlassian.com/confkb/unable-to-authenticate-while-mapping-a-webdav-client-network-drive-in-confluence-200705136.html

J'ai une piste, quel niveau de profil SSL/TLS utilises tu ? Chez moi en compatibilité moderne cela ne fonctionne pas mais en intermédiaire cela fonctionne

image.png.d9d5fbf2b3181a959f1d84e2143419b1.png

Modifié par bugs denis

Partager ce message


Lien à poster
Partager sur d’autres sites

@bugs denis

Oui et malheureusement cela ne fonctionne pas en HTTPS (message d'erreur "Échec d'ouverture de session sur le réseau").

Mais en HTTP cela fonctionne.

Comment faire en sorte que cela fonctionne en HTTPS?

Le certificat est un certificat Let's Encrypt pour mon nom de domaine.

 

EDIT: Les fichiers vidéos refusent de s'ouvrir (message d'erreur: Fichier introuvable"... LOL...)

Modifié par Stixen92

Partager ce message


Lien à poster
Partager sur d’autres sites

 

Qu'entres tu comme adresse pour l'https ? une IP locale https://192.168.2.128:5006/Fichiers-Perso/

ou  un nom de domaine https://nom.domaine.fr:5006/Fichiers-Perso/

Ou

https://reverseproxy.domaine.fr/Fichiers-Perso/

Modifié par bugs denis

Partager ce message


Lien à poster
Partager sur d’autres sites

Quand tu as créé ton certificat, quel domaine et alias as tu indiqué ? Normalement avec Let's Encrypt on ne peut pas donner d'adresse local. Windows ne se contente pas seulement de crypter l'échange de données, il vérifie aussi le certificat et le nom du site visité. 192.168.1.xxX ne fait pas partie du cerfiticat donc Windows dit NIET ce n'est pas le site certifié et sortie immédiate.

En VPN tu utilise aussi l'IP numérique ?

 

Modifié par bugs denis

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant