This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

j3r3m51

Impossible de voir les enregistrements en HTTPS

Messages recommandés

Bonjour à tous,

Je rencontre un léger problème avec Surveillance Station depuis la redirection automatique HTTP->HTTPS mise en place sur mon NAS.

Dans le Portail des Applications, le reverse proxy est configuré pour les applications DSM, dont Surveillance Station.

En tenant compte des conseils de Fenrir sur son post très utile sur la sécurisation de son NAS, la redirection automatique HTTP->HTTPS du NAS est désactivée et j'ai mis en place ce petit script sur la page index.php de Web Station :

Citation

 

<?php
$http_host = $_SERVER['HTTP_HOST'];
if ($_SERVER['HTTPS'] != 'on')
{
  header("Location: https://$http_host",TRUE,301);

  exit;
}
?>

 

Seulement, je ne peux plus accéder aux enregistrements effectués lorsque j'accède à Surveillance Station via https://cams.mondomaine.fr (même au sein de mon réseau local), ce qui fonctionnait avant de mettre en place la redirection automatique. Par contre, ce qui est étrange, c'est que je peux accéder aux enregistrements en LAN via l'adresse IP du NAS, sur le port 5001.

Il semblerait donc qu'il y ait un soucis lors de l'utilisation du sous-domaine, mais uniquement pour l'accès aux enregistrements de Surveillance Station. Aucun problème sur les autres applications.

 

Auriez-vous éventuellement une idée de la problématique, s'il-vous-plaît?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Quand tu dis que tu ne peux plus voir les enregistrements, tu veux dire que tu les vois en miniatures mais tu ne peux plus les lires ?

Si tel est le cas, n'y aurait-il pas un soucis comme sous Vidéo Station à savoir qu'il faut dans le reverse proxy réglé le service sur le port https et non http comme les autres. Soucis d'ailleurs remonté à Synology mais jamais réglé.

Sur Vidéo Station :

  • Si reverse proxy sur port http en local, les vidéos ne sont pas lues.
  • Si reverse proxy sur port https en local, les vidéos sont lues.

Ça te coute rien de faire l'essai à part un petit changement dans ta règle.

Modifié par Zeus

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant