This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Jibe75

PB copie nom trop long

Messages recommandés

Bonjour la communauté, 

 

j'ai une question à vous poser. Je tente une copie de fichiers présents sur un dd externe sur mon synologie et lors de la copie il m'indique qu'il lui est impossible de copier le contenu car des fichiers ont des noms trop long. Perso, s'il pouvait déjà copier les 99,99% autres fichiers je me moquerai éperdument des fichiers trop long, mais toute la copie est stoppée. Quelqu'un aurait une idée du comment gérer cette situation ?

 

d'avance merci, 

 

jibe

Partager ce message


Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

@Jibe75

Bonjour,

  1. EN premier lieu, sais-tu qu'un petit passage par la rubrique Présentation de ce forum est appréciée et certains ici y sont même sensibles ? Mais saches qu'il n'est pas trop tard pour ce faire ...
  2. Pour ton problème, si tu est sous WIN, alors essaies ce qui suit :
  • Touche WIN + R et taper gpedit.msc
    • Dans la partie gauche de la fenêtre, développer successivement les niveaux : Stratégie Locale Ordinateur – Configuration Ordinateur – Modèles d’administration – Système −Système de fichiers.
    • Dans la partie droite de la fenêtre, 2xClic sur : « Activer les noms de chemin d’accès Win32 longs »
      • Dans la fenêtre, sélectionner : « Activer »
      • Cliquer sur : « OK »
    • Dans la partie droite de la fenêtre, 2xClic sur : « Activer l’évaluation d’un lien symbolique »
      • Dans la fenêtre, sélectionner : « Activer » et cocher la case : « Lien local à une cible locale »
      • Cliquer sur : « OK »

Après cela tu n'auras plus de problèmes de chemins trop longs.

Cela dit je t'invites tout de même à revoir ton arborescence de fichiers pour éviter ces désagréments.

Cordialement

oracle7😉

Modifié par oracle7

Partager ce message


Lien à poster
Partager sur d’autres sites

Slt Oracle7, 

merci pour l'info. Malheureusement je suis sur mac et je souhaite faire la copie sur le nas et non sur mon poste. je cherchais plus un moyen de réduire automatiquement la taille des noms ou éventuellement activer l'option auquel tu fais référence dans le synologie.

pour la présentation, je vais faire un tour sur le forum et faire ce que tu me recommande

merci quand même

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Jibe75,

Un petit AppleScript devrait te permettre de tester la longueur des noms sur le disque ou le dossier local et de raccourcir les noms trop longs. Encore faut-il savoir combien de caractères max le NAS accepte lors d'une opération de copie. Et aussi si cette limitation concerne uniquement le nom de fichier (toto.txt) ou le chemin d'accès complet (/Volumes/Disque dur/dossier lambda/toto.txt). Je pense que ça coince sur le nom du fichier.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour CyberFr, 

hum... je crois que je vois ce que tu veux dire. Je vais chercher dans cette direction et j'indiquerai dans la discussion ce que j'ai pu trouver

thx

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 16/05/2020 à 12:56, Jibe75 a dit :

hum... je crois que je vois ce que tu veux dire. Je vais chercher dans cette direction et j'indiquerai dans la discussion ce que j'ai pu trouver

Alors, tu as trouvé ? Sinon, je peux te fournir un AppleScript prêt à l'emploi.

Il est vrai que c'est un problème spécifique à macOS où les noms de fichiers peuvent atteindre 255 caractères.

Partager ce message


Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Bonjour,
C'est souvent un problème de longueur totale de l'arborescence, j'ai déjà eu le cas à cause d'un trop grand nombre de sous-dossiers.
Et parfois peu de fichiers sont en cause et bloquent le transfert quand c'est leur tour d’être copiés.
Le sujet a déjà été évoqué ici: (pas sur mac, mais ça doit ressembler)

 

 

Modifié par jacaj

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, jacaj a dit :

C'est souvent un problème de longueur totale de l'arborescence, j'ai déjà eu le cas à cause d'un trop grand nombre de sous-dossiers.
Et parfois peu de fichiers sont en cause et bloquent le transfert quand c'est leur tour d’être copiés.

Dans le fil de discussion que tu cites, maxou56 répond que les noms de fichiers peuvent atteindre 255 caractères. Effectivement jacaj, le problème est ailleurs.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.