This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Double Jo

Membres
  • Compteur de contenus

    41
  • Inscription

  • Dernière visite

À propos de Double Jo

Visiteurs récents du profil

Le bloc de visiteurs récents est désactivé et il n’est pas visible pour les autres utilisateurs.

Double Jo's Achievements

Rookie

Rookie (2/14)

  • Dedicated Rare
  • First Post Rare
  • Collaborator Rare
  • Conversation Starter Rare
  • Week One Done Rare

Recent Badges

0

Réputation sur la communauté

  1. Ah oui mon exemple est le même concernant les DS420+ et DS920+ effectivement. Donc si je comprends bien, le DS920+ propose la possibilité de mettre une extension, mais surtout de la puissance supplémentaire. Il se trouve que je me sers beaucoup de docker, mais j'ai pas tellement besoin d'espace. Et d'ailleurs j'hésite à prendre un "vrai" serveur, pas un NAS. Voir partir dans le cloud. Qu'en pensez-vous?
  2. Bonjour! J'ai actuellement le DS218+ et j'en suis ravi. Je souhaite passer sur un 4 baies et j'ai été étonné de voir qu'au delà du DS418+, il existe des NAS avec possibilité d'extension, le DS918+ par exemple. Je ne comprends pas ce que ça apporte. Si j'ai besoin de plus d'espace, pourquoi ne pas se contenter du DS418+ avec des disques durs plus gros?
  3. Salut. Petit à petit je m'en sors avec la conf de mes domaines. J'ai deux domaines chez OVH et chacun d'eux me redirige vers mon NAS avec la conf DDNS. OVH Côté OVH, pour les 2 domaines, j'ai un truc comme ça: *.mondomaine1.fr. CNAME mondomaine1.fr. www.mondomaine1.fr. CNAME mondomaine1.fr. Parfait. NAS Côté NAS, j'ai à la fois le reverse proxy, et des virtual hosts. Reverse proxy Pour le reverse proxy j'ai quelques entrées pour des sous domaines particuliers, du genre: calendar.mondomaine1.fr drive.mondomaine1.fr mondomaine1.fr qui redirige vers le port 5000 pour le DSM ... Et rien concernant mondomaine2 ici Virtual hosts Et pour les virtual hosts, j'en ai 2: truc.mondomaine1.fr qui mène au sous dossier mondomaine1 mondomaine2.fr qui mène au sous dossier mondomaine2 Et donc le répertoire root "web" n'est pas censé être utilisé car rien ne redirige vers lui. Le problème Pour les 2 domaines, quand je saisi une adresse avec un sous domaine, n'importe lequel qui n'est pas traité par le reverse proxy, par exemple: https://sdjhfrjkdfhdjkh.mondomaine1.fr https://toto.mondomaine2.fr Je suis redirigé vers le dossier "web" de web station. Ce que je souhaite: Ça me paraîtrait logique de tomber sur une 404 à la place. On ne peut pas désactiver le dossier web pour ne laisser que les virtual hosts? Merci!
  4. Ok fausse alerte, il fallait mettre un "/" à la fin de ma route...
  5. J'ai eu une réponse sur StackOverflow. Le mec disait que je devrais plutôt utiliser le reverse proxy (qui lui bénéficie du certificat facilement) afin de rediriger les requêtes du front vers l'api. Les appels à l'api seraient donc uniquement en local et n'ont pas besoin d'être en https. J'ai donc créé une nouvelle entrée dans le reverse proxy, comme ceci (pj) Mais je tombe sur une 404 Le port 9071 est bien celui sur lequel je dois taper, car ça fonctionne quand j'indique l'adresse ip du NAS suivie du port. Pour info, la 404 que j'ai est au "style" Synology. Alors que quand je fais une erreur volontaire dans l'url, j'ai une 404 au style plus classique (voir pj) Qu'en pensez-vous? Style Synology: Style "classique":
  6. Salut! Il s'agit d'un problème à mi-chemin entre le développement et la gestion de notre NAS, j'espère que je poste au bon endroit. J'ai développé une petite API python qui tourne dans un container docker sur le nas. Cette API fait des requêtes sur une base mariadb, également sur le nas. Mais (et c'est là l'intéressant) j'ai également fais une page web (vue-js) qui interroge l'api python. Tout ça marche bien, mais je souhaite appliquer du HTTPS. Voici (en pj) le schéma de ma situation. J'ai un certificat LE, je m'en sers déjà pour sécuriser l'accès au DSM par exemple. J'ai réussi à l'utiliser pour avoir du HTTPS sur mon appli vue-js. Le problème c'est qu'il faut également du HTTPS entre l'appli vue-js, et l'api python maintenant, et là je galère. Puis-je utiliser le même certificat? Comment je le "donne" à l'api? Pour info, l'api est en python donc. C'est une appli Flask et le serveur est gunicorn. J'ai réussi à mettre le https pour les test en local, en ajoutant ssl_context = 'adhoc': def main(): app.run(host='0.0.0.0', ssl_context='adhoc') Mais une fois livré dans docker ça ne fonctionne plus: time out. Je suis un peu perdu.
  7. Bon j'ai ma réponse pour interdire l'accès extérieur à certains sites, je vais simplement y mettre un fichier .htaccess avec un truc du genre: Order Deny,Allow Deny from all Allow from 192.168.1.1/24 Pour mon second problème, l'accès en HTTPS, c'est toujours pas ça. Je viens de rajouter le sous domaine site1.web.mondomaine.fr à la liste des autres noms de mon certificat mais lorsque j'accède au site le navigateur me dit que la connexion n'est pas privée. Et que le certificat semble ne pas être bon car il vient provient du domaine mondomaine.fr Je sèche...
  8. Bonjour à vous! J'utilise Web Station pour héberger 2 sites et je suis un peu paumé. Je n'utilise pas les Virtual Hosts (c'est peut être un tort, mais je ne comprends pas bien à quoi ça sert). J'ai 2 dossiers (site1, site2) dans le répertoire "web" qui correspondent à mes 2 sites et j'accède à celui que je veux avec des urls du genre: https://web.mondomaine.fr/site1 https://web.mondomaine.fr/site2 J'utilise le reverse proxy. Mon problème c'est que je souhaite que l'un des deux sites ne soit accessible que sur mon réseau local, est-ce possible? Aujourd'hui j'ai un fichier .htaccess à la racine du dossier web avec ce contenu: RewriteEngine On RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} J'ai trouvé ça sur un tuto et j'avoue que je ne sais plus à quoi ça sert. Mon autre question: Les sites sont accessibles en HTTP mais je ne souhaite autoriser que le HTTPS. Voici la conf du reverse proxy: Une idée? Merci!
  9. Ok merci! J'ai un routeur indépendant en plus de la box (Le Synology d'ailleurs). J'ai cru lire je ne sais plus où qu'on pouvait l'utiliser pour résoudre ce problème localement. J'imagine que c'est un installant un serveur DNS dessus...
  10. Merci DaffY, tu aurais un lien à partager plus en détail ce que tu expliques stp? Ça m'intéresse de comprendre techniquement ce qu'il se passe!
  11. Oui oui! Comme je disais mon installation fonctionnait bien depuis 2 ans!
  12. Oui oui, et je t'ai répondu dans un message précédent
  13. Merci pour cette explication. Est-ce une bonne idée de renouveler mon certificat (même si il est encore valide)? Ça pourrait aider si ça se trouve? Une meilleure suggestion?
  14. Afin que je comprenne le fonctionnement normal du truc, on est bien d'accord que: -Le client tente de se connecter au NAS (https) -Le NAS envoie le certificat (délivré dans mon cas par Let's Encrypt) -Le client vérifie qu'il est valide -On arrive alors sur la page d'authentification Pourquoi mon navigateur me demande de sélectionner un certificat présent sur ma machine? J'ai déjà essayé avec Firefox, en vidant le cache, navigation privée, etc... même problème. Plus de détail sur l'erreur (En utilisant Firefox) Là j'ai une option pour visualiser le certificat en question et je suis surpris car là: Nom courant: A43E51-Livebox 4-AN1826324876073 C'est ma box qui est à l'origine du certificat?