This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

hamham

Membres
  • Compteur de contenus

    5
  • Inscription

  • Dernière visite

  1. hamham

    php 7.2 mcrypt

    Juste essaie "php72 -v". Ca arrive souvent que l'alias PHP pointe sur une ancienne version et non pas sur la version souhaitée (et faut d'ailleurs que je le fasse sur mon propre nas)
  2. Bonjour, J'essaie de mettre en place une configuration sur le nginx pour faire tourner mon site codé en Sf 4.2 mais lorsque je charge ma conf, je n'ai plus du tout accès au DSM en https (sur le port 5001) (mais http port 5000 fonctionne lui...) Type de NAS : DS416j DSM : 6 (je n'ai pas la version exact) Je fais un lien symbolique vers mon fichier symfony.conf dans le dossier /etc/nginx/site-enabled. Voici mon fichier de conf : server { listen 81; listen [::]:81; server_name _; # server_name dso.loutres.freeboxos.fr; root /var/services/web/www/symfony/public; index index.php client_max_body_size 100m; location / { try_files $uri /index.php$is_args$args; } location ~ ^/(index)\.php(/|$) { #fastcgi_pass unix:/run/php-fpm/php72-fpm.sock; fastcgi_pass unix:/run/php-fpm/php-9f1e642a-0d20-4664-8934-c51d34f609de.sock; fastcgi_split_path_info ^(.+\.php)(/.*)$; include fastcgi_params; fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name; fastcgi_param DOCUMENT_ROOT $realpath_root; internal; } location ~ \.php$ { return 404; } access_log /volume1/web/logs/user-access.log; error_log /volume1/web/logs/user-error.log; } Je souhaite le faire tourner sur le port 81 pour éviter d'écraser une probable utilisation du port 80, à tord peut-être ? Une fois le lien fait, je recgarge via les commandes " sudo synoservicecfg --reload nginx" et "sudo synoservicecfg --restart nginx" ou là d'une part je n'accède même pas à mon site sur le port 81 et comme dit au début, le https sur le port 5001 n'est plus accessible. Si je supprime le lien symbolique et relance nginx, tout revient à la normale... Une idée ? Merci d'avance
  3. hamham

    Présentation

    Le son ^^
  4. hamham

    Présentation

    Bonjour la communauté, Je me présente : moi c'est Hamham, 35ans à Montpellier. Je suis développeur PHP/Symfony. J'ai comme tout le monde ici un serveur NAS Synology mais un petit DS416j que j'utilise comme stockage de fichiers/serveur média et actuellement j'essaie d'y ajouter un serveur web sous nginx d'une appli Symfony4/VueJs/elasticSearch...ce qui vaudra certainement quelques posts... Sinon j'aime l'astronomie, les loutres et le metal :D
  5. hamham

    Problème de paquet node-sass

    Bonjour, J'ai développé un site en Symfony 4.2 (backend) et vueJS (front-end) que je souhaite héberger sur mon NAS (DS416j) mais je me retrouve avec des problèmes liés à la compilation de paquets node (entre-autre). Avant tout, voici les versions d'installés de NPM/Node/yarn : admin@Nas-Loutres:/var/services/web/www/$ npm -v 6.4.1 admin@Nas-Loutres:/var/services/web/www/$ node -v v8.9.4 admin@Nas-Loutres:/var/services/web/www/$ node -p process.versions { http_parser: '2.7.0', node: '8.9.4', v8: '6.1.534.50', uv: '1.15.0', zlib: '1.2.8', ares: '1.10.1-DEV', modules: '57', nghttp2: '1.25.0', openssl: '1.0.2k-fips', icu: '59.1', unicode: '9.0', cldr: '31.0.1', tz: '2017b' } admin@Nas-Loutres:/var/services/web/www/$ node -p process.platform linux admin@Nas-Loutres:/var/services/web/www$ node -p process.arch arm Voici mon fichier package.json (au cas ou...) { "devDependencies": { "@symfony/webpack-encore": "^0.26.0", "vue-svgicon": "^3.2.4", "webpack-notifier": "^1.6.0" }, "license": "UNLICENSED", "private": true, "scripts": { "dev-server": "encore dev-server", "dev": "encore dev", "watch": "encore dev --watch", "build": "encore production --progress", "generate-icons": "vsvg -s ./assets/svg -t ./assets/js/Widgets/Icons" }, "dependencies": { "@fortawesome/free-regular-svg-icons": "^5.8.1", "copy-webpack-plugin": "^4.6.0", "d3-celestial": "^0.6.10", "node-sass": "^4.11.0", "sass-loader": "^7.0.1", "vue": "^2.5.18", "vue-agile": "^0.3.7", "vue-burger-menu": "^2.0.0", "vue-flux": "^5.1.9", "vue-i18n": "^8.4.0", "vue-lazy-image-loading": "^1.1.5", "vue-loader": "^15.4.2", "vue-plain-pagination": "^0.3.0", "vue-pure-lightbox": "^2.1.8", "vue-router": "^3.0.2", "vue-social-sharing": "^2.3.3", "vue-template-compiler": "^2.5.18", "vue2-autocomplete-js": "^0.2.2", "vue2-touch-events": "^1.1.1" } } La version de node-sass installée est celle prise dans la documentation de Symfony. Donc pour compiler et générer mes fichiers css et JS, je lance la commande : admin@Nas-Loutres:/var/services/web/www/$ yarn encore production yarn run v1.15.2 $ /volume1/web/www/node_modules/.bin/encore production Running webpack ... ERROR Failed to compile with 1 errors 17:28:50 error in ./assets/css/app.scss Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js): ModuleBuildError: Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Node Sass does not yet support your current environment: Linux Unsupported architecture (arm) with Node.js 8.x For more information on which environments are supported please see: https://github.com/sass/node-sass/releases/tag/v4.10.0 Si je comprends bien, node-sass semble incompatible avec l'architecture de mon serveur...ce qui est plutôt problématique...et du coup je suis bloqué ne sachant que faire. Si des personnes ont deja eu ce soucis, peut-être auraient-elles une solution :) ? Merci d'avance.