This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

DavFromRouen

Membres
  • Compteur de contenus

    22
  • Inscription

  • Dernière visite

À propos de DavFromRouen

Visiteurs récents du profil

Le bloc de visiteurs récents est désactivé et il n’est pas visible pour les autres utilisateurs.

DavFromRouen's Achievements

Newbie

Newbie (1/14)

  • Week One Done Rare
  • One Month Later Rare

Recent Badges

0

Réputation sur la communauté

  1. Et voilàààà ! La fête des pères à été l'occasion de m'équiper. Un petit Syno 220J vient de rejoindre la famille. Il est prêt à faire feu, il est paramétré, il s'occupera de faire la sauvegarde de mon NAS principal (le 218J) tous les jours à minuit. J'ai demandé à mon beau-père si il était d'accord pour que je le mette chez lui et cela ne lui pose pas de problème. Pour le coup NAS principal en Normandie et secondaire en Bretagne. ...prochaine étape, les onduleurs maintenant. C'est prévu. Surtout pour la Bretagne, car là-bas souvent des coupures sauvages. Et mes beaux-parents ne sont pas à l'abri des orages non plus. Moi ca va du coté orages, j'habite à coté d'un silo à blé, qui lui-même est équipé d'un parafoudre/paratonnerre. Donc priorité Bretagne et après j'en mettrai 2 chez moi. (1 pour la Freebox Pop + Domoticz - 1 pour mon Syno 218J)
  2. Y'a pas de soucis, message reçu les gars. C'est bien compris. Prochainement je me reprends un deuxième NAS. Vous voyez je ne suis pas fier ou orgueilleux ou "plus malin que tout le monde" Là j'ai pris un coup de pied au cul, ca m'a remis les idées en place. Merci pour ce recadrage.
  3. Haa. C'est un point de vue intéressant oui. Après effectivement je trouve que c'est trop dans votre cas. Je ne partage pas cet avis pour le NAS, qui pour moi est fait pour la sauvegarde justement, et qui plus est en RAID 1 cela à tout son sens. Puisque la sauvegarde est faire à la volée. De plus, comme il y a la surveillance des disques on est pas pris au dépourvu quand un disque commence à fatiguer. Je n'ai pas eu de chance dans mon cas particulier où je voulais en même temps étendre ma capacité. (Quoique toutes mes données étaient là et le NAS fonctionnait, j'étais juste bridé à 2To au lieu de 4To) si j'avais remis un HDD de 2 To tout serait reparti comme avant. Après rien est perdu, je pense qu'il faut en faire exprès pour tout perdre sur un NAS en RAID 1. Ou être extrêmement malchanceux et avoir deux disques complètement HS(irrécupérable donc) en même temps. Par exemple, je peux encore récupérer mes données si je le souhaite sur un des deux anciens disques de 2To. Je lance DMDE avec le disque dans un dock USB/SATA et c'est parti... Déjà qu'un NAS n'est pas toujours à la portée de toutes les bourses alors imaginez deux ou 3... Dans un milieu professionnel cela à tout son sens, mais pour un particulier c'est trop à mon goût. En tout cas, merci à tous pour votre aide, votre réactivité et votre bienveillance. Longue vie au forum.
  4. Ok, pas de soucis Je fais des sauvegardes et je vais tout remettre à plat, pour repartir propre. Le truc c'est qu'un NAS c'est justement pour faire des sauvegardes et avoir de l'espace de stockage, lol. Du coup depuis hier soir j'en étale un peu partout, sur le SSD de mon PC, sur un HDD externe de 1To et un autre de 320 Go... Je vais y arriver, courage... Merci à tout d'avoir voulu m'aider. On peut clôturer le post.
  5. Il n'y a pas de groupe visiblement: root@NAS:~# vgdisplay vg1000 Volume group "vg1000" not found Cannot process volume group vg1000 root@NAS:~#
  6. root@NAS:~# vgdisplay vg1 Volume group "vg1" not found Cannot process volume group vg1 root@NAS:~#
  7. Il prend les commandes mais ne répond rien... root@NAS:~# pv display -ash: pv: command not found root@NAS:~# lv display -ash: lv: command not found root@NAS:~# vg display -ash: vg: command not found root@NAS:~# pvdisplay root@NAS:~# lvdisplay root@NAS:~# vgdisplay root@NAS:~#
  8. C'est bien là le problème, comme expliqué plus haut... les commandes ne fonctionnent pas. David@NAS:~$ sudo -i Password: root@NAS:~# pv display -ash: pv: command not found root@NAS:~# lv display -ash: lv: command not found root@NAS:~# vg display
  9. Alors, les deux commandes ont répondu ceci : root@NAS:~# cat /proc/mdstat Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] md2 : active raid1 sda3[2] sdb3[3] 3902296384 blocks super 1.2 [2/2] [UU] md1 : active raid1 sda2[0] sdb2[1] 2097088 blocks [2/2] [UU] md0 : active raid1 sda1[0] sdb1[1] 2490176 blocks [2/2] [UU] unused devices: <none> root@NAS:~# parted --list Model: WDC WD40EFZX-68AWUN0 (scsi) Disk /dev/hda: 4001GB Sector size (logical/physical): 512B/512B Partition Table: gpt Disk Flags: Number Start End Size File system Name Flags 1 1049kB 2551MB 2550MB ext4 raid 2 2551MB 4699MB 2147MB linux-swap(v1) raid 3 4832MB 4001GB 3996GB raid Model: WDC WD40EFZX-68AWUN0 (scsi) Disk /dev/sda: 4001GB Sector size (logical/physical): 512B/512B Partition Table: gpt Disk Flags: Number Start End Size File system Name Flags 1 1049kB 2551MB 2550MB ext4 raid 2 2551MB 4699MB 2147MB linux-swap(v1) raid 3 4832MB 4001GB 3996GB raid Model: WDC WD40EFZX-68AWUN0 (scsi) Disk /dev/sdb: 4001GB Sector size (logical/physical): 512B/512B Partition Table: gpt Disk Flags: Number Start End Size File system Name Flags 1 1049kB 2551MB 2550MB ext4 raid 2 2551MB 4699MB 2147MB linux-swap(v1) raid 3 4832MB 4001GB 3996GB raid Model: Linux Software RAID Array (md) Disk /dev/md0: 2550MB Sector size (logical/physical): 512B/512B Partition Table: loop Disk Flags: Number Start End Size File system Flags 1 0.00B 2550MB 2550MB ext4 Model: Linux Software RAID Array (md) Disk /dev/md1: 2147MB Sector size (logical/physical): 512B/512B Partition Table: loop Disk Flags: Number Start End Size File system Flags 1 0.00B 2147MB 2147MB linux-swap(v1) Model: Linux Software RAID Array (md) Disk /dev/md2: 3996GB Sector size (logical/physical): 512B/512B Partition Table: loop Disk Flags: Number Start End Size File system Flags 1 0.00B 3996GB 3996GB ext4 Error: /dev/mtdblock0: unrecognised disk label Model: Unknown (unknown) Disk /dev/mtdblock0: 983kB Sector size (logical/physical): 512B/512B Partition Table: unknown Disk Flags: Error: /dev/mtdblock1: unrecognised disk label Model: Unknown (unknown) Disk /dev/mtdblock1: 2949kB Sector size (logical/physical): 512B/512B Partition Table: unknown Disk Flags: Error: /dev/mtdblock2: unrecognised disk label Model: Unknown (unknown) Disk /dev/mtdblock2: 4260kB Sector size (logical/physical): 512B/512B Partition Table: unknown Disk Flags: Error: /dev/mtdblock3: unrecognised disk label Model: Unknown (unknown) Disk /dev/mtdblock3: 65.5kB Sector size (logical/physical): 512B/512B Partition Table: unknown Disk Flags: Error: /dev/mtdblock4: unrecognised disk label Model: Unknown (unknown) Disk /dev/mtdblock4: 65.5kB Sector size (logical/physical): 512B/512B Partition Table: unknown Disk Flags: Error: /dev/mtdblock5: unrecognised disk label Model: Unknown (unknown) Disk /dev/mtdblock5: 65.5kB Sector size (logical/physical): 512B/512B Partition Table: unknown Disk Flags: root@NAS:~#
  10. Bon, j'ai bien un soucis, cela n'étonnera personne, dans le système de fichier. Le problème c'est que j'ai réussi à faire un scan en lecture seule uniquement, car je n'arrive pas à démonter mon volume. J'ai essayé en SSH et en TELNET, ce dernier m'a permis de faire le scan que SSH ne pouvait pas. Voici le résultat du scan : root@NAS:~# e2fsck -nvf -C 0 /dev/md2 e2fsck 1.42.6 (21-Sep-2012) Warning! /dev/md2 is mounted. Warning: skipping journal recovery because doing a read-only filesystem check. Pass 1: Checking inodes, blocks, and sizes Inode 134837 has an invalid extent node (blk 686881, lblk 0) Clear? no Inode 134837, i_blocks is 4400, should be 0. Fix? no Pass 2: Checking directory structure Pass 3: Checking directory connectivity /lost+found not found. Create? no Pass 4: Checking reference counts Pass 5: Checking group summary information Block bitmap differences: -686881 -(874100--874101) -(165996351--165996363) -205553625 -(226516887--226516991) -(278498018--278498019) -278499327 -278501535 -(278503246--278503247) -(278503324--278503417) -(278503420--278503423) -(278508997--278508999) -(278515964--278515967) -(278516393--278516395) -(278516672--278516733) -(278559262--278559567) -(278559584--278559635) Fix? no Free blocks count wrong (142951619, counted=142951670). Fix? no Free inodes count wrong (121679223, counted=121679226). Fix? no 1.42.6-15217: ********** WARNING: Filesystem still has errors ********** 119433 inodes used (0.10%, out of 121798656) 2176 non-contiguous files (1.8%) 85 non-contiguous directories (0.1%) # of inodes with ind/dind/tind blocks: 0/0/0 Extent depth histogram: 118182/896/5 344221517 blocks used (70.66%, out of 487173136) 0 bad blocks 30 large files 106571 regular files 12507 directories 0 character device files 0 block device files 0 fifos 0 links 343 symbolic links (339 fast symbolic links) 0 sockets ------------ 119421 files Mais IMPOSSIBLE de démonter ce fichu volume 1 !! Avez vous une astuce ? J'ai essayé: syno_poweroff_task -d ainsi que umount /volume1 ou encore umount /volume1 -f -k Je suis dégagé du SSH et quand je me reconnecte, je vois que mon volume 1 est toujours monté....
  11. Peut-être que ça te dit quelque chose @Superthx ?
  12. Merci bien, j'avais parcouru ce post dans mes recherches. Le problème, c'est que je ne vois pas comment adapter mes lignes de commandes. Comme je n'ai pas la même configuration et les mêmes chemins, et certaines commandes ne fonctionnent pas dans mon cas dès le départ ( vgs -a lvs -a) root@NAS:~# mdadm --detail /dev/md2 /dev/md2: Version : 1.2 Creation Time : Sat Dec 16 20:53:30 2017 Raid Level : raid1 Array Size : 3902296384 (3721.52 GiB 3995.95 GB) Used Dev Size : 3902296384 (3721.52 GiB 3995.95 GB) Raid Devices : 2 Total Devices : 2 Persistence : Superblock is persistent Update Time : Thu May 13 19:32:57 2021 State : clean Active Devices : 2 Working Devices : 2 Failed Devices : 0 Spare Devices : 0 Name : NAS:2 (local to host NAS) UUID : adfb0bc8:13946f32:b5bd2799:a06df612 Events : 1736 Number Major Minor RaidDevice State 2 8 3 0 active sync /dev/sda3 3 8 19 1 active sync /dev/sdb3 root@NAS:~# pvs -a PV VG Fmt Attr PSize PFree /dev/md2 --- 0 0 root@NAS:~# vgs -a root@NAS:~# lvs -a root@NAS:~#
  13. J'ai tout démonté, dépoussiéré il est comme au déballage du premier jour, de décembre 2017. Mais j'ai toujours mon soucis lorsque je veux étendre mon volume par contre. Que pensez vous de scanner les disques (soit avec Gparted soit avec Linux Mint) sur une autre machine comme proposé plus haut ?
  14. oki, surtout qu'il a mangé de la poussière, j'ai poncé à proximité. Donc de l'enduit de lissage il en a respiré. J'ai dégrossi pas mal en changeant les disques. je vais voir ça.
  15. Je pense à quelque chose, dites moi si c'est valable. Je pensais enlever 1 disque (neuf, 4To) et le brancher sur un dock USB/SATA et faire un Fsck sur Linux Mint. J'ai une clé USB bootable en live et des ordis, c'est pas ce qui manque ici L'idée c'est faire passer mes deux HDD neufs la dessus. C'est valable ou bien ? Ou je risque de faire pire que mieux ?