This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

red1

Redirection Permanente Vers Le R

Messages recommandés

Bonjour à tous,

Il y a quelques temps, j'avais configuré un fichier .htaccess dans le répertoire /volume1/web de mon Syno (DS109, DSM3.2-1955), de façon à rediriger de façon permanente toutes les requêtes http vers le répertoire photo :

> pwd

/volume1/web

> more .htaccess

RedirectPermanent /index.html http://www.mondomaine.fr/photo/

Aujourd'hui j'ai cherché à désactiver cette redirection automatique.

Mais bizarrement, j'ai l'impression qu'en l'absence même du .htaccess, tous les flux sont encore dirigés de façon permanente vers le répertoire photo.

J'ai lu quelque part que lorsque le blog était activé, cette redirection pouvait être permanente. Je ne sais pas si c'est vrai, mais en dans tous les cas le blog n'est pas activé.

Je précise que le .htaccess est bien déroulé par le système : Si j'ajoute une redirection vers un autre endroit du site, cela fonctionne. C'est donc la preuve que le .htaccess sert à quelque chose.

Mon souci, c'est que lorsque je le supprime, la redirection vers le répertoire photo fonctionne toujours.

Sauriez-vous m'aider ?

D'avance merci.

Modifié par red1

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour,

tiens c'est ce que je cherche a faire,

faire en sorte que lorsque l'on se connecte a mon IP externe (port 80) cela redirige vers photostation,

actuellement cela va vers la page login de DSM

donc quand je lis que de base cela y va, j'ai du louper quelque chose ..

je viens d'activer le blog et non j'arrive toujours sur la page webman

Modifié par f1ioi

Partager ce message


Lien à poster
Partager sur d’autres sites

La redirection vers le dossier photo est de base.

Je suis surpris. Je me souviens en effet nettement qu'au début où j'avais ce Syno, je devais donner le lien direct avec le répertoire photo, et que j'avais ensuite réglé le problème avec le .htaccess.

Mais çà dépend peut-être de la version de DSM ?

Au début j'étais en 3.0 (photo station 4 de mémoire). J'ai mis le .htaccess. Et depuis je suis passé en 3.2 (photo station 5).

bonjour,

tiens c'est ce que je cherche a faire

Dans ce cas essaye d'ajouter un .htaccess dans le répertoire web comme indiqué dans mon post initial.

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement la redirection vers le dossier photo est à créer, petite erreur de ma part.

Pour le faire, soit avec une redirection par fichier PHP ou html, ou alors avec un htaccess.

Red1, dans ton cas, il faut taper l'URL avec index.html pour être redirigé. Il faut que tu redirige tous les accès au dossier racine, pas que la page index. Si tu tapes URL/index.php tu n'es pas redirigé.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

Je remonte ce post pour apporter quelques nouvelles à d'autres utilisateurs.

Tout d'abord, j'ai réussi à activer ou désactiver à la demande la redirection permanente vers mon répertoire photo.

Cette redirection passe bien par le fichier .htaccess dans le répertoire /volume1/web comme évoqué plus haut.

Le souci que j'avais, c'est que je n'étais plus en mesure de changer quoi que soit dans la configuration du .htaccess : Si je changeais quelque chose dans ce fichier, ou si même je supprimais le fichier, la redirection était toujours effective.

J'ai trouvé pourquoi : Pour que le contenu du .htaccess soit pris en compte, je dois redémarrer le serveur.

Je précise que j'ai essayé de redémarrer sélectivement le serveur, notamment en redémarrant seulement Apache depuis le login root, mais cela ne semble pas fonctionner. Je me contente donc de redémarrer le serveur complètement (bouton en face avant ou commande "redémarrer" depuis l'interface de gestion).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je redéterre un de mes vieux posts pour apporter une précision.

J'ai dû dernièrement réinstaller DSM et j'ai été de nouveau confronté à la nécessité d'installer un fichier .htaccess

Etrangement, la méthode décrite ci-dessus ne fonctionnait plus.

La raison était la suivante : même si vous ne créez pas de sites web perso sur votre Synology, il faut a minima cocher la case "Activer Web Station" dans les paramètres.

Dans le cas contraire, le .htaccess ne sera pas reconnu et donc son contenu sera inopérant.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement