This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Yanis Ben

Erreur 404 site Wordpress liens

Messages recommandés

Bonjour à tous,

Pour mon 2ème post sur ce forum, j'aimerais être éclairer sur des erreurs 404.

J'ai récemment créé un site sur wordpress synology basique, et afin de ne plus avoir le /wordpress dans mon URL jai copié .htacces et Index.php à la racine en modifiant leur code...

Cela à marché j'ai bien un site sans /wordpress, j'accède à la page d’accueil, je peux administrer mon site cependant je n'ai pas accès aux articles et à tout le contenu à cause d'une erreur 404...

Est ce une erreur au niveau du .htacces et des permaliens ?  

Merci d'avance pour votre aide.

 

DS214Play

DSM 6.1.6

Wordpress - Apache HTTP Server 2.4 - PHP 7.0

461811366_Capturewp.thumb.JPG.9bc1a02b569c94ec46413ce0b96ef6fb.JPG179700237_Capturewp2.thumb.JPG.4f9edd9a19e4258930471ef1346d30ad.JPG

Modifié par Yanis Ben

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

1ère étape : faire un tour dans l'administration Wordpress pour voir s'il n'y a pas un paramètre qui est resté avec ".../wordpress"

2e étape : il est fort probable qu'il y ait des données en base MySQL qui référencent toujours "/wordpress" (les extensions, la configuration du thème...).

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, lordtaki a dit :

Bonjour,

1ère étape : faire un tour dans l'administration Wordpress pour voir s'il n'y a pas un paramètre qui est resté avec ".../wordpress"

 2e étape : il est fort probable qu'il y ait des données en base MySQL qui référencent toujours "/wordpress" (les extensions, la configuration du thème...).

Bonjour, 

Merci de votre réponse, dans mes dossier je n'ai que les fichiers .htcasse et indexe.php où figurent /wordpress et ils sont a la racine de mon dossier web.

Ces 2 fichiers, je les ai créés (copier coller) à partir des .htacess et Indexe php originaux dans le fichier wordpress et j'ai rajouté la marque /wordpress pour rediriger les demandes vers mon dossier wordpress.

Au niveau de la base MySQL la seule référence /wordpress que j'ai vu était sur le "siteurl: https://www.site.com/wordpress" mais je l'ai supprimé et rien ne s'est résolu (cf 3ème photos).

Capture.JPG.fec568bad802ca15910c354642abb080.JPGWP.JPG.cd4e1bec8b660baa81b73793e24d3206.JPGWP2.JPG.bda6ba1b1fbacc5d9492b36896cc190b.JPG

Modifié par Yanis Ben

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @Yanis Ben,

pour être certain de mettre à jour tes url, execute ces lignes de commandes sous phpmyadmin

La requête suivante met à jour l’adresse de votre site dans les options de WordPress:

UPDATE wp_options SET option_value = replace(option_value, 'http://ancienneURL', 'http://www.nouvelleURL') WHERE option_name = 'home' OR option_name = 'siteurl';

La requête suivante change l’URL relative des articles dans la table wp_posts:

UPDATE wp_posts SET guid = replace(guid, 'http://www.ancienneURL','http://www.nouvelleURL');

La requête suivante met à jour les liens dans le contenu de vos articles et vos pages:

UPDATE wp_posts SET post_content = replace(post_content, 'http://www.ancienneURL', 'http://www.nouvelleURL');

La requête suivante met à jour les liens dans la table wp_postmeta:

UPDATE wp_postmeta SET meta_value = replace(meta_value,'http://www.ancienneURL','http://www.nouvelleURL');

Remarques importantes:

  • ancienneURL: l’ancienne adresse URL de votre site / l’ancien chemin à corriger
  • nouvelleURL: la nouvelle adresse URL de votre site / le nouveau chemin correct
  • si vous passez vos liens en https, n’oubliez pas de remplacer http:// par https:// dans la nouvelle URL
  • si vous n’utilisez pas le préfixe wp_ par défaut dans vos tables, n’oubliez pas de l’adapter

et comme dit @lordtaki tu peux très bien installer wordpress de ton blog (CV) dans un dossier spécifique dans web (par exemple : mon blog) et faire pointer ton virtual host sur ce dossier

 

Capture d’écran 2018-05-18 à 17.20.51.png

Modifié par Novioritum

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement