This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

DeeJayOne

Membres
  • Compteur de contenus

    19
  • Inscription

  • Dernière visite

À propos de DeeJayOne

  • Rang
    Initié

Visiteurs récents du profil

Le bloc de visiteurs récents est désactivé et il n’est pas visible pour les autres utilisateurs.

  1. DeeJayOne

    Migration 5 à 10

    Merci à exae pour les bonnes pistes. J'ai constaté des problèmes similaires en voulant me connecter en local sur une BDD MariaDB v10 via PHP v5.6 avec Mysqli et PDO. La seule cnx qui fonctionnait, c'était via mysqli sans mot de passe. Sur un NAS synology (DS212+ dans mon cas), les paramètres par défaut des serveurs MariaDB sont les suivants : MariaDB5 : port=3306 socket=/run/mysqld/mysqld.sock MariaDB10 : port=3307 socket=/run/mysqld/mysqld10.sock Pour se connecter à une BDD de type MariaDB avec PHP, il faut utiliser le driver mysql (mysqli ou PDO). Par défaut, mysqli utilise le port 3306 et PDO le socket '/tmp/mysql.sock'. Remarque 1 : mysqli utilise également le socket '/tmp/mysql.sock' par défaut (d'après la doc) mais j'ai constaté que ce paramètre était vide sur le NAS. Remarque 2 : Je suppose également que le port par défaut utilisé par PDO est le port 3306 (à vérifier). EN RESUME : Si l'on souhaite se connecter sur une BDD MariaDB distante, il faut simplement spécifier le port 3307 en paramètre (ou modifier le fichier php.ini) dans le cas de MariaDB10. Si l'on souhaite se connecter sur une BDD MariaDB locale, il faut en plus dans tous les cas spécifier le socket en paramètre (ou modifier le fichier php.ini). Dans tous les cas, si l'on souhaite "switcher" de MariaDB5 à MariaDB10 (et vice versa), il faut modifier le port et le socket dans PHP.
  2. Je reviens ici pour donner un complément d'infos concernant le problème de la NAS qui a planté. Après analyse des fichiers log, il se pourrait que la source du problème soit lié à 2 paramètres : - Le fait que j'utilise un disque dur usb externe relié au DS212+ - Un mauvais redémarrage après la MAJ du DSM v6.0 update 6 (l'initialisation du disque externe ne s'est pas déroulé correctement)
  3. J'ai modifié mon dernier post car je m'étais trompé de diagnostic. C'est en faisant un CTRL+C que j'ai réussis à faire apparaitre le prompt root. En revanche, j'ai de nouvelles informations à ajouter : Je travaillais en accès distant pour me connecter à la NAS en SSH et je viens de m'apercevoir que le redémarrage à distance de la NAS (à partir du dsm) ne se faisait pas du tout. J'ai tenté ensuite un arrêt propre (depuis dsm qui n'a pas fonctionné, puis depuis la NAS qui est toujours resté allumé au bout de 30mn) pour finir par débrancher le câble d'alimentation. (J'ai une sainte horreur d'en arriver là et d'appliquer ce genre de méthode mais quand ça ne veut pas...) Bref, après ré allumage de la NAS, je n'ai plus de soucis pour exécuter la commande sudo -i. Je peux parfaitement me connecter en tant que root. C'est la 2ème fois que je rencontre ce genre de problème sous DSM v6.
  4. Finalement, j'ai trouvé la solution grâce à l'appel à un ami et ça a été fructueux : sudo vi /etc/passwd Par défaut il y a une ligne : root:x:0:0::/root:/bin/ash Il faut remplacer ash par sh et sauvegarder les changements (:wq) Ensuite, la commande "sudo -i" fonctionne correctement. Rem. : Il faut attendre un peu car ce n'est pas forcément instantané. Je fais une petite rectification, car j'ai posté un peu trop vite et changer "ash" en "sh" pour root n'est pas du tout la solution au problème. En fait, après avoir tapé "sudo -i", il faut faire un CTRL+C et là c'est magnifique, j'apparais en tant que root !!! Excuse moi CoolRaoul de t'avoir fait faire toutes ces vérifications pour rien. En revanche, je pense qu'il doit tout de même y avoir un soucis à la base.
  5. En effet, apparemment on ne peut pas visualiser le contenu d'un fichier texte en tant que pièce jointe. Voici les 3 dernières lignes affichées lors de l'exécution de la commande : root 12355 12352 0 May16 ? 00:00:00 dovecot/log postfix 12372 10956 0 May16 ? 00:00:00 qmgr -l -t fifo -u root 12433 1 0 May19 ? 00:00:00 /var/packages/SurveillanceStatio Depuis le passage au DSM v6.0 je commence à avoir l'habitude de contacter le support. Je vais devoir continuer à prendre mon mal en patience. Merci pour ton aide CoolRaoul !
  6. Autant pour moi, j'ai zappé le ".profile" !!! Ci-joint la nouvelle capture d'écran pour le sudo cat /root/.profile et voici le résultat du "ps -ef" en pièce jointe car il y a trop de lignes pour une capture d'écran !!! Remarque : Il semblerait que ça se bloque lors de l'exécution de cette commande car je n'obtiens pas l'invite "admin@DS212 : $" en début de ligne. DS212+II - DSM v6.0 - (ps -ef).txt
  7. sudo ps ne fonctionne pas (idem comportement sudo -i) Voici le résultat pour sudo cat /root/
  8. Le sudo sh fonctionne bien. En pièce jointe une capture d'écran du sudo sh -lx Mon niveau concernant l'utilisation de linux étant assez limité pour l'instant, je ne me suis pas encore permis de modifier quoi que ce soit ! Le DSM v6.0 est tout neuf, je l'ai réinstallé suite à une demande du support Synology lors de l'ouverture d'un ticket pour un problème de serveur de messagerie. Je ne pense pas que le support ai modifié des choses à ce niveau là (Enfin j'espère !!!).
  9. Bonjour, Je possède une DS212+II en DSM v6.0 et j'essaie tout d'abord de me connecter avec PuTTY en mode root en appliquant la méthode décrite par Synology. https://www.synology.com/fr-fr/knowledgebase/DSM/tutorial/General/How_to_login_to_DSM_with_root_permission_via_SSH_Telnet Cependant, après avoir exécuté la commande sudo -i et saisi une nouvelle fois le mot de passe admin, j'ai un retour à la ligne avec un curseur qui clignote. Je peux saisir du texte dans la console mais aucunes commandes ne semblent fonctionner (ls, cd .., help, etc.) Une idée pour se sortir de là ?
  10. Bonjour, Je n'arrive pas à envoyer de mail à partir de round cube alors que la réception fonctionne correctement. J'ai un nom de domaine chez DYN DNS toto.dyndns-ip.net. J'ai renseigné le champ MX avec totomail.dyndns-ip.net. Je ne suis pas sûr d'avoir compris la nature du nom de domaine que l'on doit renseigner dans ce champ. Doit on choisir son propre nom de domaine ou doit on utiliser un nom de domaine bien précis qui correspond à un serveur de messagerie bien particulier ? Merci d'avance pour vos réponses Guillaume