This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

psymon75

Membres
  • Compteur de contenus

    45
  • Inscription

  • Dernière visite

Tout ce qui a été posté par psymon75

  1. Bonjour à tous ! Je voudrais utiliser la web API disponible pour download station pour créer une application perso. J'ai lu la documentation fournie (http://download.synology.com/download/ds/userguide/Synology%20Download%20Station%20Official%20API_V9.pdf) et fait un test avec mon syno. Malheureusement, quand je test par exemple : http://ip_du_syno/webapi/query.cgi?api=SYNO.API.Info&version=1&method=query&query=ALL comme indiqué dans la doc, je tombe sur une page inaccessible... C'est peut être normal ? J'ai ensuite testé via une application C# de faire une requête GET mais j'ai un timeout. Quelqu'un connait un peu mieux cette API que moi ? Merci d'avance.
  2. psymon75

    Acc

    Bonjour, J'ai un petit soucis depuis peu avec mon syno (710+). Avant, j'avais aucun problème pour accèder à mes données via le réseau local (FTP, partage windows, serveur multimédia, etc... ). Mais du jour au lendemain, plus possible d’accéder, je dois passé par mon adresse externe... A quoi cela peut être dû ? EDIT : Disons que j'ai exactement le même problème que cet utilisateur mais j'aimerais trouver une autre solution que le reset... : Merci d'avance. Psymon75
  3. Après 2-3 manip, ca fonctionne bien ! Merci de votre aide.
  4. J'ai trouvé ça : http://forums.winamp.com/showthread.php?t=330269 . J'ai installé screen mais j'ai une erreur : il ne trouve pas /proc/version...
  5. D'accord j'ai regardé. Mais par exemple, je veux installer un serveur shoutcast, il n'y a pas de script de status je crois pour ce soft ? J'ai juste un script de lancement
  6. Bonjour, j'aimerais savoir où doit se situer le script de lancement ? dans le chroot ou le syno ? Merci d'avance !
  7. Bonjour à tous, J'aimerais savoir si il était possible de, par exemple, porter l'application serveur de ShoutCAST qui tourne sous linux, dans un SPK ? J'ai regardé un peu comment faire un SPK mais je ne sais pas si c'est possible de faire un simple port d'une application déjà existante ? EDIT : Je vais déjà essayer de regarder comment est créé ce paquet. Merci d'avance. Cordialement.
  8. Oui je vais faire pareil car j'ai déjà tout perdu une fois... je vais sauvegarder et faire de même ! Merci encore.
  9. Ca fonctionne je crois ! Il faut mettre un devant l'espace ! En tout cas merci de m'avoir fait remarquer cette erreur un peu.. bête ? Ca n’empêche pas que mon bug de dossier partagé m’embête toujours.
  10. Je crois que le problème vien de la... Mais j'ai eu un enorme bug sur mon syno et enfait pour faire cours j'avais renommé mon dossier "Partage INP4B" en "PartageINP4B" et après un reboot je me suis retrouver avec 2 dossier. L'un avec l'espace, l'un sans ! Et ce qui se passe c'est que, si je supprime celui où il y a l'espace, les 2 se suppriment ! De plus, tout ce que je met dans un va dans l'autre aussi ! J'ai donc pu voir que dans mon DSM je voyais les 2 dossiers mais en SSH je vois seulement celui avec l'espace ! J'espère que je suis assez clair... Je vais donc essayer de refaire un lien vers le dossier avec espace vu que c'est celui qui apparait en SSH. Maintenant, il faut savoir si c'est possible, comme tu me l'a dis au début, de faire un lien avec un espace dedans.
  11. Oui je l'ai fais à l'instant mais aucun changement..
  12. J'ai effectivement mis le répertoire de destination dans l'open_basdir. C'est "/volume1/PartageINP4B/Films" et le lien est "/volume1/video/FilmsPartage" Voici une screen de mon dossier /volume1/video où l'on voit le lien. http://hpics.li/c9bba1b
  13. Je me suis aussi rendu compte de cette erreur surtout que mon dossier de partage est PartageINP4B et non avec un espace entre les 2. Mais même avec cette correction il reste la même erreur : Warning: is_dir(): open_basedir restriction in effect. File(/volume1/video/FilmsPartage) is not within the allowed path(s): (/etc:/etc.defaults:/tmp:/usr/bin/php:/usr/syno/synoman:/var/packages/MailStation/target/roundcubemail:/var/run:/var/services/blog:/var/services/homes:/var/services/photo:/var/services/web:/var/spool/php:/volume1/@tmp/php:/volume1/PartageINP4B/Films:/volume1/video:/volume1/video/FilmsPartage) [/CODE] [/size][/font][/color]
  14. Bonjour à tous, J'utilise le SPK qui se trouve sur le forum "VideoStation" pour indexer les films sur mon syno. J'ai donc créé un lien symbolique dans le dossier d'indexiation qui pointe sur un dossier "externe" au dossier web pour y analyser son contenu. J'ajoute ce répertoire à open_basedir. Mais je me retrouve avec le même problème... : Warning: is_dir(): open_basedir restriction in effect. File(/volume1/video/FilmsPartage) is not within the allowed path(s): (/etc:/etc.defaults:/tmp:/usr/bin/php:/usr/syno/synoman:/var/packages/MailStation/target/roundcubemail:/var/run:/var/services/blog:/var/services/homes:/var/services/photo:/var/services/web:/var/spool/php:/video/FilmsPartage:/volume1/@tmp/php:/volume1/Partage INP4B/Films:/volume1/video:/volume1/video/FilmsPartage) in /volume1/web/video/lib/functions.php on line 412 [/CODE] [/size][/font][/color] [color=#24233A][font=Verdana, Arial, sans-serif][size=3]Comme vous pouvez le voir, l'erreur est totalement illogique. J'aimerais savoir pourquoi lors que le SPK a ajouté "/volume1/video" à open_basedir, cela à fonctionner, mais quand moi j'ajoute "/volume1/video/FilmsPartage" cela ne fonctionne pas ?[/size][/font][/color] [color=#24233A][font=Verdana, Arial, sans-serif][size=3]Merci d'avance.[/size][/font][/color]
  15. Je suis dans le meme cas que toi mais ce que le support t'explique est embêtant car tu dois donner les droits sur le dossier WEB à ces utilisateurs... C'est pas pratique mais c'est malheureusement ce que je fais depuis un petit moment.
  16. Avec cette technique, les personne qui entreront le nom de domaine décrit dans le fichier .htaccess seront redirigé sur le dossier de site web personnel de la personne qui dispo du domaine (ce que je dois aussi mettre dans le htaccess ?
  17. Voila, j'avance car ma technique dites au début fonctionne ! Mais que avec des page HTML et pas PHP car le open_basedir ne me permet pas d'éxécuter les scripts... Pourtant le répertoire /var/services/homes est présent dans open_basedir...
  18. Enfait je vois bien ce que c'est mais je n'ai aucune idée de comment l'utiliser si j'ai un nom de domaine et ou mettre le fichier htaccess etc... EDIT : Et j'aimerais quand même savoir si ce que je vous propose au début est faisable ?
  19. Un sorte de redirection c'est ca ? Mais est-ce que avec l'URL rewritting l'url restera toujours celle du domaine même quand on change de page ?
  20. Merci de ta réponse mais justement je connais cette technique aussi mais c'est exactement ce que je demande car dans ce cas, l'adresse pour y accéder sera du style : www.monnas.com/~utilisateur1 mais ce n'est pas ce que je veux car mon utilisateur loue un nom de domaine...
  21. Je voudrais faire un peu près pareil sauf que pour moi les site personnels n'est pas une solution car les utilisateurs qui veulent héberger des site sur mon serveur ont un nom de domaine. Allez voir le sujet que je viens de poster si ca vous tente de m'aider !Merci
  22. psymon75

    Comment D

    Très bonne idée, merci ! je vais voir tous ca et je vous tiens au courant de mon avancement ici