This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

nougalo

Membres
  • Compteur de contenus

    23
  • Inscription

  • Dernière visite

  1. J'ai continué mes recherches pour mettre en place ce tunnel. J'ai vérifié mon fichier "etc/ssh/sshd_config" et ai changé les lignes suivantes pour les passer à yes AllowAgentForwarding yes AllowTcpForwarding yes J'y ai cru, mais ça n'a pas suffit. Quelqu'un a une piste ?
  2. Hello, J'essaie moi aussi de rediriger mon trafic vers mon NAS mais jusque là sans succès. Etant sous DSM6 et ayant l'habitude du reverse proxy natif, j'ai ajouté une règle du style : Source : https://tunnel.domain.com Destination : https://localhost:22 Puis dans Putty j'ai ajouté la conf suivante : Et je me connecte comme cela : Putty m'indique ensuite un "Connection Time Out", sans me prompter le couple user/password admin du Syno. Je ne sais pas trop ce que j'ai raté, j'ai l'impression que cette configuration est simple mais je ne vois pas d'où peut venir l'erreur. Y a t il une spécificité à DSM 6 ? Ps : je me suis inspiré de ce tuto : http://geeknewz.fr/tuto-proxy-socks-via-ssh-sur-synology-15567 Merci.
  3. Merci @Vinky, tout est ok maintenant. J'ai revu ma conf reverse proxy et j'ai tout redirigé sur les ports HTTPS des applications (5001, 8001...), sans utiliser la redirection que DSM propose. @Giome Tu ne peux pas simplement ajouter un certificat pour tes services hébergés sur les RPIs avec let's encrypt ?
  4. Je sais pas, j'avais peut être un soucis avec ma config et la désinstallation/réinstallation a tout réglé. Ca mis à part, le paquet synology semble vraiment largué au niveau des MAJ, je pense qu'il est préférable de passer par la source officielle.
  5. Donc ça marche par exemple avec dsm ou download station ? Tu as bien la même chose que ce que j'ai indiqué dans ma procédure ? C'est quoi ta règle de reverse proxy pour dsm ?
  6. Je viens de réaliser que le paquet Plex de Synology est vraiment en retard de version par rapport au paquet officiel. J'ai désinstallé le paquet Syno, récupéré celui que Plex fournit et ô surprise... Plex gère nativement l'authentification.
  7. Je m'en suis sorti pour les services web mais j'ai du revoir ma config. 1) Supprimer les éventuelles règles du proxy inversé de DSM 2) Dans web station, créer un virtual host qui servira de règle de redirection avec : Nom d'hôte : service.domain.fr port : 80/443 protocole : HTTP/HTTPS nom du sous-dossier : web/service Maintenant en entrant service.domain.fr on tombe sur l'application web service, installée dans le dossier web. 3) Créer un autre virtual host pour rediriger le traffic http vers https : Nom d'hôte : domain.fr port : 80 protocole : HTTP nom du sous-dossier : web 4) Créer un fichier .htaccess (le "." au début est important, il fait partie du nom de fichier) dans le dossier web, avec le contenu suivant : RewriteEngine On RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} Dorénavant toutes les requêtes à destination d'un web service seront redirigées vers l'application concernée, et passées en HTTPS si besoin est. En espérant que cette procédure puisse servir à d'autres :) @Vinky Par contre cette technique ne fonctionne que pour les services web installés dans "/web". Comment tu t'en sors pour rediriger les applications natives, genre DSM ou Download ? Il y a bien l'option native de DSM, mais ça ne me plait pas vraiment d'avoir à ouvrir des ports supplémentaires sur mon routeur. Merci pour le coup de main en tout cas.
  8. Ah oui, tu passes par web station pour indiquer l'emplacement de ton htaccess et le fichier contient une règle de redirection c'est ça ? Tu mets quoi comme règle ?
  9. Bonjour à tous, Mon Plex étant ouvert sur l'extérieur je peux y accéder depuis un navigateur web. C'est super, le seul problème c'est qu'aucune authentification n'est prévue, ni par plex, ni par syno pour protéger une connexion http, ce qui fait que n'importe qui connaissant l'URL peut rentrer comme dans un moulin. Quelqu'un connait une façon de contourner ce problème ? Merci d'avance, M.
  10. Hello, La semaine dernière j'ai enfin désinstallé Haproxy qui n'était plus supporté sur DSM 6.0 pour utiliser la nouvelle fonction de reverse proxy. Tout fonctionne super bien pour mes redirections url/port mais je n'ai par contre plus la redirection automatique vers le HTTPS que j'avais mis en place via Haproxy. Il existe la redirection HTTPS auto du syno mais qui ne fonctionne que pour quelques services natifs, donc cette solution ne me convient pas vraiment. Je me suis renseigné sur ce forum et sur internet en général pour trouver une solution mais jusque là je n'ai rien trouvé de convainquant. Avez vous une solution à proposer pour rediriger le HTTP vers du HTTPS automatiquement, quelque soit le service appelé ? Merci d'avance, M.
  11. Ouais ouais, c'est ce que je me suis dis, mais je pourrais faire les mises à jour en auto depuis owncloud. C'est ce que je faisais avant sur mon ancien serveur et ça fonctionne plutôt bien.
  12. D'après le ce post sur le forum Owncloud https://forum.owncloud.org/viewtopic.php?f=31&t=27360 le message que j'ai eu n'était pas très important, je l'ai donc ignoré et l'install c'est bien passé. Il reste juste à créer le répertoire data et mettre les bons droits, et ça passe.
  13. Bon apparemment je ne suis pas le seul à avoir un problème avec le paquet synocommunity. Je suis donc passé par l'install d'owncloud via l'archive récupérée sur le site officiel. J'ai du mieux, je peux accéder à la page de connexion, mais j'ai ensuite un soucis avec open_basedir et ma version de php 32bits : Il semble que cette instance ownCloud fonctionne sur un environnement PHP 32-bits et open_basedir a été configuré dans php.ini. Cela engendre des problèmes avec les fichiers supérieurs à 4Go et cela est donc fortement déconseillé. Veuillez supprimer la configuration open_basedir de votre php.ini ou basculer sur une version PHP 64-bits. Je ne sais pas vraiment interpréter ce message et je ne sais donc pas quoi faire. Quelqu'un a une idée ?
  14. Hello, J’essaie depuis ce matin d'installer le packet Owncloud fournit par la communauté syno mais jusque là sans succès. L'installation se passe bien, le service démarre, mais je ne peux pas accéder à l'application (le message classique "la page demandée n'existe pas"). J'ai bien créé le dossier Owncloud dans mon rep web, j'ai définit les droits préconisés via les commandes : chown -R http:http /volume1/web/owncloud chmod 750 /volume1/web/owncloud/data chmod 777 -R /volume1/web/owncloud/config Dans phpMyAdmin je vois ma base owncloud avec le user associé, mais impossible de me connecter à Owncloud via le web, ou en local. J'ai d'autres services web qui eux par contre fonctionnent très bien. Je copie mon fichier config.php pour vous aider à y voir plus clair. <?php $CONFIG = array ( 'instanceid' => 'ocxfdorhnvjb', 'passwordsalt' => 'passblablabla', 'secret' => 'secretblablabla', 'trusted_domains' => array ( 0 => 'web.domain.tld', ), 'datadirectory' => '/volume1/web/owncloud', 'overwrite.cli.url' => 'http://web.domain.tld/owncloud', 'dbtype' => 'mysql', 'version' => '8.0.2.0', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => '', 'dbuser' => 'owncloud', 'dbpassword' => 'monpassword', 'installed' => true, ); Quelqu'un pour m'aiguiller ?
  15. Il me manquait simplement le define('SELF_URL_PATH', 'http://rss.domain.tld/'); dans mon fichier de conf TTRSS, je n'avais pas du tout pensé à modifier ça. Merci pour ta patience et tes connaissances Fenrir, @+.