This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

CaptainIgloo

Synozwave : La Domotique Facile Avec Openzwave

Messages recommandés

Et voici pour le chantier de la prochaine version (0.0.014) :

  • Portage sur les synos PPC/PPC854x/PPC824x

Visiblement j'ai déjà la version interface web de proposée pour mon DS508 donc architecture PPC854x

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Tout d'abord super boulot!!

Ensuite, ou peut-on trouver une présentation de l'API php de la lib OpenZwave? Je souhaite l'utiliser sans la partie IHM.

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans ton répertoire web synozwaveconfig il y a un répertoire API avec des exemples d'usages.

Partager ce message


Lien à poster
Partager sur d’autres sites

Visiblement j'ai déjà la version interface web de proposée pour mon DS508 donc architecture PPC854x

Normal car l'IHM est en php elle donc compatible avec tous les Synos.

Pour la lib OpenZwave et les modules matériels Synozwave n'est pas encore compatible avec toutes les architectures.

J'ai fais ma mise à jour, j'ai installé les 2 paquets, mais SynozwaveWeb n'installe pas dicône de démarrage contrairement à synozwave. Comment je peux faire pour par exemple le lancer depuis DSM ?

Je l'ai mis en bookmark et ça fonctionne sans soucis, c'est comme ça qu'il faut faire ?

C'est momentané rafraichissement du cache.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

j'ai mit à jour mon synology en 4.1, puis installé la nouvelle version 0.13 de synozwave, et ma clé ne fonctionne plus.

Est-ce qu'il fallait rester en 4.0 ?

merci

a+

steph

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

j'ai mit à jour mon synology en 4.1, puis installé la nouvelle version 0.13 de synozwave, et ma clé ne fonctionne plus.

Est-ce qu'il fallait rester en 4.0 ?

merci

a+

steph

Bonjour,

j'ai rebooté mon syno, la clé fonctionne.

a+

steph

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens d'expérimenter une autre technique plus ou moins hasardeuse.

Dans la prochaine release 0.0.013, il y a une fonction de monitoring Ping/WOL.

Il suffira de créer une scène pour tous les jours où le smartphone (pour moi un iphone) est connecté et répond au ping pour actionner un autre périphérique ou une autre scène ou un périphérique virtuel exécutant les requêtes suivante. J'ai testé cela fonctionne pour l'instant j'allume une lampe dès que mon iphone se connecte au wifi maison.

http://ipdusyno:4020/data=vscenes&action=edit&url=[iPdusyno]&sceneNum=[NUMBER]&setEnabled=[True/False]
http://ipdusyno:4020/data=vscenes&action=edit&url=[iPdusyno]&sceneNum=[NUMBER]&setEnabled=[True/False]

Bonjour,

juste pour info, avec la version 13, les urls lancés depuis un navigateur font toujours planter synozwave.

a+

steph

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Dans les prochains jours je vais recevoir mon DS213air + un DD WD Red 2 To + une clée USB Z-Stick S2 + une prise EVERSPRING AN157-6, je vais enfin pouvoir tester synoswave.

Je souhaite aussi m'équiper d'un détecteur AEON LABS - Multisensor et d'une caméra FOSCAM, vous me conseiller la FI8918W ou la FI8910W ?

Modifié par Arkane

Partager ce message


Lien à poster
Partager sur d’autres sites

Le 4en1 Aeon labs n'est pas encore fonctionnelle.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,
Félicitations pour votre super boulot.
C'est impressionnant.
Je fais des tests avec le multi capteur 4 en 1 aeon labs. DSB05

Il est bien reconnu.

Résultats pour l'instant :

La détection de présence ne renvoit rien

Capteur luminosité ne renvoit rien

Capteur humidité non plus

Capteur température : fonctionne depuis ce soir, par contre m'affiche -5 degrés alors que la température est de 23° dans la piéce. (merci le moniteur cathodique en 20 pouces). Ce -5 correspond exactement à la conversion farenheit vers degrés.

Je n'ai pas trouvé comment modifier l'unité. Elle est grisée dans les propriétés.

Capteur ouverture Fibarro fonctionne nickel.

Je recois un sms par le biais du périphérique virtuel Google Agenda dés que le capteur s'active.

J'ai fait également des tests d'activation de scéne depuis mon galaxy SIII.
Depuis le navigateur installé par défaut, l'activation / désactivaton fonctionne mais fait planter SynoZwave.

Depuis Dolphin Browser, fonctionne sans probléme.

J'ai un probléme pour afficher ma Camera Heden V5.5 (wifi)

J'ai utilisé le périph. virtuel, renseigné tous les param. mais aucun affichage pour l'instant.

Je souhaiterais allumer une lampe dans la maison si une présence est détectée à l'extérieur, pourriez vous me conseiller un interrupteur déja reconnu par le SynoZwave ?

Est ce que le capteur 4 en 1 va fonctionner dans la prochaine version ?


Merci d'avance.

Modifié par maxfacel

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Félicitations pour votre super boulot.

C'est impressionnant.

Je fais des tests avec le multi capteur 4 en 1 aeon labs. DSB05

Il est bien reconnu.

Résultats pour l'instant :

La détection de présence ne renvoit rien

Capteur luminosité ne renvoit rien

Capteur humidité non plus

Capteur température : fonctionne depuis ce soir, par contre m'affiche -5 degrés alors que la température est de 23° dans la piéce. (merci le moniteur cathodique en 20 pouces). Ce -5 correspond exactement à la conversion farenheit vers degrés.

Je n'ai pas trouvé comment modifier l'unité. Elle est grisée dans les propriétés.

Capteur ouverture Fibarro fonctionne nickel.

Je recois un sms par le biais du périphérique virtuel Google Agenda dés que le capteur s'active.

J'ai fait également des tests d'activation de scéne depuis mon galaxy SIII.

Depuis le navigateur installé par défaut, l'activation / désactivaton fonctionne mais fait planter SynoZwave.

Depuis Dolphin Browser, fonctionne sans probléme.

J'ai un probléme pour afficher ma Camera Heden V5.5 (wifi)

J'ai utilisé le périph. virtuel, renseigné tous les param. mais aucun affichage pour l'instant.

Je souhaiterais allumer une lampe dans la maison si une présence est détectée à l'extérieur, pourriez vous me conseiller un interrupteur déja reconnu par le SynoZwave ?

Est ce que le capteur 4 en 1 va fonctionner dans la prochaine version ?

Merci d'avance.

Pour le 4 in 1, le motion devrait fonctionner après avoir associer ce dernier à au groupe 1 avec la requête http://[ipdusyno]:4020/data=association&action=add&group=1&addDeviceNum=1&toDeviceNum=[id de ton 4 en 1] (il faudra relancer le paquet éventuellement).

Pour la camip, si tu utilises SAFARI (ios) cela fonctionne normalement ?

Si sur PC Windows avec IE, l'authentification camip ne fonctionne pas (restriction microsoft).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Diaoul,

Je ne suis pas le développeur, juste un contributeur (Bilil est le développeur et il est le seul. Question rassemblement on est pas dans un dev collaboratif).

Le portage hors Syno n'est pas vraiment la priorité pour Bilil. L'intégration de nouveaux modules périphériques est principalement porté par le projet sous-jacent OpenZwave.

Python ou lib C compilé cela ne changera pas le principale problème qui est l'intégration des nouveaux modules périphériques qui dépend de cycle d'implémentation plus ou moins long et quelques soit le projet.

Sachant que les gros intégrateurs de box domotique (Vera, Eedomus, hc2, Zipabox, ...) ont tous le même problème, suivre la mise sur le marché de nouveaux modules. Python ou autres ne change pas grand chose.

Au niveau fonctionnelle et IHM, le projet est par contre ouvert puisque le moteur Synozwave fournit une API dans le paquet.

D'autres utilisateurs de ce forum ont déjà fait ce type de proposition, mais le projet est celui de Bilil.

Partager ce message


Lien à poster
Partager sur d’autres sites

maxfacel, le capteur d'ouverture fibaro, c'est lequel ? le nouveau avec possibilité de mettre une sonde de température ?

Tout à fait.

Ci-joint le lien d'un test

http://www.domotique-info.fr/2012/12/test-nouveau-capteur-zwave-fibaro-fgk101/

@captainigloo : merci pour la réponse pour le capteur 4 en 1. Je vais essayer ca.

Dans le test du fibarro, il est fait mention de la possibilité de brancher un bouton poussoir de sonnette.

Est il possible de brancher un capteur IR à la place ?

J'ai la possibilité d'en mettre un au niveau de la sonnette et le fibaro est installé juste à côté de l'arrivée du cable qui relie la sonnette à la sonnerie. Il y a plusieurs fils de libre. L'idée est d'utiliser ces fils pour déclencher une détection à l'extérieur au niveau de la porte d'entrée.

Modifié par maxfacel

Partager ce message


Lien à poster
Partager sur d’autres sites

excellent !!! je l'avais commandé lors d'une commande groupée, mais vu la galère avec un périph non supporté, je n'ai pas osé l'installer.

Je vais le faire dès que le temps le permet (en extérieur pour moi).

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le 4 in 1, le motion devrait fonctionner après avoir associer ce dernier à au groupe 1 avec la requête http://[ipdusyno]:4020/data=association&action=add&group=1&addDeviceNum=1&toDeviceNum=[id de ton 4 en 1] (il faudra relancer le paquet éventuellement).

Pour la camip, si tu utilises SAFARI (ios) cela fonctionne normalement ?

Si sur PC Windows avec IE, l'authentification camip ne fonctionne pas (restriction microsoft).

J'ai fait l'essai avec l'url.

Si je n'ouvre pas tous les ports au niveau du pare feu sur le syno, j'ai le msg "délai d'attente dépassé"

J'ai pourtant configuré le syno comme indiqué dans le tutoriel sur le wiki

http://wiki.synozwave.com/index.php?title=SynoZwave_Acc%C3%A8s_distant

Une idée de ce qui peut clocher ?

L'appel à l'url a fonctionné pour le capteru aeon 4 en 1 , j'ai relancé le paquet derrière mais il ne me détecte toujours rien.

lorsque je relance le paquet, je perd toutes les déclaration faites au niveau du dashboard (nom de capteur et localisation)

Partager ce message


Lien à poster
Partager sur d’autres sites
Bilil est le développeur et il est le seul. Question rassemblement on est pas dans un dev collaboratif.

L'intégration de nouveaux modules périphériques est principalement porté par le projet sous-jacent OpenZwave.

Donc le seul moyen pour les dev de participer au projet et de contribuer à OpenZwave qui lui est open source.

Pour suivre l'évolution du code => http://code.google.com/p/open-zwave/source/list

Pour communiquer avec la communauté: https://groups.google.com/forum/#!forum/openzwave

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Le capteur 4 en 1 aeon labs fonctionne au niveau de la détection de mouvement.
J'ai utilisé la commande fournit par CaptainIgloo

http://ip du syno:4020/data=association&action=add&group=1&addDeviceNum=N° de device du 4 en 1&toDeviceNum=N° de device du 4 en 1

Par contre, le capteur de température qui a fonctionné la semaine dernière ne fonctionne plus.

Une idée pour le ré-activer ?

Sinon, des nouvelles de la mise en place de la version 0.0014 ?

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Petite question à la communauté.

La détection d'ouverture pour le Fibaro et la détection de présence pour le Aeon 4 en 1 fonctionnent et sont bien affichées par SynoZwave.

J'ai créé 2 scénes.

Une qui déclenche la siréne Fortrez SSA2 pour le Fibaro si la porte est ouverte.

L'autre qui fait flasher la siréne SSA2 si une présence est détectée à l'extérieure.

Lorsque je lance mes scénes en manuel, elles fonctionnent bien.

En automatique, je vois bien les scénes s'éxécuter (fléche verte sur le dashboard au niveau de chaque scéne) mais il ne se passe rien.

Pas de siréne qui hurle ni de flash qui flash.

J'ai fait l'essai en ne mettant aucune plage horaire sur les scénes et également avec des plages horaires, pas de différences.

Est ce que quelqu'un a déja rencontré le même problème.

Merci pour votre aide.

Modifié par maxfacel

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Petite question à la communauté.

La détection d'ouverture pour le Fibaro et la détection de présence pour le Aeon 4 en 1 fonctionnent et sont bien affichées par SynoZwave.

J'ai créé 2 scénes.

Une qui déclenche la siréne Fortrez SSA2 pour le Fibaro si la porte est ouverte.

L'autre qui fait flasher la siréne SSA2 si une présence est détectée à l'extérieure.

Lorsque je lance mes scénes en manuel, elles fonctionnent bien.

En automatique, je vois bien les scénes s'éxécuter (fléche verte sur le dashboard au niveau de chaque scéne) mais il ne se passe rien.

Pas de siréne qui hurle ni de flash qui flash.

J'ai fait l'essai en ne mettant aucune plage horaire sur les scénes et également avec des plages horaires, pas de différences.

Est ce que quelqu'un a déja rencontré le même problème.

Merci pour votre aide.

La raison du dysfonctionnement venait des actions à rebours que j'avais paramétré sur mes scènes.

Pour la sirène, j'avais mis comme action à rebours "arrêt de la sirène au bout de 60 secondes"

J'ai supprimé ce paramétrage et maintenant ça fonctionne.

Si quelqu'un peut m'éclairer sur ces actions à rebours il est le bienvenu.

Partager ce message


Lien à poster
Partager sur d’autres sites

Question envoyé par mail à Bilil et j'espère avoir une réponse si c'est le cas je vous en ferai part.

Bonjour,

La partie serveur web caché m'intéresse fortement. Je n'arrive pas à piloter une vanne Danfoss, mais la question n'est pas là.

Ma question concerne les sources de cette application. J'avoue que tu as du faire beaucoup de développement pour proposer une tel solution. Je
suis moi aussi développeur d'un application pour la Domotique (l'IPX).

J'aimerai intégrer du ZWave à ma solution, mais étant donné que la tienne n'est pas open-source et que l'autre développeur utilise un QNAP, je suis dans l'impasse.

Voici donc ma question :

As-tu l'intention de rendre disponible tes sources ?

Si ce n'était pas le cas, je me tournerai donc vers l'écriture d'une solution que je proposerai des que possible en open-source.

Personnes ayant déjà posé la question :
http://www.touteladomotique.com/forum/viewtopic.php?f=112&t=8243&sid=480101e4d50341b8c8bf2e9d126b0402&start=12
http://maison-et-domotique.com/blog/2012/08/10/du-zwave-sur-votre-nas-synology/#comments

Cordialement
Thomas

PS : Je mets ce message sur le forum si tu veux répondre publiquement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Pour le moment, je n'ai pas vraiment l'intention de rendre les sources publiques. Il est vrai qu'actuellement j'ai un peu moins de temps à y consacrer (pour des raisons persos) mais je compte m'y atteler très bientot.
Il faut savoir que SynoZwave est basé sur la librairie OpenZwave mais tout le reste (périphériques virtuels, serveur web, interface web, intégration de blockly, scènes, etc) sont des ajouts personnels. La partie Zwave n'est pas compliquée en soit mais c'est le reste qui prend énormément de temps.
Pour ce qui est des compatibilités matériels, je suis à 100% dépendent de la librairie OpenZwave. En ce qui concerne la vanne, elle fonctionnait avec une release précédente mais à présent elle à l'air de moins bien répondre. Je rencontre un peu le même problème avec la télécommande AeonLabs 4 boutons et le détecteur 4 en 1.
Pour ce qui est du portage sur d'autres architectures, cela nécessitera certainement des adaptations suivant les possibilités offertes par ces plateformes.
Bonne journée,
Bilil

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.