This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Condorman

Gros problème : perte raid

Messages recommandés

pas grave, il fonctionne pas, on fait tout en ligne de commande ;)

ce que je te propose :

on crée un espace sur ton disque sde

tu prend ton temps pour copier tes données

ensuite tu met le disk en securité en l'enlevant

et après tu fait un ticket syno et ils se demerdent

c'est ok  sur le principe ?

Partager ce message


Lien à poster
Partager sur d’autres sites

pour etre honnete, j'ai un problème : je trouve pas d'outil sur syno pour créer un partition gpt :s la liste des outil que je connais ne sont pas inclu

je v chercher mais ca sera pour demain, desolé

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok merci.

Bonne nuit!

merci mais je crois que trouvé :

synopartition --part /dev/sde 5 0

tu test, toute facon, sde est vide, ca risque pas grand chose ;)

après fait moi un sfdisk -l /dev/sde pour voir ce que cela donne ;) 

Modifié par gaetan.cambier

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé, du coup j'étais parti me coucher ...

Voilà le résultat des commandes :

Sino> sfdisk -l /dev/sde
/dev/sde1                   256         4980735         4980480  fd
/dev/sde2               4980736         9175039         4194304  fd


Sino> synopartition --part /dev/sde 5 0

        Device   Sectors (Version6: 1-Bay)
     /dev/sde1   4980087 (2431 MB)
     /dev/sde2   4192965 (2047 MB)
Reserved size:    257040 ( 125 MB)
Primary data partition will be created.

WARNING: This action will erase all data on '/dev/sde' and repart it, are you sure to continue? [y/N] y
Cleaning all partitions...
Creating sys partitions...
Creating primary data partition...
Please remember to mdadm and mkfs new partitions.
Sino> sfdisk -l /dev/sde
/dev/sde1                    63         4980149         4980087  83
/dev/sde2               4980150         9173114         4192965  82
/dev/sde3               9430155      7814032064      7804601910  83

 

Est-ce qu'il ne faudrait pas sortir le sde du raid md1 ?

md1 : active raid1 sda2[0] sdb2[4] sdc2[1] sdd2[2]
      2097088 blocks [5/4] [UUU_U]

avant c'était :

md1 : active raid1 sda2[0] sdb2[4] sdc2[1] sdd2[2] sde2[3]
      2097088 blocks [5/5] [UUUUU]

D'ailleurs, je viens de recevoir un mail  (il n'est pas complètement mort ...):

Cher utilisateur,

Le volume système (Swap) sur Sino est passé en mode dégradé. (Nombre total de disques durs : 5 ; nombre de disques durs actifs : 4)

Veuillez redémarrer le système, et il se réparera automatiquement au démarrage.

Sincères salutations,
Synology DiskStation

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé, du coup j'étais parti me coucher ...

faut pas être désolé, toute facon, j'était crevé aussi, et j'aurai pas continué (faire ce genre de chose quand on a du mal à voir son écran, c'est pour faire des conneries) ;)

 bon, maintenant, je sais ce que fait exactement cette command, elle sert à initialisé le disque avec les belle partition toute faite :)

et comme elle a effacé toute tes partitions sur sde, sde à été ejecté des raid md0 et md1 (tu as surement pas eu le temps de le voir pour md0, s'est surement pas reste dans cet etat longtemps, une histoire de quelques minutes à peine)

--> non, pas besoin de modifier les raid md0 et md1 ils sont prevu comme ca, qd tu n'a par exemple que un disque le raid (md0 et md1) affiche U _ _ _ _ donc surtout pas modifié, faudrait tout refaire après et synology se rendrait compte que tout a été trafique

bon, ici, on va simuler un volume2 en raid1 basic et monodisque (c'est ce qui sera le + simple à faire)

bon, je crée le raid sur md2, si tu préfère un autre numero pour le md, fait toi plaisir :p (entre 0 et 127 sauf ceux déjà utilisé bien sur ;))

mdadm --create /dev/md2 --metadata 1.2 --force --raid-devices=1 /dev/sde3

un petit  "cat /proc/mdstat" serait bien après pour avoir le retour ;)

Modifié par gaetan.cambier

Partager ce message


Lien à poster
Partager sur d’autres sites
Sino> mdadm --create /dev/md2 --metadata 1.2 --force --raid-devices=1 /dev/sde3
mdadm: a RAID level is needed to create an array.

 

Faut il rajouter cela ?

--level=raid0

Partager ce message


Lien à poster
Partager sur d’autres sites
Sino> mdadm --create /dev/md2 --metadata 1.2 --force --raid-devices=1 /dev/sde3
mdadm: a RAID level is needed to create an array.

 

je suis con ...

mdadm --create /dev/md2 --metadata 1.2 --level=1 --force --raid-devices=1 /dev/sde3

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok, c'est fait :

Sino> mdadm --create /dev/md2 --metadata 1.2 --level=1 --force --raid-devices=1
/dev/sde3
mdadm: array /dev/md2 started.
Sino> cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md2 : active raid1 sde3[0]
      3902299776 blocks super 1.2 [1/1] [U]

md127 : active raid5 sdb5[5] sdd5[3] sdc5[2] sda5[4]
      5846338944 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

md3 : active raid5 sdd6[0] sdb6[3] sda6[2] sdc6[1]
      2930228352 blocks super 1.2 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

md4 : active raid1 sda7[0] sdb7[1]
      976646336 blocks super 1.2 [2/2] [UU]

md1 : active raid1 sda2[0] sdb2[4] sdc2[1] sdd2[2]
      2097088 blocks [5/4] [UUU_U]

md0 : active raid1 sda1[0] sdb1[1] sdc1[2] sdd1[3]
      2490176 blocks [4/4] [UUUU]

unused devices: <none>
Sino>

 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est fait :

Sino> mkfs.ext4 /dev/md2
mke2fs 1.42.6 (21-Sep-2012)
Filesystem label=1.42.6-5592
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
243900416 inodes, 975574944 blocks
25600 blocks (0.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3124756480
29773 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
        4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
        102400000, 214990848, 512000000, 550731776, 644972544

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok super ! Sacré support !

Sino> mount /dev/md2 /volume2

Sino> cd volume2

Sino> df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       2.3G  1.4G  868M  61% /
/tmp            3.0G  704K  3.0G   1% /tmp
/run            3.0G  2.2M  3.0G   1% /run
/dev/shm        3.0G     0  3.0G   0% /dev/shm
none            4.0K     0  4.0K   0% /sys/fs/cgroup
/dev/bus/usb    3.0G  4.0K  3.0G   1% /proc/bus/usb
/dev/vg1000/lv  9.0T  8.4T  630G  94% /volume1
/dev/md2        3.6T   89M  3.6T   1% /volume2

Bon à présent je vais pouvoir faire mes copies, je peux déjà mettre 3.6 To de côté...

Quelles seront les commandes avant de retirer le disque ?

Je pourrai le retirer à chaud sans éteindre le synology ? Car j'avais vu le le service "hotplugd" n'avait pas été lancé au dernier démarrage foireux...

Et si je veux re-mettre un autre disque après, comment cela se passe ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

en fait pour pouvoir retirer/brancher un disque à chaud, c'est + matériel : la masse est plus longue dans le connecteur pour se brancher/debrancher en premier/dernier et eviter tout choc électrique.

dans un raid multidisk, de toute facon, une fois le disk ejecté, des que tu le remet, il sera completement resynchroniser --> aucune importance

ici, comme c'est une sauvegarde, il vaut mieux :

  • demonter le volume
  • arreter le raid

et seulement ensuite ejecter le disk à chaud

les commande sont :

umount /volume2
mdadm --stop /dev/md2

 

et fini (et en cas de problème avec le nas, le disk sera au pire lisible sous n'importe quel linux)

 

bon, prend ton temps, je crois que tu maitrise la copie en ligne de commande :p

Modifié par gaetan.cambier

Partager ce message


Lien à poster
Partager sur d’autres sites

Dernière question :

Est-ce que si je sors le disque, je pourrai le mettre dans un boitier USB et le brancher sur un windows.

Il me semble que j'avais déjà réussi à lire une partition ext4.

Est-ce qu'il en sera de même dans ce cas où c'est un disque issue d'une partition raid ?

 

Pour la copie, j'avais mis un midnight commander sur le Ds1515+ et il fonctionne alors cela me permet de facilement me déplacer dans les répertoires et de faire mon choix ...

Partager ce message


Lien à poster
Partager sur d’autres sites

non, la partition raid ne sera jamais reconnue

je sais que techniquement, on pourrrait retrouver l'endroit de depart de la partition ext4 sur le disque, ca doit etre possible, mais c'est dangereux (cela impliquerai de trafiquer la table de partition), et franchement je me suis jamais amusé à çà

totue facon, un live cd/usb ubuntu et tu as acces à ta partition windows si tu veux transférer sur ton pc ;)

ca sera + simple pour tout le monde

Partager ce message


Lien à poster
Partager sur d’autres sites

OK.

Je me pose juste la question de l'intérêt d'avoir associé la partition /dev/sde3 à un volume raid (md2)

Est-ce qu'il n'aurait pas été possible de formater et de monter directement /dev/sde3 ?

Dans ce cas, la partition n'aurait-elle pas été lisible par Linux et windows directement ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Ha OK, je comprends.

Bon en tout cas, si tu passes un jour par La Rochelle, je te paye un coup à boire une bière ( belge :-) ?)  !

Grâce à toi, j'attends avec moins d'impatience (pendant que mes copies se font) le support Synology..

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ha OK, je comprends.

Bon en tout cas, si tu passes un jour par La Rochelle, je te paye un coup à boire une bière ( belge :-) ?)  !

Grâce à toi, j'attends avec moins d'impatience (pendant que mes copies se font) le support Synology..

 

c'est sur, le + important sera copié deja

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, alors voilà comment cela se termine.

Grâce à l'aide de @Gaetan Cambier, j'avais accès à mon volume1 où j'avais toute mes données accessibles.

Avec mon disque en plus + des disques que j'ai branché en USB sur le NAS, j'ai réussi à sauvegarder tout ce qui me paraissait important.

3 jours après avoir rempli le formulaire du support Synology et auquel j'avais donné un descriptif détaillé des actions qui avaient été prises afin qu'ils comprennent bien dans quel état était mon NAS, le support m'a contacté par email. J'ai été assez déçu de leur réponse :

Merci de votre réponse, dans un premier temps lorsque vous avez constaté le crash de votre volume vous devriez être en mesure d' attendre nos investigations sur votre NAS. Mais là vous avez déjà fait des manœuvres sur votre NAS et donc tout ce qui pourrait advenir sera de votre responsabilité. J' ai bien pu parcourir votre fichier pdf et constaté que vous avez en effet essayer de faire certaines commandes qui vous ont servi, mais pour des raisons de procédures je ne peux m' engager sur la démarche que vous avez suivi et donc je ne peux donner d' avis sur cette démarche. j' espère donc bien que vous aurez la possibilité de pouvoir sauvegarder toutes vos données. tout ce que je pourrai peut être faire c 'est l' analyse de vos logs et vous informer de l' état de votre volume avant le crash et aussi vous informer s' il y a des disques en cours de défection

Bref, comme vous avez dû vous débrouiller tout seul, et bien continuez ...

C'est dommage qu'ils ne traitent pas certaines situations peut être avec plus de réactivité que d'autre. Je vous explique pas déjà le stress que c'était quand mon problème est arrivé (je pensais avoir tout perdu) alors attendre 3 jours avant d'avoir un premier contact, c'est très très très long... Heureusement que dans mon job, on répond plus vite à nos clients...

Après mes sauvegardes, j'ai donc tenté le reboot. Cela m'a amené dans exactement la même situation c'est à dire que le paramétrage du RAID de mon volume de données était absent.

Alors, suite à un message lu sur un forum anglais, j'ai tenté la réinstallation du DSM. (après un reset sur le boitier)

J'ai croisé les doigts jusqu'au bout et finalement, j'ai bien retrouvé mon volume comme quand il m'avait quitté. J'ai eu 1 message comme quoi la partition système du disque 2 était plantée. Il l'a réparé sans message d'erreur.

Bon, il me reste à tout re-installer et à re--paramétrer les packages. (Au passage, mon md127 est redevenu md2 de base)

Je m'en tire pas mal.

Du coup, je suis devenu client de Crashplan et j'en ai pour quelques mois à tout sauvegarder (ADSL ....) car avant, je n'avais pas de sauvegarde de tout....

De tout manière, il faut que je me prépare à tout sauvegarder hors de mes 4 disques car j'aimerai remettre à plat ma config RAID et passer au btrfs quand celui ci sera disponible en mars prochain et comme il n'y aurait pas de migration possible, il faudra bien se débrouiller autrement ...

 

 

 

 

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.