This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

filou80

[Résolu]Base de données mariaDB10

Messages recommandés

Bonjour à tous

Je ne parviens à me connecter à ma base de donner mariadb10, aussi bien pour mon site perso que pour wordpress.
Par exemple que mettre à la case : adresse de la base de données, j'ai mis localhost ou localhost:/run/mysqld/mysqld10.sock meme avec mon ip cela ne fonctionne pas.
Quelqu'un à une solution ?
Pour info wordpress je l'ai installer sans passer par le plugin de synology car en passant par celui de synology réguliérement je suis bloquer pour faire les mise a jour de mes pages.
Merci par avance pour votre aide

 

Nom de la base de données Le nom de la base de données avec laquelle vous souhaitez utiliser WordPress.
Identifiant Nom d’utilisateur MySQL.
Mot de passe Votre mot de passe de base de données.
Adresse de la base de données Si localhost ne fonctionne pas, demandez cette information à l’hébergeur de votre site.
Préfixe des tables Si vous souhaitez faire tourner plusieurs installations de WordPress sur une même base de données, modifiez ce réglage.
     
     
     
     
     

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

J'ai également un WP en installation "classique". Je suis aussi sous MariaDB10.

Voici mon fichier wp-config.php

/** Nom de la base de données de WordPress. */
define('DB_NAME', 'wordpress');
/** Utilisateur de la base de données MySQL. */
define('DB_USER', 'root');
/** Mot de passe de la base de données MySQL. */
define('DB_PASSWORD', 'MONPASSESQL');
/** Adresse de l’hébergement MySQL. */
//define('DB_HOST', 'localhost');
/** MySQL hostname */
define('DB_HOST','localhost:/run/mysqld/mysqld10.sock');
/** Jeu de caractères à utiliser par la base de données lors de la création des tables. */
define('DB_CHARSET', 'utf8mb4');

As tu essayer de te connecter a PhpMyAdmin afin de valider tes identifiants MySQL ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci EVOTk pour votre réponse aussi rapide,

moi voila ce que cela me met en rentrant les données (je suis désespérer, cela fait un moment que je but dessus) :
PS : Je suis sur de moi au niveau des identifiants et autre, apres je sais pas si il faut activer option ou autre sur le nas ?
SI je met une page en php ou html elle apparait bien.

image.thumb.png.a5e6ae4c819258be8a6a3896bffc1835.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Effectivement les identifiants sont OK, l’installeur le dit !

Par contre tu as un soucis de permission. On dirait que root n'a pas l'autorisation de la créer lui même. Tu devrait créer toi la base de donnée ( par exemple "wordpress" ou "trucmuche" ) via PhpMyAdmin puis re-essayer.

Pour cela rien de compliquer, tu te connect a PhpMyAdmin, tu clique sur Database, tu rentre le nom de ta database dans "Database name" et tu clique sur Create

unR612D.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Peut-être éviter d’utiliser le compte root et créer un autre compte (WordPress par exemple)avec dans nom d’hôte = %

En extension d’authentification : Mysql native

Et cocher ou pas : créer une base portant son nom et donner à cet utilisateur tous les privilèges sur cette base.

Car peut-être que WordPress refusera si la base est déjà créé ( j’utilise pas WordPress)

 

 

————————————————————

Envoyé de mon iPhone en utilisant Tapatalk

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur mon NAS le port natif MariaDb est le 3307. Tu peux le voir en ouvrant l’app Maradb dans DSM


————————————————————
Forum IPOffice Avaya :

https://ipoffice.ovh

Envoyé de mon iPhone en utilisant Tapatalk

en général le port natif de MariaDb pour d’autres application c’est le 3306. Il faut peut être renseigner le nouveau port dans WordPress


————————————————————
Forum IPOffice Avaya :

https://ipoffice.ovh

Envoyé de mon iPhone en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu peux essayer de renseigner dans WordPress
localhost:3307 si tu n’as pas de case pour renseigner le port

Sinon regarde ce qui suit :

Un port alternative de MySQL dans Wordpress avec le fichier wp-config.php


Si votre hôte utilise un autre numéro de port pour votre base de donnée, vous avez besoin de changer la valeur DB_HOST dans le fichier wp-config.php pour installer Wordpress.

Pour localhost

define('DB_HOST', 'localhost:33XX');

Pour les autres

define('DB_HOST', 'mysql.example.com:33XX');

Remplacez la valeur 33XX avec le numéro de port que l'hébergeur web vous a fourni.



Les Pipes et les Sockets MySQL dans Wordpress avec le fichier wp-config.php


Si votre hôte utilise des Sockets ou des Pipes Unix, ajustez la valeur de DB_HOST dans le fichier wp-config.php.

define('DB_HOST', 'localhost:/var/run/mysqld/mysqld.sock');



Remplacez /var/run/mysqld/mysqld.sock avec le Socket ou le Pipe que l'hébergeur web vous a fourni.



Provenance : Courrier pour Windows 10



————————————————————
Forum IPOffice Avaya :

https://ipoffice.ovh

Envoyé de mon iPhone en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Du coup j'ai reinstaller wordpress via le plugin de synology je comprend rien car quand je regarde apres le fichier config.php c'est les même infos que je rentre pour installer le wordpress "classique".

Merci encore pour votre aide.
Si ils y en à qui passent par la est qui ont des solutions je suis preneur.

@+ Filou

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Il faut bien paramétrer webstation et le profil php associé.

 

Un peu de recherche sur le forum, permet de trouver des pistes de solutions.

Cf sujet :Installer wordpress sans passer par le centre de paquet

 

Bon courage

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.