This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

testadaz

Membres
  • Compteur de contenus

    76
  • Inscription

  • Dernière visite

À propos de testadaz

  • Rang
    Novice Syno

Visiteurs récents du profil

1 019 visualisations du profil
  1. testadaz

    [Funkwhale] besoin d'aide pour l'installation

    le problème semble lié aux permissions de nginx sur un synology. Le dev de l'appli n'a rien à voir avec cela c'est donc pour cela que j'ai posé la question ici. Je cherche quelqu'un qui maitriserait nginx dans l'environnement synology (par exemple @CoolRaoul ou @Fenrir vous auriez une idée ?? )
  2. testadaz

    [Funkwhale] besoin d'aide pour l'installation

    Ça ne fait vraiment avancer mon problème, mais cette anecdote est vraiment intéressante ! Une idée quelqu'un d'autre ?
  3. testadaz

    [Funkwhale] besoin d'aide pour l'installation

    non le reverse proxy pour cette appli est plus compliqué que ça. Je t'invite à jeter un oeil sur ces deux fichiers qui sont les templates https://code.eliotberriot.com/funkwhale/funkwhale/raw/develop/deploy/funkwhale_proxy.conf https://code.eliotberriot.com/funkwhale/funkwhale/raw/develop/deploy/docker.proxy.template pour en mesurer la complexité une fois modifié avec mes config j'ai toujours une erreur du type 2018/10/08 20:48:04 [emerg] 28018#28018: open() "/etc/nginx/sites-enabled/funkwhale.conf" failed (13: Permission denied) in /etc/nginx/nginx.conf:361 une idée ?
  4. testadaz

    docker et RAM utilisée

    je voulais dire que le téléchargement n'avance pas : Alors que speedtest me donne 70Mb/s...
  5. testadaz

    docker et RAM utilisée

    Bonjour, J'ai comme l'impression d'avoir un soucis avec Docker 1. La conso de RAM est vraiment bizzare : (cf pj) 2. lorsque je tente de faire un docker pull, je n'obtient jamais le paquet concerné ... Est ce que vous auriez une solution à cette maladie ? 😛
  6. testadaz

    [TUTO] Installer Bitwarden

    haha le monde est petit ^^ Sinon j'ai vu des mecs qui ne mettent pas la barrette synology dans leur ds218+. En effet, il y a des barrettes compatibles à 40€ (les 4Go) -par ex: HX318LS11IB/4 ) et il y a même des courageux qui mettent des barrettes de 8Go (alors que syno spécifie 6Go max (mais le chip intel peut aller à 8Go) et qui affirment avoir 10Go de RAM fonctionnelles (pour 80€).... Ca me tente bowdel il y a meme des gars qui changent les deux barettes pour passer à 16Go :
  7. testadaz

    [TUTO] Installer Bitwarden

    c'est possible mais zut... 84€ alors que mon nas est neuf... Fait chier ! à priori je ne suis pas seul dans le cas : https://www.ldlc.com/avis/PB00236549.html#PC01170575
  8. testadaz

    [TUTO] Installer Bitwarden

    J'ai du effectivement adapté 2/3 trucs, mais j'y suis arrivé par contre j'ai meme probleme qu'une personne sur le topic j'ai pas assez de ram et le container mssql ne fait que redémarrer... Donc je suis bloqué... tant pis, je vais attendre une version plus optimisée PS : C'est juste hallucinant en terme de conso de RAM, juste pour faire tourner une base de données, non ?
  9. testadaz

    [TUTO] Installer Bitwarden

    Je voulais me lancer dans l'install de cet outil, mais à la lecture de ce topic, il semble que pas mal de choses est changé depuis l'écriture du topic. Est ce que le premier post est à jour ? Est ce que je peux m'en servir pour installer Bitwarden les yeux fermés ?
  10. testadaz

    [pleroma] besoin d'aide pour l'installation

    Bon pour revenir au sujet de l'installation. J'ai réussi à passer la commande docker exec -i pleroma_postgres psql -U pleroma -c "CREATE EXTENSION IF NOT EXISTS citext;" en y ajoutant un sudo sudo docker exec -i pleroma_postgres psql -U pleroma -c "CREATE EXTENSION IF NOT EXISTS citext;" sudo docker-compose down ensuite j'ai crée le fichier config/secret.exs en modifiant comme demandé host secret_key_base email et puis j'ai lancé : sudo docker-compose build A ce moment là ca plante : Sending build context to Docker daemon 46.76MB Step 1/13 : FROM elixir:1.6-alpine ---> e9a46db6bcb9 Step 2/13 : ENV UID 911 GID 911 MIX_ENV prod ---> Using cache ---> 0751d8d14d4c Step 3/13 : ARG PLEROMA_VER=develop ---> Using cache ---> 1242816ebb1a Step 4/13 : RUN apk -U upgrade && apk add --no-cache build-base git ---> Using cache ---> 62f700e373b1 Step 5/13 : RUN addgroup -g ${GID} pleroma && adduser -h /pleroma -s /bin/sh -D -G pleroma -u ${UID} pleroma ---> Using cache ---> 227b615de897 Step 6/13 : USER pleroma ---> Using cache ---> 4632fc3f44a2 Step 7/13 : WORKDIR pleroma ---> Using cache ---> ac006edf589b Step 8/13 : RUN git clone -b develop https://git.pleroma.social/pleroma/pleroma.git /pleroma && git checkout ${PLEROMA_VER} ---> Using cache ---> cb39406ff8be Step 9/13 : COPY config/secret.exs /pleroma/config/prod.secret.exs ---> Using cache ---> 1270b84ce5c4 Step 10/13 : RUN mix local.rebar --force && mix local.hex --force && mix deps.get && mix compile ---> Running in dc439d6bbd27 ** (Mix.Config.LoadError) could not load config config/prod.secret.exs ** (File.Error) could not read file "/pleroma/config/prod.secret.exs": permission denied (elixir) lib/file.ex:310: File.read!/1 (mix) lib/mix/config.ex:189: Mix.Config.read!/2 (mix) lib/mix/config.ex:233: anonymous fn/3 in Mix.Config.read_wildcard!/2 (elixir) lib/enum.ex:1899: Enum."-reduce/3-lists^foldl/2-0-"/3 (stdlib) erl_eval.erl:670: :erl_eval.do_apply/6 (stdlib) erl_eval.erl:878: :erl_eval.expr_list/6 (stdlib) erl_eval.erl:404: :erl_eval.expr/5 The command '/bin/sh -c mix local.rebar --force && mix local.hex --force && mix deps.get && mix compile' returned a non-zero code: 1 Encore un problème de permission...
  11. testadaz

    [pleroma] besoin d'aide pour l'installation

    Tusky : https://f-droid.org/fr/packages/com.keylesspalace.tusky/ ou Mastalab : https://f-droid.org/fr/packages/fr.gouv.etalab.mastodon/
  12. testadaz

    [pleroma] besoin d'aide pour l'installation

    Je ne suis pas sur de vraiment comprendre ta question. Car si la personne veut suivre les 50 personnes oui il va falloir qu'elle suive (les 50 personnes). c’est la meme chose sur twitter ! Lorsque l'on crée un compte twitter on ne voit pas les centaines de milliers d'utilisateurs dans ton flux... il faut donc bien aller suivre les 50 personnes en quesitons Si ta question portait sur le fait que les 50 personnes en question sont sur des serveurs dont on ne connait pas l'adresse et même l'existence, c'est là que la magie du fediverse opere... Les serveurs sont fédérés et donc sont connectés entre eux (dès qu'il y a eu une première interaction entre eux) et il y a aussi un concept qui n'existe pas sur twitter c’est le "fil public global". Exemple: A est sur serveur "serveur A" il suit B qui est sur le "serveur B" mais il ne suit pas et ne connait C qui est sur le "serveur C". si B fait un retoot (équivalent d'un RT sur twitter), A va voir le post de C et donc pourra suivre C meme si il est sur sur serveur qu'il ne connaissait pas... du coup si A suit C, tous les utilisateurs du serveur A auront dans leur "fil public global" les messages de tous les utilisateur du serveur C (et donc de C) un fil public global qui présente les messages des utilisateurs de toutes les instances fédérées (source wikipédia : https://fr.wikipedia.org/wiki/Mastodon_(réseau_social)) Voila en espérant avoir été clair. Autres points primordiaux pour moi de l'intéret de ces nouveaux réseaux : La donnée est stockée dans un endroit de confiance la données n'est pas chez un GAFAM il n'y a pas de pub Après peut-être que les liens ci dessous t'aideront : https://twitter.com/EldritchCafe/status/1031162505165529090 https://www.numerama.com/tech/246684-debuter-sur-mastodon-9-questions-pour-tout-comprendre-au-reseau-social-decentralise.html https://docs.framasoft.org/fr/mastodon/ les liens concernent Mastodon, car il est un plus connu et dévelopé et donc il y a des guides pour les béotiens, mais Mastodon et pleroma ont le meme fonctionnement, il fonctionnent sur le meme réséau (le fediverse) pleroma est juste plus léger et je pense que serait plus adapté au plus grand nombre des lecteurs de ce forum. Voila vous savez tout
  13. testadaz

    Alternatives aux paquets DSM et autres...

    @InfoYann : Voici les topics de demande d'aide pleroma : https://www.nas-forum.com/forum/topic/60846-pleroma-besoin-daide-pour-linstallation/ funkwhale : http://www.nas-forum.com/forum/topic/60845-funkwhale-besoin-daide-pour-linstallation/ Merci à toi
  14. Préambule : je ne sais si ce sujet est au bon endroit, déplacez le si besoin Salut, Je cherche à installer pleroma sur mon NAS et j'aurais besoin d'aide de votre part pour mener à bien cette installation, mon but serait d'arriver à écrire un tuto pour que d'autre puissent s'y mettre. à propos de pleroma : http://pleroma.social C'est une alternative intéressante à twitter (auto hebergée; décentralisée et fonctionnant sur le protocole ActivityPub) Sur le conseils d'@InfoYANN, je suis partit sur l'installation de pleroma en version dockerisée Les infos originelles sont situées ici : https://github.com/angristan/docker-pleroma Voici les commandes lancées jusqu’ici : mkdir /volume1/web/pleroma cd /volume1/web/pleroma git clone https://github.com/angristan/docker-pleroma mv docker-pleroma/* . rm -rf docker-pleroma j'ai crée le fichier docker-compose.yml comme demandé dans le tuto en * changeant le mot de passe de postgres * changeant la version de docker-compose (premiere ligne), on remplace 2.3 par 3.1 mkdir uploads config sudo chown -R 911:911 uploads sudo docker-compose up -d postgres Cette commande retrourne une erreur car des dossiers ne sont pas crées donc mkdir /volume1/web/pleroma/postgres mkdir /volume1/web/pleroma/postgres puis docker exec -i pleroma_postgres psql -U pleroma -c "CREATE EXTENSION IF NOT EXISTS citext;" et la j’obtiens cette erreur : psql: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"? Je suis bloqué ici, je ne sais pas quoi faire pour aller plus loin. Pourriez vous m'aider ? Merci
  15. Préambule : je ne sais si ce sujet est au bon endroit, déplacez le si besoin Salut, Je cherche à installer Funkwhale sur mon NAS et j'aurais besoin d'aide de votre part pour mener à bien cette installation, mon but serait d'arriver à écrire un tuto pour que d'autre puissent s'y mettre. à propos de Funkwhale : https://join.funkwhale.audio/ ou https://funkwhale.audio/ C'est une alternative intéressante à AudioStation qui permet de partager sa bibliothèque et de faire partie d'un réseau décentralisé... J'ai suivi le "tuto" basé sur docker, mais j'ai pas mal de difficultés, probablement lié au fait que docker n'a peut-etre pas les meme droits sur les NAS syno que sur un linux standard. Je m'explique. il faut créer à la main certains dossiers qui doivent être crée automatiquement il faut adapter certains PATH Le config de nginx Lancer certaines commande avec des sudo Est ce normal ? (le détail ci dessous (qui me servira à écrire un tuto)) J'aurais besoin de votre aide sur la suite, c'est à dire la config du reverse proxy, les infos sont données ici : https://docs.funkwhale.audio/installation/index.html#reverse-proxy-setup Mais est une bonne idée d'aller modifier des fichiers dans /etc/nginx ?? Merci à vous le tuto originel est ici : https://docs.funkwhale.audio/installation/docker.html voici ce que j'ai fait en adaptant un peu : cd /volume1/docker mkdir funkwhale cd funkwhale mkdir nginx curl -L -o nginx/funkwhale.template "https://code.eliotberriot.com/funkwhale/funkwhale/raw/0.16.3/deploy/docker.nginx.template" curl -L -o nginx/funkwhale_proxy.conf "https://code.eliotberriot.com/funkwhale/funkwhale/raw/0.16.3/deploy/funkwhale_proxy.conf" curl -L -o docker-compose.yml "https://code.eliotberriot.com/funkwhale/funkwhale/raw/0.16.3/deploy/docker-compose.yml" export FUNKWHALE_VERSION="0.16.3" curl -L -o .env "https://code.eliotberriot.com/funkwhale/funkwhale/raw/0.16.3/deploy/env.prod.sample" sed -i "s/FUNKWHALE_VERSION=latest/FUNKWHALE_VERSION=$FUNKWHALE_VERSION/" .env Modification du fichier .env il faut changer * FUNKWHALE_API_PORT par exemple : FUNKWHALE_API_PORT=5678 (car le port 500 est déjà utilisé) * FUNKWHALE_URL=[METTEZ VOTRE DOMAINE] * DJANGO_ALLOWED_HOSTS=[METTEZ VOTRE DOMAINE] * DJANGO_SECRET_KEY=[METTEZ VOTRE CLEF, générée aevc 'openssl rand -base64 45' petite commande sed custom pour virer les références à /srv/funkwhale : sed -i "s/srv\/funkwhale/volume1\/docker\/funkwhale/" .env puis sudo docker-compose pull sudo docker-compose up -d postgres cette commande renvoie une erreur : ERROR: for funkwhale_postgres_1 Cannot start service postgres: Bind mount failed: '/volume1/docker/funkwhale/data/postgres' does not exists ERROR: for postgres Cannot start service postgres: Bind mount failed: '/volume1/docker/funkwhale/data/postgres' does not exists -- Pour ne plus avoir cette erreur il faut créer les dossiers manquants : mkdir /volume1/docker/funkwhale/data/ mkdir /volume1/docker/funkwhale/data/postgres puis on lance sudo docker-compose run --rm api python manage.py migrate ici encore plein d'erreurs liées au fait que les dossiers n'existent pas, il faut donc créer : mkdir /volume1/docker/funkwhale/front/ mkdir /volume1/docker/funkwhale/front/dist mkdir /volume1/docker/funkwhale/data/static mkdir /volume1/docker/funkwhale/data/media mkdir /volume1/docker/funkwhale/data/redis on relance sudo docker-compose run --rm api python manage.py migrate sudo docker-compose run --rm api python manage.py createsuperuser sudo docker-compose up -d jusque la ca va ! Si l'on va dans l'interface docker, on voit les container qui sont lancé. Mes problèmes commencent avec la config du reverse proxy : https://docs.funkwhale.audio/installation/index.html#reverse-proxy-setup pourriez vous m'aider sur cette partie ? car je ne sais pas comment faire.