This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

bpier

Membres
  • Compteur de contenus

    19
  • Inscription

  • Dernière visite

À propos de bpier

  • Rang
    Initié

Visiteurs récents du profil

Le bloc de visiteurs récents est désactivé et il n’est pas visible pour les autres utilisateurs.

  1. Merci kasimodem. Donc, le LAG n'est vraiment utile que sur le réseau local dans le cas plusieurs ordi se connectent en même temps sur le NAS.
  2. C'est la question que je vous pose et je n'y ai toujours pas répondu. J'avais en effet besoin de changer de switch pour gagner quelques ports en plus. J'en ai donc profité pour choisir un switch manageable, qui faisait LAG et j'ai retenu le Netgear GS110EMX qui embarque en outre deux ports 10Gb/5Gb/1Gb, parfaitement inutiles dans mon cas au-dessus de 1Gb : si les deux connexions LAN du 918+ acceptent au max 1Gb chacune, la Freebox Revolution que j'utilise comme routeur ne va pas au-delà de 1Gb. Bref, ne pas compter doubler sa bande passante. J'ai néanmoins décidé de créer un LAG, en choisissant sur le Syno la deuxième option, LAG dynamique, en me disant que le LAG permettrait probablement d'obtenir que le switch gère mieux le trafic en direction du site sous Wordpress hébergé sur mon NAS. Mais, pour le moment, après quelques jours d'utilisation, je ne vois aucun gain. Quels sont, de votre côté, vos retours d'expérience ?
  3. Après avoir désinstallé MailPlus Server, je le réinstalle. Motif : mon IP est désormais totalement déblacklistée de toutes les listes chez Spamhaus (après en avoir fait la demande) ; mon nom de domaine est validé et inscrit sur Google Search Console et mon site est intégré à la liste HSTS Preload. Normalement, avec tout ça, je ne devrais plus rencontrer de problèmes de blocage de mail (je l'espère), à condition bien sûr que je tienne compte de toutes les recommandations listées par alan.dub. Je vous tiendrai au courant du résultat.
  4. Je me réponds à moi-même. Les fichiers qui contenaient les headers en double étaient server.webstation-vhost.mustache et SSLProfile*, localisés dans /var/ packages/WebStation/target/misc/ Ce sont eux qui prennent la main sur /etc/nginx/nginx.conf Si ça peut être utile à d'autres.
  5. Bonjour à tous. J'essaie d'enregistrer mon site, hébergé sur mon Syno, sur hstspreload.org. Ce qui permet, une fois que c'est fait, d'être directement identifié par les navigateurs comme site https. Bien sûr, j'ai sécurisé Nginx, notamment -et c'est le sujet- en entrant des instructions en headers (add_header) dans le fichier VirtualHost.nginx.mustache et j'ai commenté (#) ceux que j'avais entrés dans le fichier /etc/nginx/conf.d/bcb*/user*. On sait qu'il n'est pas possible d'écrire dans le fichier /etc/nginx/nginx.conf, du fait justement de l'utilisation de Mustache par Synology. Et quand j'essaie d'enregistrer mon site, hébergé sur mon Syno, sur hstspreload.org, j'ai invariablement comme réponse que j'ai des headers en double. Du coup, échec. Ma question est donc : dans quel fichier nginx je dois intervenir pour virer les doublons ? Merci d'avance pour votre aide. Pierre
  6. Super Daffy ! Je vais me plonger dans cette littérature. Quant à Nginx, il gère plusieurs instances, dont Wordpress et je suppose même qu'il est multisite (j'ai pas testé). Faut juste ne rien toucher au fichier /etc/nginx/nginx.conf qui inclut entre autres les config des fichiers dms,. Synology a bien pensé son OS car tu ne peux a priori rien ajouter à ce nginx.conf : il semble protégé en écriture. Faut donc passer soit par la création d'un fichier default (pour ton site/ndd) dans /etc/nginx/sites-enable ou par le fichier user placé dans le répertoire bcb* inclus dans /etc/nginx/conf.d/ Ce que j'ai fait. En outre, tu as aussi un fichier nginx.conf spécifique à la racine du répertoire Wordpress que je n'ai pour ainsi dire pas utilisé (c'est peut-être une erreur). Nginx est un super serveur. Il existe d'ailleurs un module pagespeed que tu peux implémenter dans Nginx. Sur une Debian, je n'aurais pas redouté l'ajouter, mais, sur Syno, j'ai peur de pêter l'OS, justement parce que Nginx est un paquet stratégique de DMS. Et là, je suis moins à l'aise avec l'OS. En tout cas, merci pour ton retour. Et puis, je suis à peu près sûr que tu as raison pour les workers. EDIT : je viens de faire le test : ça plante. Nginx ne les accepte pas sur Syno. EDIT : j'ai récupéré pas mal d'optimisations proposées dans le lien https://buzut.net/optimiser-nginx/ Cool
  7. Bonjour Daffy. J'utilise beaucoup ssh et j'ai déjà pas mal configuré Nginx (pour la compression gzip, sécuriser les headers, etc.), mais je cale sur la partie mise en cache. 🙂 Voilà ma config, pour l'instant. Je ne suis pas sûr que ce soit très valable : location ~* \.(js||js2|js3|js4|css|ttf|png|jpg|jpeg|gif|svg|webp|ico|pdf|swf|html)$ { expires max; add_header Cache-Control "public, no-transform"; } location ~* \.(avi|divx|wmv|mp4|mp3)$ { expires max; add_header Cache-Control "max-age=31536000, public"; } location ~* \.(xml)$ { expires 10s; add_header Cache-Control "max-age=10, public"; } J'essaie à la fois d'optimiser le chargement de mon site et sa sécurité. Sur URI Report, j'obtiens un A en ayant désactivé (pour le moment) le Content-Security-Policy et sur GTmetrix, je m'en tire avec un A (93%) sur le PageSpeed Score mais un B (87%) sur le YSlow Score.
  8. Bonjour à tous. J'ai installé un site Wordpress (install manuelle, sans passer par le paquet Syno) sur mon 918+. Il tourne évidemment sur Web Station avec le couple Nginx/PHP7.3 Je cherche désormais à optimiser la mise en cache Nginx. J'ai fait une recherche sur le site, sans trouver mon bonheur. Sur Google, j'ai bien repéré un post de Fenrir, mais il date de 2014. Je me tourne donc vers vous car j'essaie d'éviter au maximum de recourir aux extensions Wordpress.
  9. Merci Alan.dub. Alors, je me pencherai prochainement sur ces deux tutos. Cela dit, pour le moment, tout fonctionne correctement chez moi. Pour l'instant, je me suis pas mal consacré à résoudre les soucis relatifs aux headers. Je viens de les régler. En tout cas, merci du conseil.
  10. Je réponds très tardivement à ta question. Mais, je viens moi aussi de rencontrer ce souci. La solution est là, sur le forum sécurité de Synologie et elle fonctionne : https://community.synology.com/enu/forum/1/post/122043 Je viens de l'éprouver.
  11. Alan.dub, je n'utilise pas DNS Server. J'ai juste paramétré la zone DNS de mon domaine chez mon registraire, en y mettant notamment un enregistrement MX de ma rDNS pointant vers mon nom de domaine. De mémoire, c'était nécessaire pour que l'outil Google webmaster valide la propriété de mon site.
  12. Même erreur que toi : au lieu d'attendre la fin de la propagation, j'attendais juste quelques heures. Cela dit, le problème est réglé sans passer par un relais SMTP. Ce n'est pas du tout indiqué dans le tuto de configuration de Mailplus server, présent sur le site, mais il faut renseigner la ligne SMPT Banner, , pour que le serveur SMTP fonctionne. Faute de quoi, il est inutile d'aller plus loin. Car le SMTP Banner, ce n'est rien d'autre que la reverse DNS qui est indispensable pour faire fonctionner un serveur mail perso et ne pas, par exemple, voir ses mails rejeter par Gmail. Et dans le cas des reverse DNS que Free délivre à ses abonné.e.s, et bien le SMTP Banner c'est XX-TON-IP-XX.subs.proxad.net. Attention quand on met sa propre IP : les chiffres sont séparés non pas par des points, mais par des tirets. Donc, la rDNS de Free fonctionne, encore faut-il savoir qu'il faut passer par la subs.proxad.net. Free ne documente pas l'usage de la rDNS. Mais, pas de surprise, car dès le départ, on est prévenu. Plus problématique : mon tour du net et des forums ne m'a pas permis de dénicher cette info. J'ai peut-être mal cherché. En tout cas, la voilà : la rDNS de Free fonctionne. En outre, Il existe un site qui fournit tous les outils nécessaires pour créer et tester sa configuration, il est ici https://mxtoolbox.com/NetworkTools.aspx . Dans sa doc sur Mailplus Server, Synology nous conseille d'ailleurs de l'utiliser. Ainsi, si vous n'utilisez pas la ligne de commande ou si vous n'êtes pas familiarisé à l'usage du nslookup ou du host, vous rentrez votre IP fixe dans la tool box DNS reverse lookup et, là, en cliquant sur la flèche, vous obtiendrez votre rDNS qu'il faudra alors renseigner dans la case SMTP Banner qui, je le redis, ne doit pas restée vide, sauf à ne pas de préoccuper du comportement erratique de son serveur mail sur le net. Autre point important, une fois le SMTP Banner renseigné, aller cher son registar pour créer dans sa zone DNS une entrée MX qui renvoie le sous-domaine qu'on a demandé en créant sa reverse DNS chez Free avec pour cible votre nomdedomaine immédiatement suivi d'un point après le fr ou le com. Maintenant, toutefois, je cherche le moyen d'entrer un autre serveur SMTP au cas où mon Syno planterait. Je crois, à ce sujet, qu'il est recommandé d'avoir un server SMTP de secours, pour montrer qu'on a pris les dispositions nécessaires pour que les mails parviennent bien à leurs destinataires, quoi qu'il arrive.
  13. Je me réponds tout seul : la reverse DNS que propose Free à ses abonnés est jugée comme douteuse par les moteurs anti-spams. Motif : l'IP fixe qui vous est attribuée est en fait une IP dynamique, bien que j'aie dans mon cas le contrôle de l'ensemble des ports associés. Résultat : ce n'est pas top quand on veut fonctionner avec son propre serveur mail.
  14. Bonjour à tous. Souhaitant installer Mailplus Server sur mon NAS Synology DS918+ et disposant une IP full stack chez Free, j'ai donc demandé une reverse DNS qui est désormais annoncée comme active sur interface de mon compte Free. Elle est sous cette forme machine.mondomaine.fr. Mais quand je lance la commande host sur mon IP, j'obtiens XX.MON.IP.XX.in-addr.arpa domain name pointer XX.MON.IP.XX.subs.proxad.net ! A l'inverse, quand je lance un nslookup machine.mondomaine.fr, il pointe vers mon IP fixe. En clair, cela ne me semble pas bon. Voilà pourquoi j'ai besoin de votre avis.
  15. Les conseils d'alan.dub m'ont servi. Config OK entre la Macbook, la Freebox et le NAS. Par précaution, sur le pare-feu, j'ai mis, sur la config du port 8443 (CardNAV) en IP source l'IP statique de mon Mac.