This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Brunchto

Mailstation Non Utilisable Avec Ldap

Messages recommandés

hello,

<MODE TROLL=ON>

je gratouille un peu dans mailstation pour gérer mes mails à la maison et, d'autre part, je souhaitais utiliser directory server pour réaliser l'authentification de mes postes windows (via pGina). et bien cela ne fonctionne pas... pas de liaison entre les utilisateurs LDAP et la messagerie. mailstation fonctionne pour les utilisateurs locaux.

si on ajoute une version de roundcube pas à jour, pas de sieve ou de règles routage coté serveur, pas de push ... on est vraiment light pour la messagerie :(

c'est moi qui en demande trop ou quoi?

<MODE TROLL=OFF>

bon, ben maintenant, on va refaire machine arriere et se remettre dans le domain, virer pGina, et désactiver tout le bazar. finalement, un domaine AD et un exchange, c'est plus simple à gérer ...

Partager ce message


Lien à poster
Partager sur d’autres sites

suite de mes aventures ...

j'ai créé l'utilisateur toto dans le directory server,

je m'authentifie sur mon pc via pGina avec ce user... impec, je suis reconnu sur le syno et hop, j'ai accés a mon home...

etape 2, je crée un user toto sur le syno pour la boite mail (puisque cela ne fonctionne pas pour les users du directory server)

pouf, je perds mon home, qui se retrouve branché sur le home du user tot du syno.

bon je me dis, je vais donc créer des users spéciaux mails: je mets mail_toto comme nom de compte, toto@mondomaine comme mail et zou ...

pas de bol, la boite mail du compte est bien toto_mail@mondomaine

j'ai vraiment l'impression de voir de plus en plus un assemblage de briques logicielles, sans vraiment de lien entre elles. Le dsm fait plein de truc, mais j'ai de plus en plus l'impression que ce n'est pas terminé ... ex, le package VPN ne voit pas, lui non plus, les users du directory server, même si le syno est client LDAP... alors on fait comment quand on a 200 users? on recrée les comptes?

en y reflechissant, pour mon utilisation, il faut que je fasse a l'envers: n'utiliser le directory service que pour l'authentification et créer des comptes users de base pour le stockage et les mails et les applis. mais c'est bien crado quand même, puisqu'il faut doubler les users et maintenir 2 couples de logins /mots de passe

Partager ce message


Lien à poster
Partager sur d’autres sites

oui, tu as raison, le segment de marché des synos vise l'entreprise (ou essaie de le faire) sans que le système le permette vraiment. C'est pour ça que j'ai installé zentyal (donc j'ai déjà parlé sur ce forum) : il sait faire contrôleur de domaine, le ldap est un vrai ldap utilisé par le système (et donc les comptes mail), il gère les domaines mail virtuels, tout ce qui manque au syno, quoi !

En fait, il suffirait de basculer l'authentification sur ldap pour que tout fonctionne mieux.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Brunchto,

Pour pouvoir utiliser les comptes LDAP depuis MailStation, il faut modifier le fichier de référence de dovecot qui se trouve dans /etc/pam.d/ -> dovecot.

Dans la configuration de base du Syno, ce fichier contient deux lignes :

auth sufficient /lib/security/pam_unix.so

account sufficient /lib/security/pam_unix.so

Il faut le modifier comme suit :

auth sufficient /lib/security/pam_unix.so

auth sufficient /lib/security/pam_ldap.so

account sufficient /lib/security/pam_unix.so

account sufficient /lib/security/pam_ldap.so

Tu redémarres le service MailStation (c'est peut-être même pas nécessaire !) et tu peux te connecter en utilisant le nom LDAP complet (username@ldap_domain_name genre toto@ldap.local)...

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne sais pas si ça peut encore servir mais voilà :

Pour se connecter au WebMail avec un comtpe LDAP il ne faut pas metre user / password mais user@domaine.tld / password dans roundcube.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai remarqué que je ne pouvais pas envoyer ou recevoir de mail avec les comptes LDAP via MailStation. Je pense savoir d'ou vient le problème :

Lorque l'on veut se log à MailStation avec un compte LDAP il faut rentrer comme identifiant user@domaine.tld au lieux de user pour les utilisateurs locaux. Cependant on peut quand même se log.

J'ai ensuite remarqué que si j'envoi un mail à user@domaine.tld je reçois une notification d'échec (mail Delivery Status...) indiquant que l'utisateur "user" n'a pas été trouvé dans le domaine domaine.tld. Normal car le nom d'utilisateur est user@domaine.tld (en tout cas c'est comme celà uniquement que les user en question peut se log à MailStation), il faudrait donc envoyer un mail à user@domaine.tld@domaine.tld, ce qui n'est pas permis par les clients ou bien qui est transformé en user@domaine.tld lors de l'envois (j'ai testé).

Et enfin si j'envois une message depuis roundcube avec le compte user@domaine.tld j'ai un message "Erreur SMTP (535) : Echec de l'authentification". A noter que roundcube me propose 2 adresses d'envois user@domaine.tld et user@domaine.tld@domaine.tld. Avec les 2 j'obtiens la même erreur 535.

J'ai essayé de changé le nom d'utilisateur pour la connexion au serveur SMTP dans les Préférences de roundcube une fois connecté avec un compte LDAP pour mettre user@domaine.tld au lieux de user (par défaut) mais j'obtiens toujours la même erreur...

Ma question est donc : comment faire pour que MailStation considère les utilisateurs LDAP comme des utilisateurs locaux, c'est à dire sans le @domaine.tld à la fin ? Cela fonctionne très bien pour le navigateur de fichier.

PS : pas de soucis avec l'envois/réception de mails pour les utilisateurs locaux.

Merci !

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.