This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

pfs

certificats SSL wildcard

Messages recommandés

En fait j'ai des soucis avec ce certificat que j'ai installé pour mes sous domaines et mon domaine.

le navigateur ne reconnaît pas le certificat: le certiticat de sécurité présenté par ce site web a été émis pour une autre adresse de site web.

Lorsque l'on tape le nom de domaine de son nas www.nomdedomaine.com celui dans la barre d'adresse est remplacé par https://adresseipfixedemapasserelle:port.

l'adresse ipfixedemapasserelle est un certificat de sécurité invalide. le certificat n'est valide que pour les noms suivants: *.monnomdedomaine.com et monnomdedomaine.com

si quelqu'un a une idée?

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

ben voila,c'est pas un problème de certificat, c'est un problème que ton nom de domaine redirige vers ton ip

donne moi ton nom de domaine en pv pour que je vois, ca ira + vite pour savoir ou se trouve le problème ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

bon 10 secondes et j'ai le problème :

gaetan@debian8-x86:~$ wget www.tondomaine.net
--2016-02-04 20:50:10--  http://www.tondomaine.net/
Résolution de www.tondomaine.net (www.tondomaine.net)… 217.xxx.yyy.zzz, 2001:8d8:1001:0123:4567:89ab:cdef:11
Connexion à www.tondomaine.net (www.tondomaine.net)|217.xxx.yyy.zzz|:80… connecté.
requête HTTP transmise, en attente de la réponse… 302 Found
Emplacement : https://89.xx.yy.zz:39501 [suivant]
--2016-02-04 20:50:11--  https://89.xx.yy.zz:39501/
Connexion à 89.xx.yy.zz:39501… connecté.
Le propriétaire du certificat ne correspond pas au nom d'hôte « 89.xx.yy.zz »

bon : le problème viens de ta config dns : (chez 1and1.com) tu supprime ta redirection pourrie

et à la place tu crée une entrée dns comme ceci si tu as une ip fixe :

www A 89.xx.yy.zz 

si tu as une ip dynamique, tu as deja un dyndyns surement donc, on utilise ceci :

www CNAME tondyndns.net

comme tu est chez Bouygues Telecom, je crois que ca serala solution 2

avec çà www.tondomaine.net fonctionnera

par contre, je ne pense que qu'il soit très utile de mettre la page de login de son nas en domain www, c'est l'exposer au potentiel hacker vu que c'est évidemment le sous-domaine le + scanné

voila, je crois que tu aura compris pourquoi je demande l'url en privé plutôt que de poser 10.000 questions ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites

normal que le port apparaisse, oui, si c'est pas le port standard 443, il l'ajoute 

possible de le supprimer oui aussi via un reverse proxy

3 reverse proxy possible :

apache
nginx
haproxy

le + simple je trouve est haproxy, il se trouve dans les paquet de la communauté

grace au reverse proxy, tu va associer un sous domaine à un port de son nas ou d'une autre machine de ton reseau --> tous va pouvoir passer sur les port http et https et en choisissant le bon sous domaine, tu sera regirigé sur le bon service

Partager ce message


Lien à poster
Partager sur d’autres sites

tout fonctionne avec haproxy(sympa cette application), du moins presque. j'arrive aux différentes applications (vidéo, vidéosurveillance, ..... ) par contre j'ai un petit soucis pour accéder directement à un site web(WordPress).

 

Partager ce message


Lien à poster
Partager sur d’autres sites

la manip ne marche pas. nom du sous dossier: WordPress > nom de hôte : mondomaine.net  > protocole (http et/ou https).

sur haproxy j'ai rajouter l'association suivante:  https | web | if { hdr_beg(Host) -i web.}  (j'ai essayé auparavant sans le rajout de cette association).

je tape : https://www.mondomaine.net/wordpress   aucun affichage.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ton wordpress, je suppose que tu veux l'utiliser avec le www

Donc :

Le nom d'hote doit etre www.domaine.org

Apres faudra voir avec wordpress car il aime pas qd on lui change son url

Dans la base de donnee, faut changer 2 champs dans la table option

Il y a le siteurl et une autre qui contiendra également ton url

Si ca va toujours pas, active le debut php dans le dsm, tu aura les messages d'erreurs;)

Egalement dans haproxy c'est if begin host www est pas web

Impossible pour moi de la taper correctement, je suis sur gsm ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

 je n'ai pas touché haproxy pour l'instant.

https://www.mondomaine.com/wordpress Seul le contenu sécurisé s’affiche (pas de ssl en https) et login WordPress impossible.

Je te fais parvenir le log du httpd :

(98) Address already in use : make_sock : could not bind to address [::] :80

(98) Address already in use : make_sock : could not bind to address 0.0.0 :80

 

Partager ce message


Lien à poster
Partager sur d’autres sites

tu as bien redirigé sur ton routeur les ports 80 --> 5080 et 443 --> 5443 pour passer via haproxy ? et pas changer les port par defaut de haproxy (en voyant ca, j'ai un gros doute)

le but c'est d'arriver à ceci :

client --> internet --> routeur --> haproxy --> httpd --> wordpress

 

Modifié par gaetan.cambier

Partager ce message


Lien à poster
Partager sur d’autres sites

je confirme la bonne configuration de la passerelle.

Dans le backend haproxy photo localhost 80 check et web localhost 80 check.

etc/ hosts

127.0.0.1 nas

127.0.0.1 localhost

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai réinstallé WordPress par le ftp pour passer en tls.

Je me connecte en root sur putty pour créer un virtualhost par en éditant le fichier /etc/httpd/. j'ai la permission refusé. comment gérer cette permission?

Partager ce message


Lien à poster
Partager sur d’autres sites

configuration actuelle:

file station > web > wordpress > tous mes dossiers wordpress

Hôte virtuels : wordpress  www.mondomaine.org   443

screen capture haproxy

Je tape : https://www.monnomdedomaine.org je suis renvoyé sur la page d’accueil de mon site wordpress sans ccs. (Il faut afficher tout le contenu pour que les ccs apparaissent).

Quant à l’accés à l’admin de mon site impossible :

Par le DSM, lorsque je clique sur l’icône ‘wordpress’ il me renvoi à l’url du DSM.

Par https://www.monnomdedomaine.org/wordpress/wp-admin (il me renvoi à la page de login du site mais lorsque je rentre le login et mdp, ils sont éffacés)

Si quelqu’un a une idée ?

merci

sc1_backends.png

sc2_associations.png

Partager ce message


Lien à poster
Partager sur d’autres sites

En effet j’avais oublié les espaces pour certaines conditions d’associations. Par contre j’ai toujours cette erreur principale : ‘server web’ unknown keyword 80 ou ‘server www’ unknown keyword 80. Après un petit scan netstat, je crois que le port 80 pointe extérieurement vers ip publique quickconnect ????

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, pfs a dit :

En effet j’avais oublié les espaces pour certaines conditions d’associations. Par contre j’ai toujours cette erreur principale : ‘server web’ unknown keyword 80 ou ‘server www’ unknown keyword 80. Après un petit scan netstat, je crois que le port 80 pointe extérieurement vers ip publique quickconnect ????

les espaces !!! ... en trop cette fois ci :lol:

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.