This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

[DSM 6.0.2] Nginx Basic Authentification , une aide serais apréciée svp.


jjwil

Messages recommandés

Bonjour à tous et toutes,

Ayant pour but de limiter l'accès d'un répertoire web aux seuls utilisateurs autorisés, 

je tente de mettre en place une protection de type Basic Authentification sans succès jusqu'a présent,

en admettant que l'url du serveur soit: serveur.me

que l'emplacement du repertoire web a proteger se situe sur le sino à l'emplacement suivant: /volume2/web/repertoireprotege

que l'emplacement du fichier .htaccess se trouve à l'emplacement: /volume2/web/repertoireprotege/.htaccess

je crée donc un fichier dans /etc/nginx/sites-enabled  nommé serveur.me

contenant les infos suivantes:

server{
       listen 443;
       server_name server.me;

       root /volume2/web/repertoireprotege;

       location / {
                   auth_basic "Restricted";
                   auth_basic_user_file /volume2/web/repertoireprotege/.htaccess;
                  }
       }

restart de nginx: synoservicecfg --restart nginx

test de la chose serveur.me/repertoireprotege/   et... rien, que dalle la page d'index du dit répertoire s'affiche

mais la protection ne fonctionne pas !

Aurais-je commis une erreur ? , probablement mais quoi et ou ?, comment résoudre cela ?

j'ai essayé sous le serveur apache 2 de DSM 6.0.2 du syno et là je tente sous son serveur Nginx,

là je commence doucement à ne plus voir de quel sens me tourner, ça fait deux semaines que je cherche,

Même si je stoppe web station dans le centre de paquet j'accède a mes sites allez comprendre...

soit web station a un gros mais alors très gros problème, soit il ne gère rien du tout et se fout totalement de la config.

je ne cacherai pas que l'aide ou conseils de quelqu'un de plus expérimenté que moi sur le sujet serais la bienvenue et grandement apréciée.

merçi

Correction d'après un post lu récement:

Bon d'après ce que j'en ai compris je suis à côté de la plaque, le fichier gérant les virtualhost se trouve maintenant à l'emplacement 

suivant : /var/packages/WebStation/etc/VirtualHost.json  (merci synology).

bien entendu fichier fournis sans aucune indications de configuration , ni dans le fichier lui-même, ni dans un fichier texte qui aurais pu l'accompagner,

aucune info de dispo dans knowledge base de chez synology, ni sur le forum , ni sur google (merçi, merçi synology).

alors c'est bien beau, mais vu que ce foutu fichier remplace les enciens fichiers virtualhost dans lesquels j'indiquais mes base authentification,

comment je fais maintenant avec le VirtualHost.json parce que c'est un sacré bordel dans ce fichier, rien y est détaillé, et l'écriture y est complètement différente !

edit : suppression du pêtage de plombs précédent , ça ne le fais pas trop sur un forum, désolé de m'être un poil emporté, mais bon au bout d'un moment je râle tout haut ^^.

là un ticket est en cours chez synology vu que pas de solution en vue, je continue a chercher entre-temps, et ne manquerai pas de faire un retour de la solution

dès que j'en trouverai une ou qu'un éclaircissement de synology se fasse.

histoire que cela puisse aider ceux qui pourraient se trouver dans le même cas.

cordialement

 

Modifié par jjwil
Lien vers le commentaire
Partager sur d’autres sites

bonjour,

bon apparement pour le moment, on n'est pas prêt d'avoir la solution au problème, c'est même plutôt mort.

c'est ça d'envoyer des mises à jour avant d'avoir tout testé.

enfin soit, la réponse de chez synology est pour le moment la suivante, donc reste à attendre qu'ils règle le problème, à quelle update , va savoir...

Citation

Dear Customer,

Thank you for your inquiry and please allow us reply in English.

We are so sorry but this method described in the link does not currently apply to Nginx for DSM 6. There is currently no workaround, I apologize for your inconvenience. However, I have passed this message to our developers and product management group. They will have more research on such feature. Thank you for bringing this issue to our attention. 

If you need to suggest more features, you could also submit the following form to let the PM team know your ideas:

 

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.