This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

razekiel

[Photo Station] Bad Request avec Reverse Proxy

Messages recommandés

Bonjour tous,

Après avoir suivi les tutos de @Fenrir sur la sécurisation et le reverse proxy je suis pas trop mal avancé mais j'ai un "léger" soucis avec PhotoStation.

Mes recherches sur le net ne me parviennent pas à solutionner mon soucis. Bien que ce sujet ressemble fortement à ce que j'ai.

J'ai activé un DDNS, et je souhaite accéder à Photo Station via un NDD. Du style https://photos.NDD.fr via le port 443.

  • Alors en interne, si je tape https://IPNAS/photo -> j'accède à PhotoStation OK
  • Depuis, DSM, si je clique sur l'icone PhotoStation ou depuis un réseau externe, ca lance la page https://photos.NDD.fr/photo -> la page n’aboutis et j'atterrie sur BadRequest
  • Et si je tape https://photos.NDD.fr:443/photo -> BAd request également.

Voici mes paramétrages: Reverse Proxy, Photos Station, et mon Routeur Livebox.

2018-12-01_22h14_15.png.d253400d0be520e85179c811c4d0f078.png2018-12-01_22h14_50.png.6bb06f7e374b9719194612b3cb51a5da.png

2018-12-01_22h20_03.png.bf918ce32e05976f9f3f4722f39a939f.png

Seriez vous en mesure de m'aiguiller?

Modifié par razekiel

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Il me semble que tu ne peux pas faire de reverse proxy avec Photo Station qui est un paquet au fonctionnement différent des autres. Au grand damne de beaucoup, dont moi, qui souhaitais faire comme toi.

Mais d’autres utilisateurs me corrigeront si je dis n’importe quoi.

Il te faudra donc plutôt y accéder depuis :

https://NDD.fr/photo

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Alors oui et non.

Tu as raison dans un sens mais il est vrai qu'il est possible de le faire quand même avec plus ou moins de succès. Je me souviens plus de la manipulation mais c'est un petit bazar à mettre en place.

Perso, je me suis résolu à ne pas le faire.

Modifié par Zeus

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, moi ca me pose pas de soucis d'avoir à mettre le /photo.

J'aimerais juste avoir la possibilité d'y accéder depuis un réseau externe.

Il y a 23 heures, 9re9os a dit :

Bonjour,

Il me semble que tu ne peux pas faire de reverse proxy avec Photo Station qui est un paquet au fonctionnement différent des autres. Au grand damne de beaucoup, dont moi, qui souhaitais faire comme toi.

Mais d’autres utilisateurs me corrigeront si je dis n’importe quoi.

Il te faudra donc plutôt y accéder depuis :

https://NDD.fr/photo

@9re9os, J'ai testé de cette manière. j'ai donc reparamétré PhotoStation comme ci-dessous.2018-12-02_23h04_47.png.d6e3510a3d206506bce21438a0d3e40d.png

Donc maintenant :

Depuis DSM, si je clique sur PhotoStation la connexion se déroule bien

Si je tape https://NDD.fr/photo la page de Photo Station charge bien super.

En revanche, cela ne fonctionne qu'en local... je ne parviens pas à paramétrer DSphoto sur Android ou à y accéder depuis un réseau externe... des idées?

 

Il y a 22 heures, Zeus a dit :

Bonsoir,

Alors oui et non.

Tu as raison dans un sens mais il est vrai qu'il est possible de le faire quand même avec plus ou moins de succès. Je me souviens plus de la manipulation mais c'est un petit bazar à mettre en place.

Perso, je me suis résolu à ne pas le faire.

@Zeus de ce que j'ai lu on peut tout faire avec PhotoStation mais il faut mettre les mains dedans, et je ne suis pas familier des lignes de codes ou autre.

 

Est-il possible d'utiliser PhotoStation en réseau externe exclus avec QuickConnect?

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors, contrairement à Zeus, je n'y parviens pas (encore) en https://ndd.fr/photo (mais je cherche, là) (j'ai une réponse du type "The service is disabled now)

Par contre je n'ai pas de problème via DSPhoto sur appli moblie, ni via https !

-> As-tu un site web lié à ndd.fr ?  Je demande car avant de te répondre, j'ai fait quelques essais divers (je suis en pleine config) et j'ai pu constater que si j'utilise ndd.fr avec VirtualHost & WebStation, même en appli mobile ça ne fonctionne plus. Il doit y avoir une esquive, mais ce n'est pas mon sujet actuel.

Modifié par 9re9os

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est simple, j'utilise mon nom de domaine pour différents services et même autres appareils sur mon réseau y compris des petits services web persos !

Ex:

xxx.ndd.tld amène à mon Raspberry Pi.

yyy.ndd.tld amène à un service installé via Docker

ndd.tld/photo amène à Photo Station

video.ndd.tld amène à Emby sous Docker

omv.ndd.tld amène à mon petit serveur sous openmediavault

Etc...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Zeus a dit :

Oui puisque j'ai comme lien https://ndd.fr/photo

Je te conseille dans un premier temps de mettre en application le tuto de Fenrir sur la sécurité des NAS 🙂

C'est la première chose que j'ai faite. Appliquer son tuto. C'est en suivant ces recommandations que je souhaite m'affranchir de quickconnect. 

Tout fonctionne en externe: Videostation, DSM, File station, Note... 

Mais PhotoStation ne veut pas. 

J'ai pourtant le port Https 443 ouvert sur la box. Dans le pare-feu, PhotoStation/Webstation est autorisé... 

Il y a 9 heures, 9re9os a dit :

Alors, contrairement à Zeus, je n'y parviens pas (encore) en https://ndd.fr/photo (mais je cherche, là) (j'ai une réponse du type "The service is disabled now)

Par contre je n'ai pas de problème via DSPhoto sur appli moblie, ni via https !

-> As-tu un site web lié à ndd.fr ?  Je demande car avant de te répondre, j'ai fait quelques essais divers (je suis en pleine config) et j'ai pu constater que si j'utilise ndd.fr avec VirtualHost & WebStation, même en appli mobile ça ne fonctionne plus. Il doit y avoir une esquive, mais ce n'est pas mon sujet actuel.

Non j'ai pas de site Web. 

Je fais peut être une erreur de syntaxe dans l' application PhotoStation. Vous avez inscrit quoi ? 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 5 minutes, razekiel a dit :

Je fais peut être une erreur de syntaxe dans l' application PhotoStation. Vous avez inscrit quoi ? 

Justement, rien du tout ! Si tu parles du champ : "Entrez le numéro de port du routeur pour rendre accessibles vos photos depuis les réseaux sociaux ou services internet".

Partager ce message


Lien à poster
Partager sur d’autres sites
Justement, rien du tout ! Si tu parles du champ : "Entrez le numéro de port du routeur pour rendre accessibles vos photos depuis les réseaux sociaux ou services internet".

Je fais référence à ca (cf PJ) J'ai aussi testé

ndd.fr

ndd.fr:443

ndd.fr:443/photo

 

mais j'ai un echec

f68ceeb99cae3afa2ec221ce4c1b57ff.jpg&key=ac27f08d01a6ca4d453db6550ee4a01abf36edb15da1ac56f068b216d1f6ac6e

 

Envoyé de mon CLT-L29 en utilisant Tapatalk

 

 

En effet, je n'ai rien noté non plus à l'époque sur Photo Station. Tout est géré sur DSM. A noter que Photo Station utilise par défaut les ports 80 et 443 !

 

Justement j'ai mis les ports 80/443 pour déjà tester avec ceux pas défauts... Cf Premiers posts avec mes captures. 

Au début j'étais parti sur des ports modifiés avec redirection... Mais bon..

 

Envoyé de mon CLT-L29 en utilisant Tapatalk

 

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Si mes souvenirs sont bons, tu n'as pas besoin de mettre le /photo dans DS Photo. Essaie au cas ou.
J'avais testé mais idem. Ko.

En revanche,
Je viens de tester:
ndd.fr
Https désactivé et je suis parvenu à me connecter à DSphoto depuis l'extérieur.

Par contre les nouvelles photos prises ne s'upload pas... Pourtant j'ai Désactivé le chargement par WiFi uniquement mais l'état du Transfert est sur Reconnexion...?



J'ai du coup testé aussi:
ndd.fr:443
Https désactivé mais KO

Faut il que j'active la redirection automatique de http->https dans PhotoStation ? b7a17ded6293062e3644a733de25bddf.jpg

Envoyé de mon CLT-L29 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites

Refais ta conf pour la sauvegarde auto. Re-indiques lui ton ndd.fr au lieu d'une adresse IP. Et réponds oui pour la sauvegarde en HTTPS.

Je viens de tester ce qui suit :

  • Je suis en wifi, en reseau LAN où se trouve le nas. J'ouvre DSPhoto avec ndd.fr en http. Il fait une sauvegarde.
  • Je désactive le wifi, passe en 4G, ferme l'appli DSPhoto, puis la réouvre, et me reconnecte en ndd.fr, mais en https.
  • Les sauvegardes continuent.

Donc, ça marche. Revois ta config.

Zeus et moi avons une conf poussée avec serveur DNS. Je ne sais pas si cela à un lien.

EDIT : Je n'ai pas activé de redirection HTTP -> HTTPS, ni sur photostation ni ailleurs (sauf via un .htaccess dans le dossier web, mais ça n'agit pas sur le sujet qui te préoccupes, il me semble.)

Modifié par 9re9os

Partager ce message


Lien à poster
Partager sur d’autres sites
Refais ta conf pour la sauvegarde auto. Re-indiques lui ton ndd.fr au lieu d'une adresse IP. Et réponds oui pour la sauvegarde en HTTPS.
Je viens de tester ce qui suit :
  • Je suis en wifi, en reseau LAN où se trouve le nas. J'ouvre DSPhoto avec ndd.fr en http. Il fait une sauvegarde.
  • Je désactive le wifi, passe en 4G, ferme l'appli DSPhoto, puis la réouvre, et me reconnecte en ndd.fr, mais en https.
  • Les sauvegardes continuent.
Donc, ça marche. Revois ta config.
Zeus et moi avons une conf poussée avec serveur DNS. Je ne sais pas si cela à un lien.
EDIT : Je n'ai pas activé de redirection HTTP -> HTTPS, ni sur photostation ni ailleurs (sauf via un .htaccess dans le dossier web, mais ça n'agit pas sur le sujet qui te préoccupes, il me semble.)
J'avais en effet oublié de modifier le NDD.fr dans la sauvegarde.

Donc ça fonction en local et en réseau externe. Mais uniquement en http.

Je me demande si j'ai pas un conflit.

J'ai créé un reverse proxy pour accéder au DSM via l'adresse https://NDD.fr via le port 443.
Et c'est exactement la même adresse que je renseigne dans DSphoto.

Est ce que cela peux être la cause du soucis ?
Sinon je mets une autre adresse pour accéder à DSM du style https://dsm.ndd.fr

Envoyé de mon CLT-L29 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 5 minutes, razekiel a dit :

Sinon je mets une autre adresse pour accéder à DSM du style https://dsm.ndd.fr

Oui, ça devrait fonctionner ensuite ^^

il y a 47 minutes, Zeus a dit :

Je passe par une redirection PHP et ça fonctionne aussi pour Photo Station.

(HS-ON)

puisque tu en parles, @Zeus, petite question : suffit-il de mettre le code php en index.html à la racine du dossier "web"  ou bien doit-on avoir un dossier default en particulier ou autre ?

En effet, j'ai par mégarde viré tous les fichiers/dossiers créés par l'installation du paquet webstation.

Puis, je me suis mis à faire la redirection http/s par .htaccess. Sauf que je vois un peu partout sur le forum et en fonction des allérgies des uns et des autres au htaccess, qu'il est préférable de passer par un PHP.

En htaccess ma redirection fonctionne. Je viens de la passer par PHP en virant le fichier htaccess, mais ça ne fonctionne plus. Doit me manquer un truc. Le PHP c'est un copié/collé de celui de Fenrir.

Si tu pouvais me mettre sur la piste à l'occasion... :)

(HS-OFF)

Partager ce message


Lien à poster
Partager sur d’autres sites

Voici le code que j'ai dans mon index.php

//If the HTTPS is not found to be "on"
if(!isset($_SERVER["HTTPS"]) || $_SERVER["HTTPS"] != "on")
{
    //Tell the browser to redirect to the HTTPS URL.
    header("Location: https://" . $_SERVER["HTTP_HOST"] . $_SERVER["REQUEST_URI"]);
    //Prevent the rest of the script from executing.
    exit;
}

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant