This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Zegorax

Mail Server & Web Server - Configuration De A

Messages recommandés

Hellow à toutes et à tous !
Je suis ici pour vous faire un petit tutoriel sur la configuration de MailServer, pour pouvoir recevoir vos mails et... en envoyer x) (Comme l'indique le titre :P)
Mais qu'est-ce qu'on attends ?! Commençons !
La liste des courses :
- Un Synology (Vous saviez pas ?! Moi non plus...)
- Un nom de domaine
- Internet (Sérieux ?! )
Vous avez tout ? N'oubliez pas de passer à la caisse alors :P
Pour cette démonstration, je vous ferai l'exemple avec un nom de domaine gratuit en .tk, que vous pourrez aussi utiliser pour vos futurs mails.
Premièrement, nous allons nous rendre sur http://dot.tk . Ce registar, délivre des noms de domaines gratuit, comme vous pourrez le constater. ATTENTION : Pour les malins, il ne s'agit pas de sous-domaine de type hello.fr.biz ou autre. :P
Vous arriverez donc sur cette page :
1394009061-1.png
Entrez le nom de domaine voulu dans la boîte au milieu, et cliquez sur "Go"
1394009061-2.png
Vous arriverez après dans la page d'enregistrement de votre nouveau domaine :
1394009061-3.png
Pour la configuration des DNS, nous allons utiliser CloudFlare, qui permet de faire une protection supplémentaire contre les attaques, mais aussi des redirections DNS. Donc pour cette configuration, cliquez sur "Use DNS", puis sur "Votre DNS" et insérer les valeurs suivantes :
anna.ns.cloudflare.com
ben.ns.cloudflare.com
Et mettez la valeur d'expiration à 12 mois, comme indiqué ci-dessous :
1394009061-4.png
Insérer le captcha, et cliquez sur "Sign Up" (Le gros bouton bleu :P)
Mais attention : En bas, ne sélectionnez pas "Continue without sign up" sinon, votre domaine sera configuré, mais il ne sera pas possible de le récupérer. (Vous pouvez vous logger avec un compte Google ou autre, ou alors vous enregistrer sur le site)
Pour ensuite administrer votre domaine, rendez-vous sur http://my.dot.tk . (Inutile pour le reste de ce tutoriel)
Modifié par Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites
Ceci est la suite de mon tutoriel sur le MailServer et WebStation
Maintenant que votre domaine est enregistré, rendez-vous sur http://cloudflare.com . Cette étape est très importante !
Vous arriverez ici :
1394009061-5.png
Cliquez sur "Sign Up", en haut à gauche :
1394009061-6.png
Vous arriverez sur la page d'inscription, renseignez tous les champs concernés, et cliquez sur "Create Account Now"
Vous arriverez sur une page. Vous allez maintenant entrez le nom de domaine que vous avez au préalable enregistré.
1394009062-7.png
Ensuite, une analyse des enregistrements sera effectuée.
1394009062-8.png
Attendez que l'opération se termine. Une fois fini, Cliquez sur "Continue Setup"
1394009063-9.png
Normalement, vous arriverez sur une page vous indiquant qu'il n'y a aucun enregistrement. Mais si vous en aviez avant, donc un domaine enregistré ailleurs, je vous conseille de tous les supprimer, et de les remplacer par ceux que je vais vous montrer tout de suite.
Faites exactement comme la capture d'écran ci-dessous, à une exception près. Les adresses IP (Que je vous montrerai sous forme de 1.1.1.1) devront être celle de votre routeur ! Vous pouvez récupérer votre adresse IP dans la configuration de votre routeur, ou sur http://mon-ip.com
Donc, retournons à nos moutons, et faites comme cela :
1394009063-10.png
Je vous ai encadré le choses à changer, ou les choses importantes. Précision : Lorsque vous avez fait ces redirections, le serveur pourra aussi gérer le serveur Web.
Une fois ceci fait, cliquez sur "I've added all missing records, continue >"
Quelques options s'affichent, ne modifiez rien, et cliquez sur "Continue >"
1394009063-11.png
Cliquez ensuite sur "Continue to my Websites >"
Modifié par Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites
Et voilà ! Vous êtes presque le maître du monde. Maintenant, la partie Synology / DSM !
Précision : Je suis sous le DSM 5.0, mais cela ne devrait rien changer.
Donc, allumez votre Synology, (C'est bête mais c'est comme ça :P) et loggez vous en tant qu'Administrateur.
Lancez le gestionnaire de paquets, et tapez dans la barre de recherche : "DNS Server" (Indispensable pour les enregistrements et les redirections). :
1394009063-12.png
Installez le premer, comme sur l'image. Une fois installé, lancez-le. Vous arriverez ici :
1394009064-13.png
Cliquez sur le bouton "Créer" en haut, puis "Zone master" :
1394009064-14.png
Une fenêtre de configuration va s'ouvrir, entrez votre nom de domaine et cliquez sur "OK" :
1394009064-15.png
Votre domaine sera maintenant ajouté. Faites un clic-droit sur votre nom de domaine, et cliquez sur "Enregistrement de ressource" :
1394009064-16.png
Cliquez sur "Créer" puis sur "MX Type" : (Oui vous l'avez compris, nous allons créer un miroir de CloudFlare)
1394009065-17.png
Je vous montrerai juste le MX, car il est différent à faire.
Mettez maintenant les valeurs suivantes : (Excepté le nom de domaine et laissez vide la première boîte !)
1394009065-18.png
Cliquez sur "OK" pour valider. Ensuite, mettez exactement la même chose que moi ici (Excepté le nom de domaine et les IP's) :
1394009065-19.png
PS : Pour le CNAME : L'information "www" va dans le champ "Nom canonique" (Non, pas besoin de revolver :P)
Une fois ceci fait, vous pouvez maintenant fermer DNS Server. Nous n'en auront plus besoin. ;)
Modifié par Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites
Maintenant, la partie MailServer ! Celle que vous attendiez tous avec impatience ! (Ou pas ? :P)
Lancez le gestionnaire de paquets. Dans la barre de recherche (Chez moi en haut à gauche), tapez "MailServer" :
1394009086-20.png
Ne pouvant pas le désinstaller, je vous ai fait une capture d'écran lorsqu'il l'est déjà.
Donc cliquez dessus, et installez le. Une fois installé, démarrez-le et ouvrez-le. Vous arriverez ici :
1394009087-21.png
Bien sûr, votre graphe sera vide. Allez dans l'onglet SMTP :
1394009087-22.png
Vous allez arriver sur la page de configuration. Cochez la case "Activer SMTP", vérifiez que le type de compte soit réglé sur "Utilisateurs Locaux" La case "Le nom de l'expéditeur et le nom de connexion doivent être identiques" doit aussi être cochée. Mettez votre nom de domaine dans la boîte "Nom de domaine" (Logique non ? La vie est bien faite quand même :P) et cliquez sur "OK" pour valider :
1394009087-23.png
Maintenant rendez-vous dans la section IMAP / POP3. Faites les réglages conformes à la capture d'écran ci-dessous :
1394009087-24.png
C'est tout vous pensez ? Quand il y en a plus, y'en a encore ! Et oui, maintenant, il vous faut ouvrir les ports 25, 143, 993 et 80 (Le 80 sera pour le WebMail que nous verrons après) de votre routeur et les rediriger sur le Synology pour que les mails puissent passer.
Nous allons maintenant passer à une étape EXTRÊMEMENT importante ! Votre adresse IP, jeune, joviale, et DYNAMIQUE, est pour le moment considérée comme spam sur l'ensemble des infrastructures réseaux dans le monde entier (La pauvre :( ) C'est pourquoi nous allons la débloquer grâce à SpamHaus. SpamHaus est utilisé dans le monde entier pour répertorier les adresses IP spammeuse. Donc rendez vous sur http://www.spamhaus.org/lookup/ et entrez votre adresse IP dans la boîte au centre. Si elle est bloquée, vous serez prié de suivre conformément les instructions mises à disposition. ATTENTION : SpamHaus va vous demander une adresse mail. Mettez celle que vous avez configurée sur le Synology !
Maintenant vous allez me dire : C'est bien beau... Mais comment je crée des adresses Mail ?
C'est tout simple ! Il vous suffit de créer un utilisateur dans les paramètres du Synology et l'adresse sera automatiquement créée avec le même mot de passe !
Maintenant nous allons installer un WebMail (Oui on a presque fini, vous serez bientôt le maître du monde !)
Tout d'abord, activez les services Web dans les paramètres du Synology. Ouvrez le panneau de configuration, et sélectionnez "Services Web". Une fois dedans, cochez la case "Activer WebStation" (Je ne vous fais pas de captures d'écran, car étant sous DSM 5.0, le menu a changé)
Ensuite, cliquez sur "Hôtes Virtuels" :
1394009087-25.png
Vous verrez ensuite une fenêtre. Cliquez sur "Créer" et mettez la même configuration que moi (Vérifiez que vous avez bien ouvert le port 80 dans votre routeur) :
1394009087-26.png
Si vous voulez installer un WebMail, il faudra l'installer dans le dossier "webmail" qui se trouvera normalement dans : Un lecteur partagé doit s'être créé lors de l'activation des services Web. Il se situe à la racine du Synology, en tant que dossier partagé. À l'intérieur se trouvera le dossier "webmail". Si il n'y est pas, refaites l'étape de la configuration des Hôtes Virtuel.
Maintenant, lancez encore une fois le Centre de Paquets. Tapez "WebStation" dans la barre de recherche. Premier le premier paquet :
1394010636-27.png
Une fois installé, vous pourrez vous rendre sur http://votrenomdedomaine/mail. Ou http://IPDUSYNOLOGY/mail
Pour vous logger :
Utilisateur : utilisateur (sans le @nomdedomaine !)
Et votre mot de passe
Pour ajouter un sous domaine, il vous faudra ajouter des enregistrements de type "A" partout. C'est-à-dire dans CloudFlare, et dans le DNS Server !
Maintenant, votre serveur est prêt à envoyer et recevoir des mails ! Nous allons maintenant tester. Créez-vous une adresse autre, de type Gmail. Envoyez-vous un mail à vous-même et regarder si ça passe ! Effectuez aussi le test dans l'autre sens.
MIRACLE ! Ça marche ! Si c'est le cas, c'est que vous avez bien suivi ce tutoriel ! Vous pouvez être fier de vous et maintenant allez vous la péter devant vos copains pour leur dire "Je sais configurer un serveur Mail Synology !"
En tout cas, je vous remercie de m'avoir lu, en espérant que ça vous sera utile pour la suite ! N'oubliez pas qu'un petit "J'aime" fait toujours plaisir Vous avez encore des problèmes ? Postez sur le forum et avertissez-en moi en MP, je vous répondrai le plus tôt possible :D
Cordialement, Zegorax
Modifié par Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour et un GRAND MERCI à "Zegorax" pour ce magnifique tuto.

Je l'ai suivi à la lettre et pourtant j'ai quelques petits problèmes:

- Quand je tape http://webmail.xxx.tk, je n'arrive malheureusement pas sur le webmail mais sur la page dy syno me disant de configurer mon serveur web.

Pourtant j'ai bien indiqué l'hote virtuel.... est-ce un BUG ??? (je suis aussi en DSM 5.0)

- L'autre problème concerne l'envoi des mails, rien ne part pourtant le SMTP est correctement configuré.

Mon IP n'est pourtant pas blacklisté sur "spamhaus"

Je ne comprends donc pas trop d'où pourrais venir ces problèmes.

SI vous avez une idée, je suis preneur.

Merci beaucoup

Modifié par seb773

Partager ce message


Lien à poster
Partager sur d’autres sites

- Quand je tape http://webmail.xxx.tk, je n'arrive malheureusement pas sur le webmail mais sur la page dy syno me disant de configurer mon serveur web.

Pourtant j'ai bien indiqué l'hote virtuel.... est-ce un BUG ??? (je suis aussi en DSM 5.0)

J'ai fait une découverte concernant mon premier problème quand je tape http://webmail.xxx.tk/mail/, cela fonctionne.

Il faut donc simplement ajouter le /mail à la fin de l'url.

Je n'avais finalement pas suivi à la lettre ce tuto dsl...

Modifié par seb773

Partager ce message


Lien à poster
Partager sur d’autres sites

Très bon tuto, franchement bravo!

petite précision sur le site dot.tk à un moment on rentre :

anna.ns.cloudflare.com
ben.ns.cloudflare.com

Chose que j'ai fais.

Par contre une fois sur le site de clouflare on nous recommande de corriger les DNS en :

zoe.ns.cloudflare.com

phil.ns.cloudflare.com

Chose que j'ai fais.... et magie ça ne marchait pas, du coup je suis revenus aux DNS spécifiés par Zegorax et tout est OK

Encore merci pour ce superbe tuto

PS:

une fois mon compte mail activé par exemple mikael@toto.tk, peut-on envoyé des mails en tant que mikael.pro@toto.tk sans faire un nouvel utilisateur?

J'arrive à faire un alias "mikael.pro" et quand j'utilise mon compte gmail pour envoyé un mais à "mikael.pro@toto.tk" je la reçois bien par contre quand je fais répondre ça répond avec mikael@toto.tk

Des idées ?

Je suis sous DSM 4.3

TROUVE :

il suffit de décoché "Le nom de l'expéditeur et le nom de connexion doivent être identiques" et modifier dans le webmail.

Y a t il un risque/danger à décocher cette option?

Modifié par Mike78

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour moi je ne comprends pas pourquoi l'envoi de mail ne fonctionne pas.

J'ai pourtant vérifier ma config smtp et tout semble correct.

J'ai mis en attendant le smtp de mon FAI et ça fonctionne.

Avez-vous une idée de où peut venir le problème ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello tout le monde !

Pour les DNS, je ne savais pas que CloudFlare proposait d'autres petits nom ;) Donc évidemment, il faut modifier. Par contre, il faut effectivement rajouter le /mail.

@seb

Normalement l'envoi de mail devrait fonctionner sans problème. Il se peut que aies fait une erreur dans la configuration des DNS sur le Synology. Vérifies ça et redis-moi.

Cordialement, Zegorax

Modifié par Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites

@seb

Normalement l'envoi de mail devrait fonctionner sans problème. Il se peut que aies fait une erreur dans la configuration des DNS sur le Synology. Vérifies ça et redis-moi.

Cordialement, Zegorax

Bonjour et merci pour ta réponse,

J'ai revérifier ma config dns et tout est correct.

Voilà ce que j'obtiens dans le webmail quand je veux envoyer quelquechose:

"Erreur SMTP (-1) : Echec de la connexion au serveur."

Est-ce que cela pourrais venir d'un blocage de mon FAI ? (NC)

Merci,

Séb

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai re-fait et vérifié toute la configuration "tout est correct"

Je ne comprends pas pourquoi uniquement la réception fonctionne, aucun envoi possible...

Comme mon IP n'est pas blacklisté, je suppose peut être un blocage de la part de NumeriCab...

J'ai même essayé de m'envoyer un message à moi même mais impossible toujours la même erreur.

"erreur smtp (-1) echec de la connexion au serveur"

Renseignement complémentaires:

Je ne sais pas si c'est normal mais je n'arrive pas à utiliser un client de messagerie de type outlook.

J'ai accès aux mails uniquement depuis le webmail aussi bien en interne qu'en externe.

Et mes transferts de port sont bien actifs au niveau de mon routeur.

Je ne sais pas si ces infos vous mettent sur une piste vers une solution...

PS:

Je me pose également une question supplémentaire à l'endroit où l'on rentre notre IP externe que ce passe t'il pour les personnes n'ayant pas d'IP fixe ?

Modifié par seb773

Partager ce message


Lien à poster
Partager sur d’autres sites

Hellow,

Alors, pour les personnes n'ayant pas d'IP fixe, dès que tu redémarre ton routeur, ton IP va changer (Enfin, normalement x)), donc il faut que tu remettes ton IP actualisée sur le CloudFlare, et dans les config Synology. Par contre pour ton envoi de mail, il se peut que ton FAI n'utilise pas SpamHaus... Donc il faudrait que tu leur envoie un mail pour le demander de la mettre sur leur listes d'autorisation à travers leur pare-feu. Utilises-tu un relai SMTP ?

Cordialement, Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites

Hellow,

Alors, pour les personnes n'ayant pas d'IP fixe, dès que tu redémarre ton routeur, ton IP va changer (Enfin, normalement x)), donc il faut que tu remettes ton IP actualisée sur le CloudFlare, et dans les config Synology. Par contre pour ton envoi de mail, il se peut que ton FAI n'utilise pas SpamHaus... Donc il faudrait que tu leur envoie un mail pour le demander de la mettre sur leur listes d'autorisation à travers leur pare-feu. Utilises-tu un relai SMTP ?

Cordialement, Zegorax

Hello,

Non je n'utilise pas un relais SMTP. J'ai reproduit à l'identique la configuration comme dans ton superbe tuto.

Pour remédier au problème d'envoi, j'ai ajouté dans le config du webmail le serveur SMTP de mon FAI que j'ai défini par défaut cela me permet d'envoyer des mails mais le problème ce qu'ils n'apparaissent pas dans les statistiques au niveau du NAS.

Je service clients de mon FAI est tellement mauvais que ce n'est pas la peine que je les contact pour ce problème...

Y'aurai t'il quelqu'un avec le même FAI pour qui ca fonctionne ?

En tout cas merci pour m'avoir aidé.

Mise à jour: J'ai contacté un conseiller NC par chat et voilà ce qu'il m'a dit "Il n'existe pas de smtp relais vous n'avez pas la possibilité de configurer votre serveur personnel."

Modifié par seb773

Partager ce message


Lien à poster
Partager sur d’autres sites

Ahah je suis exactement dans le même cas, j'essaie d'envoyer des choses via mail server et mail station en passant par les dns de syno. Je reçois bien le tout mais j'arrive pas à sortir :/ (je suis chez nc aussi)

Modifié par Caidezel

Partager ce message


Lien à poster
Partager sur d’autres sites

Qui sont vos FAI ?

Bonjour,

NC = NumériCable

Je pense que c'est le pire des providers à par pour la qualité de connexion.

Il est pourtant mis dans les FAI compatible dans le tuto ci-dessous:

Il semblerait malheureusement que ce ne soit plus la cas...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour a tous,

Merci pour ce tuto, mais j'ai le même problème que Seb773. Je peux recevoir mais pas envoyer (erreur smtp (-1) echec de la connexion au serveur). J'ai vérifié 4 fois et je ne vois pas ou est le problème. J'ai testé mes ports et c'est ok de ce côté également...

Moi je suis chez Free et je revérifié mon compte et je suis bien en blocage smtp inactif.

Quelqu'un a une solution ???

Pour info j'ai un IP fixe, je ne sais pas si ca change quelque chose sur le tuto.

merci pour votre aide.

Modifié par willyboy09

Partager ce message


Lien à poster
Partager sur d’autres sites

Hellow !

Alors pour les problèmes d'envois, il faudrait vraiment me donner plus d'infos... Sinon pour les IP fixes, il est même VIVEMENT conseillé d'en avoir une ! Car si votre adresse IP change, il vous faudra la modifier aussi sur CloudFlare et le DNS Server !

Cordialement, Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites

Hellow !

Oui il y a un problème ! Dans "Informations" dans la partie Synology, certains champs correspondent à Bulledebeaute et d'autres à Beaute ! Il faut faire attention à bien mettre les mêmes partout ;)

EDIT : L'adresse IP 88.100.00.00 me semble bizarre, aussi elle ne renvoie rien

Cordialement, Zegorax

Modifié par Zegorax

Partager ce message


Lien à poster
Partager sur d’autres sites

Slt Zegorax,

Désolé, tu as raison en faite je ne voulais pas mettre on ip directement mais tous les ip sont identiques dans mon dns server et dans cloudFlare.

Concernant l'adresse j'ai aussi voulu la modifier mais j'ai oublié 3 endroits... en faite il faut bien lire bulledebeaute.tk et cela partout beauté.tk n'existe pas c'est juste une retouche de li'mage que j'ai effectuée...

Désolé je te complique les choses, mais dans l'ensemble je suis sûr d'avoir rempli les cases comme tu le disais de faire

Encore merci pour ton aide

William

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce tuto est quand même vachement compliqué je trouve :D

Pour numéricable les infos pour le relais smtp sont :

smtps.numericable.fr

587

utilisateur@numericable.fr

mdpduwebmailnc

et çà fonctionne sans soucis.

Si tu n'a pas d'IP fixe tu peux juste faire une redirection DNS avec les services DDNS de dsm5 qui fait très bien ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant