This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Volume système (Root) dans NAS planté


Messages recommandés

LOL tu n'a fais peur, cas si j'avoie avoir exécuté les autres ligne que tu m'a fais passer en les adaptent bêtement cette dernière j'ai vérifier plusieurs fois cas je connaissais les conséquence. 

Pour le moment elle est toujours en cour mais c'est dommage de ne pas avoir de % sur l’avancement... en verra demain matin.

 je te drais

Lien à poster
Partager sur d’autres sites

en fait comme je ne savais pas que sda était un disque neuf, j'ai cru que tu étais entrain d'écrire sur le disque système de ton pc.

Par contre il est possible que ta commande ne se termine pas correctement (par exemple si sda est plus petit, même de quelques octets que sdb) ou que le résultat ne soit pas exploitable.

Laisse le finir et regarde si tu arrives à récupérer quelque chose sur sda (refais les commandes de diag du début), tu peux aussi tenter de le mettre directement dans le syno.

Lien à poster
Partager sur d’autres sites

C'est bon c'est enfin terminer :o)

J'ai redémarrer le live CD et garder uniquement le disque dure neuf, il y a bien les même patition il est en sda.

J'ai donc mon clone, une bonne chose

J'ai refait la porcédure de Synologie décrite dans mon premier poste

J'ai la même chose :

root@ubuntu:~# mdadm -Asf && vgchange -ay
mdadm: No arrays found in config file or automatically

J'ai aussi fais ça :

 

root@ubuntu:~# sfdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util sfdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 364801 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1          0+ 267349- 267350- 2147483647+  ee  GPT
		start: (c,h,s) expected (0,0,2) found (0,0,1)
/dev/sda2          0       -       0          0    0  Empty
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0          0    0  Empty

Disk /dev/sdf: 38913 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sdf1          0+  38913-  38914- 312568832    7  HPFS/NTFS/exFAT
/dev/sdf2          0       -       0          0    0  Empty
/dev/sdf3          0       -       0          0    0  Empty
/dev/sdf4          0       -       0          0    0  Empty

j'ai fais aussi ça :

root@ubuntu:~# mdadm --examine /dev/sd[abcdefghijklmn][1234] >> conf.raid && cat conf.raid
mdadm: No md superblock detected on /dev/sda1.
mdadm: No md superblock detected on /dev/sda2.
mdadm: No md superblock detected on /dev/sda3.

Je peux faire quoi maintenant ?

Lien à poster
Partager sur d’autres sites

L'appli "Disks" (graphique) que tu avais lancé voit elle les même partitions que sur sdb ?

  • oui => tu n'es pas plus avancé, mais au moins tu as un backup pour tenter des choses
  • non => soit la table de partition est endommagée, soit elle n'a pas été intégralement copiée par dd (il faut parfois lui dire explicitement, ça peut être fait sans tout recopier)

 Mais à première vue, je dirai que tout est dans sda1 car les autres sont à 0 => la table des partitions n'a pas été clonée.

Je n'ai jamais joué avec les tables GPT, donc je préfère ne pas m'avancer, mais tu peux essayer ça :

 

Lien à poster
Partager sur d’autres sites

ok

Tu peux maintenant tenter de réparer les erreurs, il y a plein de guide sur le net.

Je ne vais malheureusement pas être d'une grande aide pour la suite, je n'ai jamais fait ça avec un disque en gpt et encore moins avec un raid sur un disque en gpt.

Peut être que quelqu'un sur le forum aura plus d'infos

Modifié par Fenrir
Lien à poster
Partager sur d’autres sites

Bon, ce matin mon live Ubuntu était planté, impossible de le sortir de veille.

J'ai donc éteint le système et du coup essayé le clone que j'avais fais, le Syno démarre correctement mais avec un système neuf d'usine ... 

J'ai donc pas de volume, je ne sais pas comment le faire remonté ?

Dans le gestionnaire de stockage un message qui me dit que la partition système est planté, je suis entrain de réinstaller le DNS ... je croise les doigts

 

 

 

Capture.JPG

Modifié par Twin69
Lien à poster
Partager sur d’autres sites

Je crois que j'ai réussi !!!!

Avec testdisk j'ai changer de type de partition pour que ce soit une partition Linux "normal", maintenant je vois mes données ... je vais les transférer sur mon autre Syno pour pouvoir ensuite réinstaller mon RAID avec mes nouveau disque.

Merci beaucoup Fenrir d'avoir pris du temps pour m'aider.

Lien à poster
Partager sur d’autres sites

Oui c'est ce que je vais faire, ça ma servi de leçon ...

Je vais envoyer mes deux disques dur HS qui sont encore sous garantie (15 jours après et je n'avais plus de garantie) au retour je vais m'en servir pour faire des sauvegardes.

Fenrir, si tu peux m'envoyer en message priver ton adresse postale je voudrais t'envoyer un petit quelque chose en remerciement.

Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.