This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

babskwal

php et connexion base de données

Messages recommandés

Bonsoir à tous,

Difficulté en apparence toute simple, mais je n'arrive pas à trouver le problème : je n'arrive pas à me connecter à ma base mysql par mon script php, alors que ça fonctionnait à l'époque où j'avais le tout (php et base mysql sur les pages perso SFR !).

J'obtiens un " Warning: mysqli_connect(): (HY000/2002): No such file or directory in /volume1/web/locoscope/annexes/connexion-ds.php on line 2"

Dans cette line 2 se trouve

mysqli_connect('localhost', 'root', [password], '[nom_base]');

Question naÏve de débutant ? En tous cas, je ne sais pas s'il y a un problème de paramétrage sur le NAS ? Ou autre ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Oui. Sans plus de résultats.

Mais entre temps j'ai essayé avec MariaDB5 au lieu de MariaDB 10. Et ça marche ! Tant mieux, j'ai un résultat. Mais du coup je ne comprends tjs pas ça ne marchait pas avec MariaDB 10 !?

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant