This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Ced DS216+

Certaines images Wordpress m'empechent d'être full HTTPS

Messages recommandés

Bonjour, ayant longuement farfouillé en solitaire (et ayant fait sauter mon site à force de faire n'imp' !) je me tourne vers vous pour trouver une piste à suivre :

Mon wordpress est accessible depuis l'extérieur en https://monsite.synology.me, le certificat letsencrypt est présent, les navigateurs m'indiquent cependant que mon site n'est pas ENTIÈREMENT sécurisé, il y a des images qui ne le sont pas sur la page.

En effet, et c'est là ma question, sur une même page, j'ai des images avec cette adresse : https://monsite.synology.me/wordpress/wp-content/uploads/2018/07/monfichier.jpg
qui "sont donc bien" en HTTPS, mais il existe également des images avec une adresse locale en HTTP simple : http://192.168.0.12/wordpress/wp-content/uploads/2019/02/monautrefichier.gif

 

Et à cause de ça je n'ai pas accès au Graal, ce petit cadenas vert qui stipule que tout est clean.

J'ai essayé de fouiller dans wordpress, bibliotheque, médias, de changer les url, mais je sèche.
Une idée ?!

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Dans ton site wordpress tu as donc des liens erronés en  http://193.168.0.12 au lieu de http://monsite.synology.me .

Regarde dans la gestion du site si tu as l'extension "Search Regex"  sinon installe la.

Avec cette extension tu peux faire une recherche sur les pages de code et remplacer  http://193.168.0.12  par http://monsite.synology.me sur l'ensemble des pages.

Bien sûr, avant cela, fais une sauvegarde de l'ensemble du site.

 

Modifié par Jeff777

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Jeff, je fais ça dès que j'ai récupéré l'accès à mon NAS !
(En effet là, il est comme bloqué, il ne veut pas redémarrer seul (par l'option DSM redémarrer), et n'est plus accessible via windows 😞 il semble travailler à mort, en écriture de disque, et lan...)

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 23 heures, Jeff777 a dit :

 tu peux faire une recherche sur les pages de code et remplacer  http://193.168.0.12  par http://monsite.synology.me sur l'ensemble des pages.

Alors j'ai suivi ton tuyau, et le résultat est incompréhensible. Je n'"ai qu'une seule page, sur laquelle l'extension a trouvé 13 adresses à remplacer, ce qu'elle a fait, le code en témoigne. Mais lors du passage aux navigateurs de contrôlé, ayant vidé le cache, les images jpg et png sont bien avec la bonne adresse, mais les (nombreux) gif résistent encore et tjrs à l'envahisseur et affichent le 192.168.0.12 !!??

Partager ce message


Lien à poster
Partager sur d’autres sites

je pense, c'était en : Source : "Post content"

Ne puis-je pas faire une modif du htaccess pour résoudre ce nommage ?

la console m'indique ça : (image plus bas) (=contenu mixte)

J'ai bien parcouru ça : https://developer.mozilla.org/fr/docs/Sécurité/MixedContent?utm_campaign=default&utm_medium=firefox-console-errors&utm_source=mozilla
et ça https://developer.mozilla.org/en-US/docs/Web/Security/Mixed_content/How_to_fix_website_with_mixed_content
 

Mais je ne sais pas quoi faire ^^

console.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

EDIT : j'ai ENFIN trouvé : j'ai désactivé l'ensemble des extensions (inutiles !) telles qu' " Autoptimize ""hyper cach", et d'un coup ça marche nickel, c'est full sécurisé / cadenas vert !
Merci pour l'aide

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement