This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

Petit-genie

Deploiement OS par PXE - Transformer NAS en serveur de deploiement

Messages recommandés

Bonjour,

Il y a déjà eu quelques sujets sur le PXE et j'avais promis de faire un petit tuto. La différence avec d'autres méthodes est que celle-ci permet de booter sur des images WIM et de déployer des OS type windows 7. J'ai aussi récupérer les sources d' HallowMan pour booter sur des utilitaires systèmes ou de diagnostics. cf

Le tutorial était un peu trop long pour le poster tel quel donc le voici sous forme de PDF


Voici les sources nécessaires pour tester :


N’hésitez pas à faire des commentaires pour que j'améliore le tuto

 

NB : password des sources : synology

Modifié par Petit-genie

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir petit-genie,

merci beaucoup pour ce tuto fort bien fait, je suis parvenu très vite à booter en PXE sur mes PC et c'est génial!

Juste un truc qui m'a paru bizarre mais il faudrait que je re-essaie : le temps de boot pour install Windows7 x64 m'a paru bien long comparé à celui de WinPE (bien plus long que la proportion de leurs tailles de fichiers).

Merci encore,

Jean

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir petit-genie,

merci beaucoup pour ce tuto fort bien fait, je suis parvenu très vite à booter en PXE sur mes PC et c'est génial!

Juste un truc qui m'a paru bizarre mais il faudrait que je re-essaie : le temps de boot pour install Windows7 x64 m'a paru bien long comparé à celui de WinPE (bien plus long que la proportion de leurs tailles de fichiers).

Merci encore,

Jean

Le temps de boot pour install -->Que veux tu dire?Au debut tu boot en WINPE en HTTP. Ensuite depuis le WINPE tu map ton lecteur réseau et installe ton windows en CIFS. Tu parles de cela? Ou du live cd windows 7 ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Je parlais du livecd Win7x64 mais bon j'ai refait mes essais et j'ai du halluciner car ça boote super vite maintenant !

Y'a quand même un truc :-) Le boot winpexp ne marche pas chez moi; le fichier livecd/winpexp.iso n'est pas trouvé, bizarre car je n'ai pas trouvé d'erreur dans le script.

Enfin bon, tout ce qui m'interesse marche du feu de dieu!

Merci encore,

Jean

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Je parlais du livecd Win7x64 mais bon j'ai refait mes essais et j'ai du halluciner car ça boote super vite maintenant !

Y'a quand même un truc :-) Le boot winpexp ne marche pas chez moi; le fichier livecd/winpexp.iso n'est pas trouvé, bizarre car je n'ai pas trouvé d'erreur dans le script.

Enfin bon, tout ce qui m'interesse marche du feu de dieu!

Merci encore,

Jean

Mais as tu bien le fichier winpexp.iso présent dans ton répertoire web/PXE/livecd ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

l'erreur reportée esten essayant l'option "WindowsPE Boot pour Windows XP":

/livecd/winpexp.iso... No such file or directory (http://ipxe.org/2d0c613b)

Probleme survenu...lancement su shell

iPXE>

Un pb dans la hiérarchie des fichiers peut être?

Par contre ça marche pour "WindowsPE Boot pour OS 32/64 bits".

A+,

Jean

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans le fichier boot.ipxe peux tu remplacer

#### WindowsPE Boot for Windows XP
:winPExp
initrd ${boot-url}/livecd/winpexp.iso || goto failed
chain ${boot-url}/livecd/memdisk iso raw || goto failed

par

#### WindowsPE Boot for Windows XP
:winPExp
initrd livecd/winpexp.iso || goto failed
chain livecd/memdisk iso raw || goto failed

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

ça marche maintenant :-)

Bon après lors du chargement de XP, je me prends un bel écran bleu (sans doute qu'il n'aime pas mon SSD) mais pour le PXE c'est nickel.

A+,

Jean

Effectivement il y a des chances....

Bon tu devrais avoir les bases pour modifier comme tu le souhaites maintenant :)

Partager ce message


Lien à poster
Partager sur d’autres sites

très bon Tuto, merci à toi

je les lu vite fait pas encore testé mais il me semble que c'était problématique pour moi de mettre le Nas en DHCP du faite que j'ai une box Orange et que le dhcp d'orange envoie une option 77 pour la TV

Je vais me pencher sur ça quand même ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir ,

Juste pour ma culture, ça vous sert a quoi de monter une image d'os en pxe?

Tu as peut-être mal compris OS = Operating system.

Cela permet par exemple d'installer Windows sur un PC sans cle USB ou DVD mais uniquement par le réseau.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je reviens après avoir test

Pour ma part cela fonctionne

Par contre ,je suis fortement intéressé par ce sujet mais ayant du mal à trouver des tutos ou base de connaissance, j'aimerais savoir si tu aurais des liens ou mots clés pour comprendre le savoir qui t'as amené à tous configurer ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je reviens après avoir test

Pour ma part cela fonctionne

Par contre ,je suis fortement intéressé par ce sujet mais ayant du mal à trouver des tutos ou base de connaissance, j'aimerais savoir si tu aurais des liens ou mots clés pour comprendre le savoir qui t'as amené à tous configurer ?

Il n'y a pas un lien particulier car il y a plusieurs processus a comprendre derrière.Sous windows , cela se fait avec WDS et se faisait avant avec RIS donc avec ces mots tu devrais trouver ou au pire "serveur de déploiement"

Partager ce message


Lien à poster
Partager sur d’autres sites

Ils etaient valable 30 jours il me semble

Les voici

http://ovh.to/1ATZMcQ

http://ovh.to/hK6s32

les liens sont toujours valides certes mais le téléchargement du second fichier échoue vers les 95% ...

j'ai essayé a 6 reprises avec chrome et ie et le résultat est le même ... plante tout a la fin ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Franchement... ça vaut le coup !

J'ai contacté Petit-genie pour obtenir les liens de son travail sur ipxe et qu'une chose à dire: BRAVO !

Tout a fonctionné directement sur une vmware...

Un peu d'info sur ipxe: http://linuxfr.org/news/presentation-d-ipxe-un-chargeur-d-amorcage-en-pxe

Je me suis ensuite essayé à compiler moi même mon ipxe, j'ai suivi ce tuto avec un ubuntu sous vmware: https://coderwall.com/p/0sq9gg

Puis j'ai automatisé le lancement du script en faisant comme indiquer ici: http://ipxe.org/howto/chainloading

Merci Petit-genie !

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement