This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

jahwarrior

Ip Contenue Dans Mail De Notification.

Messages recommandés

Bonjour,

Tout d'abord ma config :

- nas synology 213j, DSM 4.3. 2X2to.

- 1Mac book pro et 1pc sous win8

- Fournisseur d'accés free (ip fixe)

Mon problème :

Lorsque je crée un profil utilisateur et que je lui envoi une notification par mail. L'adresse contenue dans le mail est l'adresse ip locale de mon nas, donc impossible pour lui de se connecter. Comment modifier ce paramètre ?

9076e939-1369-4124-8aa8-7fc57f39c65b.jpg

Merci par avance de l'intérêt que porterez à mon problème.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Tu peux aller ici

C'est cette partie qui t'aidera à faire se que tu veux:

Bonjour,
D'abord, si tu ne connais rien à Linux et à Telnet, je te déconseille de tenter l'aventure, car lorsque l'on est connecté sous Linux comme root, on peut effectuer des manoeuvres irréversibles qui entraineraient la réinstallation du système.
Mais si tu insistes :
- sous Windows, tu onvres une fenêtre "Invite de commandes"
- tu tapes : telnet 192.168.xxx.xxx, ceci est l'adresse LAN de ton syno, tu remplaces les xxx par les bonnes valeurs. Je suppose que tu as activé Telnet dans l'administration du syno.
- à "login" tu réponds "root" (sans les "")
- à "password" tu réponds "ton mot de passe admin du syno"

Maintenant tu es dans le système du syno, donc attention aux bêtises !!!

- tu tapes : cd /usr/syno/synoman/webman/texts/fre

Tu es alors dans le répertotre qui contient le fichier "mails"

1° Pour les habitués à Linux :

- Tu ouvres ce fichier avec l'éditeur "vi" avec la commande : vi mails

Le fichier s'ouvre et tu peux alors l'éditer, mais il faut connaître les commandes de vi qui est un éditeur très rudimentaire, je te conseille de faire une recherche sur Google (ou autre) pour "manuel vi" et de t'en imprégner !

Pour faire simple :

- tu te déplaces dans le fichier avec les flèches du clavier (pas de souris)
- tu supprimes une ligne par la commande 'dd'
- tu supprimes un caractère par la commande 'x'
- tu entres en mode insertion avec la commande 'i'
- tu en sors avec la touche 'ESC'
- tu quittes sans rien avoir modifié avec la commande ":q"
- tu quittes en abandonnant les modifrications avec la commande ":q!"
- tu quittes en sauvegardant les modifications avec la commande ":wq"

Voila, j'ai fait cela de tête, je ne crois pas m'être trompé.

2° une méthode pour les newbies

Je suppose que tu as créé un répertoire partagé sur le syno, tu prends n'importe lequel, appelons le "public"

-tu exécutes la commande : cp mails /volume1/public/mails

Ton fichier se trouve à ta disposition dans le dossier public, tu peux le modifier avec l'éditeur de ton choix sous Windows, pas n'importe lequel cependant car certains te doubleront les retours à la ligne !

une fois modifié selon ton gré, tu reviens sous telnet au point où tu en étais sur ce tuto et tu fais :

cp /volume1/public/mails /usr/syno/synoman/webman/texts/fre/mails

Ton fichier modifié est en place, n'oublie pas de le supprimer dans le dossier public

Tu quittes Telnet avec la commande "exit"

Cherche la partie [userWelcome] dans le fichier, le fichier est très grand, se que tu cherches est sur la fin!

Cordialement, 542

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

deux solutions:

1) tu as un loopback => tu te connectes avec ton ip externe, ton nom de domaine ou ton DDNS

2) tu peux de toutes façons paramétrer dans "panneau de configuration" "parametres de DSM" "port du routeur" ton ip externe, ton nom de domaine ou ton DDNS et les ports par lesquels ils seront accessibles (nom d'hôte ou ip statique)

Partager ce message


Lien à poster
Partager sur d’autres sites
2) tu peux de toutes façons paramétrer dans "panneau de configuration" "parametres de DSM" "port du routeur" ton ip externe, ton nom de domaine ou ton DDNS et les ports par lesquels ils seront accessibles (nom d'hôte ou ip statique)
Testé et approuvé. C'est la bonne méthode. Les emails contiendront deux url, une avec l'ip interne et l'autre avec l'ip externe ou le nom d'hôte que tu auras renseigné dans ce formulaire. Modifié par CoolRaoul

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

j'ai le même souci que jahwarrior et je n'ai rien trouvé de mieux ce soir, alors je déterre ces échanges :-)

l'adresse ip locale affiché dans le mail est attribuéée par la variable %hostname% que l'on peut voir dans les fichiers cd /usr/syno/synoman/webman/texts/fre

mais le hostname ne correspond pas au nom FQDN, ni au nom de la machine...

Je n'ai pas l'option dont tu parles CoolRaoul (DSM5.1) : c'est à dire pas de possiblité d'indiquer mon ip externe ou nom de domaine dans l'onglet Sécurité, qui scontient la congiguration du routeur et la config DDNS - services dont je ne me sert pas au passage, mais mon nas parle bien au monde extérieur tout de même :-)

Une idée ?


et j'oubliais : l'option Loopback que tu évoques pluton212+ , ça me parle, mais qu'à moitié ... tu pourrais éclaircir ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

j'ai une autre solution pour les notification email nouvelle utilisateur, dans DSM/panneau de config/notification/avancé/Bienvenu nouvelle utilisateur/Editer le message

remplacer la variable %HTTP_URL% par http://votre ip ou host

ca a un avantage, la modification est conservé a chaque update mais il manque encore quelque message comme celui pour re gen le password user (et malgré mes recherches je n'ai pas trouvé ou il est celui la ^^)

Modifié par devildant

Partager ce message


Lien à poster
Partager sur d’autres sites

Je conseille l utilisation de ConfigEditor un vieux spk qui permet l'édition de fichiers du syno

Ainsi on peut modifier les modèles de mail et résoudre le pb

Perso j'ai mis " En sur" dans le mal Welcome l'adresse de mon Nas

Sujet abordé sur le forum " personnalisation du message de bienvenue"

Partager ce message


Lien à poster
Partager sur d’autres sites
ca a un avantage, c'est que même c'est conserver a chaque update mais il manque encore quelque message comme celui pour re gen le password user (et malgré mes recherches je n'ai pas trouvé ou il est celui la ^^)

oui et c'est justement celui là que j'aimerai modifier ...

IL y a forcément un moyen sinon le reset de mot de passe ne peut s'effectuer qu'en local, ce qui n'est pas vraiment pratique ... :unsure:

Partager ce message


Lien à poster
Partager sur d’autres sites

oui et c'est justement celui là que j'aimerai modifier ...

IL y a forcément un moyen sinon le reset de mot de passe ne peut s'effectuer qu'en local, ce qui n'est pas vraiment pratique ... :unsure:

Il faudrait faire une request a synology ^^ je n'ai pas eu le temps de la faire, j'ai deja 3 ticket d'ouvert chez syno pour des bug par ci par la ^^ (dsm mobile et le scroll sans fin, le client ftp qui ne recup pas les homes ou encore la configuration custom des client mail dans le profile user qui ne marche pas)

Donc si tes motivé tu peux leurs faire une request :)

Partager ce message


Lien à poster
Partager sur d’autres sites

oui du nouveau au final.

C'est pas d'une grande aide (je comprends pas pourquoi ils insistent sur le wan et sur le lan sachant que justement tu peux qualifier un nom de domaine correct) , mais ça aide :

"Dear Customer,

You need to go to DS UI > Control Panel > External Access > Advance to put the URL you wish to show on Mail notification on Host/IP textbox.
However, you could only set either LAN URL or WAN URL, but not both, port number is normally 5000 and 5001.

You can only set as LAN URL or WAN URL, you could not set LAN URL to change password notification and WAN for welcome mail notification, this feature is not yet supported, we will file feature request to analysis further."

Au final je peux bien générer l'url attendu et comprendant bien l'adresse qualifiée : nas.xxx.fr par exemple

Mais le mail utilisateur indique encore également et dans le premier paragraphe l'adresse ip local du nas.

Qui ne regarde que moi en l'occurence :-)

Ce qui donne :

Dear XXXXX,
You can click the link below to reset your password:

%A6.'>https://192.168.XX.XX:5001/webman/forget_passwd.cgi?ticket=….

puis idem avec

http://nas.XXXX.fr:5000/...

et/ou selon le(s) champ(s) rempli(s) dans le panneaux de config DSM

https://nas.XXXX.fr:5001/...

Modifié par GeoGeorges

Partager ce message


Lien à poster
Partager sur d’autres sites

Perso au risque de me répéter, avec configeditor j'accède aux mails et je peux les adapter

Le mail welcomeuser le mail changepassword et y mettre mon iP en dure.

Bon a chaque maj de firmware je mets de côté mes personnalisations et je les remets ensuite.

Ça contourne les pb non ?

Désolé si je me trompe dans la compréhension de la problématique

Partager ce message


Lien à poster
Partager sur d’autres sites

Perso au risque de me répéter, avec configeditor j'accède aux mails et je peux les adapter

Le mail welcomeuser le mail changepassword et y mettre mon iP en dure.

Bon a chaque maj de firmware je mets de côté mes personnalisations et je les remets ensuite.

Ça contourne les pb non ?

Désolé si je me trompe dans la compréhension de la problématique

Bonjour daffy,

saurai tu quels est le nom du fichier qui contient le mail change password?

car le welcomeuser il peux être changé directement via DSM ce qui peux être pratique (pas besoins de le re changer a chaque maj)

concernant les autres je les set directement via putty ..fr/mails, sauf que le mail de changement de password n'y apparaît pas.

après autre truc pénible c'est que maintenant si on a une le malheur de modifier le fichier des mail on se prends une alert dans DSM comme quoi un fichier a été modif....

ps je ne suis pas trop fan de configeditor car je trouve ça un peux dangereux d'accéder au conf via l'interface web, je préfère faire mes modif a la main via ssh ^^

Modifié par devildant

Partager ce message


Lien à poster
Partager sur d’autres sites

Il y a une section userchangepassword

Concernant l'alerte de sécu il y a une option permettant de ne pas prendre en compte ce genre de chose. Oui ça baisse le niveau mais on faisait aussi sans avant...

Concernant l'utilisation de configfileeditor c'est une question de goût

Partager ce message


Lien à poster
Partager sur d’autres sites

Il y a une section userchangepassword

Concernant l'alerte de sécu il y a une option permettant de ne pas prendre en compte ce genre de chose. Oui ça baisse le niveau mais on faisait aussi sans avant...

Concernant l'utilisation de configfileeditor c'est une question de goût

merci bon je retournerai voir via putty, mais je l'avais cherché sans la trouvé ^^.

wep je sais qu'on peux le désactivé mais bon c'est pas tip top, c'est pour ça que je suis plus pour une intégration du message directement dans DSM .

je ferai un retour des que j'aurai jeté un œil, merci en tout cas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon effectivement le message de mot de passe oublié est bien dans /usr/syno/synoman/webman/texts/fre/mails, faut juste que synology l’intègre dans panneau de conf/notification/avancé

ca reste quand même un mystère pour moi, pourquoi certain message sont absent de cette interface

Partager ce message


Lien à poster
Partager sur d’autres sites

Absent quelques temps, je me repenche sur la question...

Effectivement Daffy, remplacer les variables non contrôlées par du texte "en dur" permet de contourner le problème : merci pour l'idée. Je ne connais pas configfileditor, mais je vois le principe et le testerai bien, as-tu un lien ?

Et je n'avais pas non plus trouvé le message "reset mdp", donc merci Devildant :).

Je ne suis pas en local avec mon syno donc je testerai demain via ssh.

A première vue ça règle mes problèmes, mais je suis vraiment étonné :

- de ne pas trouver comment prendre la main sur les valeurs des variables comme "%HOSTNAME%" , "%HTTP_URL%" etc ...

- que cette valeur %HOSTNAME% ne soit pas par défaut le FQDN quand il existe bel et bien

- que l'affichage dans les notifications des 2 cartes réseaux + ip locales soit automatique et non configurable. c'est un peu "amateur" lorsque l'on veut mettre cela en production.

Je relance le support syno ...

Modifié par GeoGeorges

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Je déterre ce sujet car je suis confronté au même problème, à savoir ne pas faire apparaître l'adresse IP locale du NAS dans les notifications, surtout dans l'email qui envoie un lien pour changer son mot de passe.

Partout ailleurs j'ai réussi à contourner le problème en mettant mon FQDN dans la variable %HTTP_URL%. Mais dans le cas du changement de mot de passe c'est la variable %URL% qui est utilisée  et celle-ci contient par défaut l'adresse IP locale en plus de l'autre (soit deux liens). Qu'est ce qui est passé par la tête de Synology d'imaginer que ça pouvait être une bonne idée quand le NAS possède un FQDN ?

Bref, si quelqu'un a un moyen pour paramétrer ça ou contourner le problème, je suis preneur car pour le moment j'ai dû ajouter un message indiquant à l'utilisateur externe de ne cliquer que sur le dernier lien. Mais c'est pas très pro...

Merci d'avance,

Sébastien

Modifié par sebweaver

Partager ce message


Lien à poster
Partager sur d’autres sites

Il faut personnaliser le message et au pire mettre en dur dans le mail le fqdn souhaite. Ce dernier est transforme en lien.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.