This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

CPC_Baron

Serveur Minecraft sur DS418 - Service qui arrête tout seul

Messages recommandés

Bonjour à tous,

Alors je ne sais pas si je suis au bon endroit pour poster, je suis venu ici à cause du matériel - le NAS DS418. J'ai un problème technique en rapport avec Minecraft mais je suis pas sûr que le jeu y soit pour quelque chose.

Je m'explique :  j'ai fait tout comme dit le monsieur ici : https://digitalboxweb.wordpress.com/2019/08/21/minecraft-sur-nas-synology

Mais au bout du processus, le serveur reste inaccessible et me fait l'erreur suivante : https://tof.cx/images/2020/04/13/d5cdbeea01e4028db4468f5549fa4982.png

Et quand je vérifie sur le NAS, le service "Minecraft" est toujours en cours : https://tof.cx/images/2020/04/13/e2e62b7facbcd224ef96b172b3bc3478.png

Du moins c'est comme ça que je l'interprète.

Sauf que quand je vérifie directement via SSH sur le serveur, je vois bien qu'il s'est arrêté tout seul et assez rapidement (bloqué après 3''14) : https://tof.cx/images/2020/04/13/14c04e2bf121153ddb7e558e67a8897e.png

Et en fait il fait ça à chaque fois. Quelque chose me dit que le bug est en rapport avec le service sur le NAS et j'espérais qu'un linuxien ou un maitre synologien sache détecter le problème avec le screen au-dessus.

Si je me trompe d'endroit, faut me dire, hein 🙂

Merci d'avance pour votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Tu peux jeter un oeil à syslog.log, dpkg.loge et messages déjà et exécuter la commande suivante :

cat /var/log/log_a_analyser | grep -A 25 -B 25 -i minecraft

 

Modifié par .Shad.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je sais pas si je fais ce qu'il faut. J'ai - je pense - réussi à voir les 2 premiers fichiers log mais je ne vois rien en rapport avec l'installation sur le serveur de Minecraft. J'ai regardé avec la commande "tail". Exemple avec "syslog.log" : https://tof.cx/images/2020/04/19/29017eb7831ecda5b721c404948349ce.png

Pas sûr de comprendre ce que je lis...

Et quand je tape ta dernière commande (cat /var/log/log_a_analyser | grep -A 25 -B 25 -i minecraft), il me dit "no such file or directory". Effectivement, je ne vois aucun fichier "log_a_analyser".

Merci pour ton aide.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui c'est sûr... Comme je me place en niveau 0 de connaissance linux, j'ai pas interprété ton log à analyser 😄

1ère remarque, il faut toujours que je fasse un "sudo su" sur ma session Putty pour pouvoir exécuter ce type de commande. Et une fois fait, quand je tape la commande, il ne se passe rien : https://tof.cx/images/2020/04/19/1854138e5632d427e55648e5df0908f7.png

Le service est pourtant supposer fonctionner. C'est ce que m'affiche mon interface du serveur sur le navigateur ("en cours d'execution") et j'observe effectivement que mon NAS est effectivement sollicité, a priori en permanence.

Je comprends pas ce paradoxe. Mais en même temps, je ne sais pas exploiter les fichiers du NAS pour analyser et comprendre le problème.

Partager ce message


Lien à poster
Partager sur d’autres sites

Simplement je n'ai aucune idée de quoi faire avec un package Synology dont je n'ai aucune idée du fonctionnement.
Par défaut j'évite d'utiliser des packages Tiers, je passe par Docker pour ce genre de chose, mais pas dispo sur les DS418.

Je ne pourrais que te conseiller d'acheter un Raspberry 3B+ ou mieux 4, ce n'est pas la ruine, et tu pourras faire tourner Minecraft et tout plein d'autres applications, fréquemment mises à jour, et pour lesquelles tu trouveras beaucoup plus d'informations.

Si pas, le mieux serait à mon humble avis de contacter le rédacteur du tutoriel, il saura peut-être t'indiquer où se trouvent les logs ou mieux, identifier ton problème.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 19/04/2020 à 18:37, CPC_Baron a dit :

1ère remarque, il faut toujours que je fasse un "sudo su" sur ma session Putty pour pouvoir exécuter ce type de commande. Et une fois fait, quand je tape la commande, il ne se passe rien : https://tof.cx/images/2020/04/19/1854138e5632d427e55648e5df0908f7.png

Pour être exact, il faut faire une "sudo su -" mais ce n'est pas ton problème.

Dans ton cas, il s'est bien passé quelque chose. La commande s'est terminée sans te faire de retour. Autrement dit, les fichiers de logs testés ne contiennent pas le mot "minecraft" (nb, je ne connais pas les argument -A et -B donc c'est peut-être normal).

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour votre aide. Je suis vraiment étonné qu'il n'y ait pas eu le problème plus largement signalé. J'ai même posté une demande de solution sur https://bugs.mojang.com/ mais ils m'ont renvoyé à une proposition de solution avec les ports de communication. Or je ne vois pas le rapport entre la cessation du service en plein milieu du process et des problèmes de communication...

Merci pour les conseils mais je vais glisser vers une proposition de serveur directement sur le PC, et donc non permanent 😉

Partager ce message


Lien à poster
Partager sur d’autres sites

Je continue à triturer les fichiers et ce soir, en éditant "latest.log", un "Warn" s'est ajoutée 4 secondes après les "advancements" : "Unable to find spawn biome".
Comme j'ai monté un serveur directement sur le PC de ma fille, il me semble que la différence vient de la présence du répertoire "world" mais peut-être que j'extrapole...
Les 2 sont vraiment différents donc c'est dur de juger...

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.