This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

[Résolu] Permissions droits d'accès folder pour Nextcloud


Messages recommandés

Bonjour,

J'avais envie de tester Onlyoffice.

J'essaye donc désespérément d'installer Nextcloud.... 😞

Je bute sur les droits en écriture du folder créé pour Nextcloud.

Si je configure pour qu'il utilise le répertoire web , cela fonctionne mais j'ai alors le message que d'autres utilisateurs peuvent accéder au répertoire ce qui n'a pas l'air de plaire à Nextcloud.

J'ai donc créé un shared folder Nextcloud auquel j'ai donné les droits suivants:

image.png.55233577d2681b32216f21f995b7e60b.png

Mais rien à faire, j'ai toujours le message suivant lorsque je démarre l'installation :

image.png.87febdd1eb5893dfdba17e01abd31a9e.png

Un peu d'aide serait bienvenu.

Merci.

 

Georges

Modifié par goerges
Lien à poster
Partager sur d’autres sites

Je l'ai installé manuellement.

J'ai suivi ce tuto: https://www.hebergeurcloud.com/installer-nextcloud-sur-synology-nas/

J'ai donc :

- Décompressé le .zip Nextcloud dans le folder web

- Donné tous les droits à "System" sur ce folder

- Modifié les settings PHP

-...

 

Le seul setting pour lequel j'ai un petit doute c'est open_basedir pour lequel j'ai: /tmp:/var/services/tmp:/var/services/web:/Volume1/Nextcloud

Modifié par goerges
Lien à poster
Partager sur d’autres sites

Bon, cela avance.

J'ai recommencé depuis zéro et j'ai finalement réussi à écrire dans le shared folder. J'ai tellement chipoté que je ne peux malheureusement pas expliquer où était le problème. Les droits sont restés les mêmes que dans mon premier post.

J'avais néanmoins toujours le problème au niveau "owner" des répertoires "apps".

En lançant la commande ls -l via Putty, j'ai remarqué que les propriétaires étaient http et admin.

Pour résoudre le problème, j'ai fait un chown -R http:http /var/services/web/nextcloud/apps

J'avais ensuite un problème avec CRON: 

"It was not possible to execute the cron job via CLI. The following technical errors have appeared:

Your data directory is invalid Ensure there is a file called “.ocdata” in the root of the data directory."

qui a été résolu avec:

Well, what i did to fix it was to go to Basic Settings, switch to Cron, then go back to overview, let the scan run and all went fine, then went back to Basic Settings and select AJAX back, then go back to Overview and let it run and that was it, it was fixed 😉

Finalement, j'avais aussi un message comme quoi mon serveur web était mal configuré.

La doc m'a donc indiqué qu'il fallait ajouter dans le.htaccess dans le root du serveur ces 5 lignes:

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteRule ^\.well-known/host-meta /nextcloud/public.php?service=host-meta [QSA,L]
  RewriteRule ^\.well-known/host-meta\.json /nextcloud/public.php?service=host-meta-json [QSA,L]
  RewriteRule ^\.well-known/webfinger /nextcloud/public.php?service=webfinger [QSA,L]
  RewriteRule ^\.well-known/carddav /nextcloud/remote.php/dav [R=301,L]
  RewriteRule ^\.well-known/caldav /nextcloud/remote.php/dav [R=301,L]
</IfModule>

 

Conclusion, ce Nextcloud m'a bien fait suer ! 😉

 

Lien à poster
Partager sur d’autres sites
  • goerges changed the title to [Résolu] Permissions droits d'accès folder pour Nextcloud

Je désespère, cela ne fonctionne à nouveau plus 😞

Quelqu'un peut-il me dire la signification des arguments de ce CHMOD 777:

  find /volume1/Web/nexctloud/ -type f -print0 | xargs -0 chmod 777

et aussi peut-être pourquoi l'ai un "operation is not permitted" avec cette commande bien que je la lance avec sudo ?

Merci.

Georges.

 

Lien à poster
Partager sur d’autres sites
  • goerges changed the title to Permissions droits d'accès folder pour Nextcloud
  • goerges changed the title to [Résolu] Permissions droits d'accès folder pour Nextcloud

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.