This site uses cookies! Learn More

Ce site utilise des cookies !

En continuant à utiliser ce site, vous vous engagez à nous permettre de stocker des cookies sur votre ordinateur.

 

Si nous utilisons des cookies et retenons des données anonymes, c’est pour nous aider à mieux gérer notre mesure d’audience, aider nos partenaires commerciaux à nous rémunérer et nos partenaires publicitaires à proposer des annonces qui vous correspondent.

 

Grâce à ces cookies, le forum est en mesure de savoir qui écrit un message et utile pour le système d'authentification.

 

En cliquant sur « J'accepte », vous acceptez l'utilisation par NAS-Forum de cookies publicitaires et de mesure d'audience fine.

j3r3m51

Membres
  • Compteur de contenus

    55
  • Inscription

  • Dernière visite

  • Jours gagnés

    1

j3r3m51 a gagné pour la dernière fois le 24 novembre 2017

j3r3m51 a eu le contenu le plus aimé !

À propos de j3r3m51

  • Rang
    Novice Syno

Visiteurs récents du profil

482 visualisations du profil
  1. j3r3m51

    Impossible de voir les enregistrements en HTTPS

    Personne n'a d'idée concernant cette problématique? 😲
  2. Bonjour à tous, Je rencontre un léger problème avec Surveillance Station depuis la redirection automatique HTTP->HTTPS mise en place sur mon NAS. Dans le Portail des Applications, le reverse proxy est configuré pour les applications DSM, dont Surveillance Station. En tenant compte des conseils de Fenrir sur son post très utile sur la sécurisation de son NAS, la redirection automatique HTTP->HTTPS du NAS est désactivée et j'ai mis en place ce petit script sur la page index.php de Web Station : Seulement, je ne peux plus accéder aux enregistrements effectués lorsque j'accède à Surveillance Station via https://cams.mondomaine.fr (même au sein de mon réseau local), ce qui fonctionnait avant de mettre en place la redirection automatique. Par contre, ce qui est étrange, c'est que je peux accéder aux enregistrements en LAN via l'adresse IP du NAS, sur le port 5001. Il semblerait donc qu'il y ait un soucis lors de l'utilisation du sous-domaine, mais uniquement pour l'accès aux enregistrements de Surveillance Station. Aucun problème sur les autres applications. Auriez-vous éventuellement une idée de la problématique, s'il-vous-plaît?
  3. j3r3m51

    [TUTO] Sécuriser les accès à son nas

    Merci de ton retour. Après vérification, je n'avais pas de redirection HTTPS->HTTP enclenchée. J'ai solutionné le problème en vérifiant simplement si le protocole était déjà en HTTPS avant d'effectuer la redirection, de la manière suivante :
  4. j3r3m51

    [TUTO] Sécuriser les accès à son nas

    Bonjour et merci de ce tutoriel ô combien utile ! J'ai quelques sous-domaines et ai donc configuré un proxy inversé dans le Portail des applications. Cela fonctionne parfaitement bien lorsqu'on accède directement à mes sous-domaines en HTTPS. Afin de conserver le fonctionnement de mes sous-domaines, j'ai désactivé la redirection automatique du Syno HTTP -> HTTPS et ai mis en place le petit script fourni. Le script PHP fait bien son office pour mes sous-domaines, mais plante totalement le site web hébergé. Il semble qu'un reload infini tente de s'effectuer sur celui-ci et ai ensuite bloqué par le navigateur. Erreur sous Firefox : Erreur sous Safari : J'ai essayé de modifier le nombre de redirections maximales de Firefox (en les passant de 20 à 200), mais le résultat, bien plus long à se manifester, reste malheureusement le même. Une idée de l'origine du problème ?
  5. Merci encore de cette réponse! En effet, j'y ai pensé au cours de la nuit, mes dernières règles sont inutiles et le problème se situait autre part. Dans tous les cas, ajuster les règles du pare-feu Syno et modifier la configuration du Portail des applications et du Reverse Proxy solutionnera sans le moindre doute les attaques dont il était question dans mon premier message. Merci encore! Je vais étudier ce tutoriel et vous remercie de toutes ces réponses qui furent toutes efficaces et bienveillantes.
  6. Il semblerait que je m'en sois plutôt bien sorti avec le Reverse Proxy, cela fonctionne! Ça sera néanmoins légèrement plus complexe de communiquer les identifiants de connexion à mes amis et ma famille désormais 😛 Par contre, petite demande supplémentaire. Je souhaite que l'accès à DSM ne soit pas possible en dehors de mon réseau local (via un VPN ou lorsque je suis chez moi donc). Dans Reverse Proxy, j'ai créé une règle qui pointe nas.domaine.fr vers 192.168.2.5 sur le port 5001. Dans le Pare-feu, j'ai créé une règle qui accepte les connexions sur les ports 5000 & 5001 à partir du moment où les IPs sont de la plage 192.168.x.x et une autre règle pour la plage 10.x.x.x (VPN). Cependant, j'arrive encore à me connecter à nas.domaine.fr depuis l'extérieur de mon réseau local. Qu'ai-je omis, s'il-vous-plait?
  7. Il est vrai que l'accès aux pages Web est surtout intéressant pour les personnes francophones. Mais, à brider les ports à seulement ces visiteurs, j'ai peur de ne pas pouvoir accéder à mes applications (surtout DS Cam) lorsque je suis à l'étranger, ce qui m'arrive régulièrement. Je vous remercie, je vais essayer de creuser l'utilisation du Reverse Proxy donc et reviendrai faire un bilan ici de ce que j'ai réussi à faire et comment.
  8. @meepmeep007, au temps pour moi! Je n'avais pas en tête la notion que les personnes devaient pouvoir ajouter/supprimer des photos à ces albums. Dans ce cas, la solution reste néanmoins simple. Il te suffit de créer autant de profils utilisateurs que nécessaires (non-administrateurs) via le Panneau de configuration de DSM. Dans les paramètres d'accès aux applications, limite simplement ces comptes à PhotoStation. Ensuite, tu pourras gérer ce que chaque compte aura la possibilité de faire et dans quel album, directement depuis les paramètres de PhotoStation. Il n'y a pas énormément de menus, donc tu trouveras vite comment faire ce que tu cherches! Ensuite, il suffira simplement de communiquer ton adresse QuickConnect avec les informations de PhotoStation. Tes amis pourront ainsi directement se connecter sur l'application.
  9. Voici la configuration actuelle de la redirection de ports de mon routeur : Et voici celle du pare-feu du Syno : Ce qui me donne un VPN fonctionnel et le fonctionnement des applications mobiles Synology. Retester le VPN m'a rappelé à quel point la connexion montante de mon domicile était horriblement faible... Ce qui ne donne vraiment pas envie de l'utiliser, je vous l'assure! Les ports sont maintenant filtrés par pays, mais lorsque je supprime la règle sur le port 5001, les applications mobiles ne fonctionnent plus.
  10. Merci @Mic13710! Effectivement, grosse faille de sécurité et je vous en remercie. Heureusement que je n'utilise que très exceptionnellement le VPN! J'avais arrêté l'utilisation du VPN puisque son fonctionnement était plutôt intermittent à l'époque. En effet, d'une heure sur l'autre, je ne pouvais plus forcément m'y connecter. Il était devenu plus simple d'ouvrir l'accès à DSM depuis le port 5001! Je pensais qu'imposer cette règle de refus dès le début ferait directement le tri des pays depuis lesquels je ne souhaite vraiment pas avoir de visites. Cela me paraissait plus simple que de créer des règles pour les pays autorisés. Cette règle pose vraiment problème? En modifiant les pays autorisés à se connecter aux ports HTTP et HTTPS, il faut effectivement que je pense à vérifier que le pays soit bien sélectionné avant d'y partir. Mais effectivement, c'est très certainement depuis ces ports que les tentatives ont été effectuées! Les ports 80 et 443 sont utiles pour les visiteurs du site web hébergé sur Web Station. À l'heure actuelle, mondomaine.fr mène sur ce site et les différents sous-domaines mènent directement sur les applications Synology. Je vous remercie néanmoins de ces précisions et cette proposition concernant Let's Encrypt! Effectivement, je comprends bien. À vrai dire, j'avais supprimé les règles concernant les plages IP de L2TP/IPSec en ne me souvenant plus de leur intérêt. Cela m'est vite revenu en retournant dans les réglages du Serveur VPN de Synology. J'ai finalement coché la case "Redirections des connexions HTTP vers HTTPS". 🙂
  11. Merci de ces réponses! Je n'utilise pas le Reverse Proxy, simplement car j'ai un peu de mal à en comprendre vraiment l'intérêt dans mon cas. Et surtout car la configuration est plus complexe. Dans l'onglet Applications, j'ai simplement configuré les applications qui m'intéressaient pour qu'elles écoutent les sous-domaines en question (cams.domaine.fr, videos.domaine.fr, etc...). J'ai également configuré un sous-domaine pour l'accès à DSM via Paramètres / Réseau / Paramètres de DSM / Activer un domaine personnalisé (nas.domaine.fr). Accéder à domaine.fr mène sur la page d'accueil de Web Station, nas.domaine.fr mène sur la page de connexion à DSM, cams.domaine.fr mène sur la page de connexion à Surveillance Station, etc. Cela fonctionne sans problème depuis des années, je n'ai donc pas cherché au-delà. J'ai tout de même ajouté une règle pour filtrer les pays dans le pare-feu du Syno et supprimé la redirection du port 5000 sur mon NAS. Voici donc ma configuration actuelle : Routeur - Redirection des ports DSM - Pare-feu Cependant, il est vrai qu'accéder à nas.domaine.fr semble mener sur la page de connexion à DSM en HTTP. Depuis ces petites modifications, l'application DS Cam n'arrive plus à se connecter, même après avoir tenté d'attribuer un port d'écoute à l'application et en le redirigeant. Ceci commence légèrement à sortir de mes compétences et j'en suis désolé.
  12. Salut, Dans PhotoStation, tu peux simplement partager un album au public en quelques clics. Ainsi, PhotoStation te fournit ensuite une URL que tu peux communiquer pour que les personnes puissent voir l'album en question. Petit plus, tu peux rendre cet album accessible d'une date à une autre dans les options. Ainsi, le lien ne mènera à ton album que lorsque tu l'auras prédéfini!
  13. Bonjour à tous, Depuis plusieurs années, j'ai un nom de domaine qui pointe sur le dossier web de mon Syno. De plus, j'ai créé quelques sous-domaines afin d'avoir accès rapidement accès à Audio Station, Video Station, Photo Station, Surveillance Station et Surveillance Station. Cela m'évite ainsi d'avoir recours à QuickConnect, ce qui est pour moi beaucoup plus simple à retenir et surtout, m'affiche un décalage moindre dans Surveillance Station, là où il est 10 fois plus important via QuickConnect. Cependant, depuis maintenant 2-3 mois, je suis victime d'environ une tentative de "piratage" par semaine. Par piratage, j'entends simplement des tentatives de connexion à DSM. Les comptes sont protégés par la double authentification et j'ai réglé le nombre de tentative de connexions avant bloquage IP à 2. Je pense que la personne utilise un VPN, puisque les tentatives de connexion viennent toutes de Moscou. Et ce qu'il y a sur mon NAS n'intéressera jamais Poutine, c'est certain! J'avais pensé à rediriger les ports par défaut de DSM, notamment les ports d'accès à l'interface d'administration 5000 et 5001, mais effectuer cela m'interdit ensuite l'utilisation des applications Synology sur mobile. De plus, cette solution ne serait que très temporaire puisque je pense que scanner les ports actifs du nom de domaine ne doit pas être trop complexe pour certaines personnes. J'ai bien conscience qu'utiliser QuickConnect serait une solution pour éviter cette situation, mais j'ai vraiment envie de conserver mes sous-domaines. Dans ces conditions, qu'est-il possible de mettre en place pour éviter que cela perdure? Je vous remercie par avance de vos réponses.
  14. Bonjour à vous et merci de ces précisions! Je comprends pourquoi l'auteur a souhaité supprimer ce paquet de la liste et c'est tout à fait légitime et très respectueux de sa part! Je m'étais également renseigné sur VMM, mais ça semblait plus simple sur Debian Chroot. Mon système de fichiers actuel est ext4 et VMM a absolument besoin d'un système de fichiers en btrfs... Malheureusement, la conversion ext4 <-> btrfs n'est pas proposée par Synology, bien qu'existante... Ma finalité est d'installer Jeedom sur cet OS, qui est beaucoup trop limité sur Docker (en bridge).
  15. Bonjour à tous, Je vous contacte aujourd'hui puisque je souhaiterais installer le paquet Debian Chroot sur mon DS916+. J'ai bien déclaré la source SynoCommunity et autorisé les paquets de Synology Inc et des éditeurs de confiance, seulement le paquet en question n'est pas dans la liste. J'ai également essayé en autorisant tous les éditeurs de paquets et, là également, aucun Debian Chroot à l'horizon. Le paquet semble bien exister sur GitHub, mais aucune trace non plus directement sur le site SynoCommunity. J'ai effectué un paquet de recherches, je ne suis tombé que sur des problèmes liés à l'installation du paquet, mais aucun sur cette non présence de celui-ci dans le Centre de Paquets. Auriez-vous une idée / une explication s'il-vous-plaît ? Merci d'avance ! EDIT Auto-réponse... Visiblement, l'éditeur a décidé de stopper sa diffusion suite à certaines plaintes de fonctionnement. Dommage, je me réveille quelques mois trop tard... 😕 https://github.com/SynoCommunity/spksrc/issues/3055